Garuda boot option is not opening in sway

I have just recently installed garuda sway instead of dragonized edition and i found a problem that garuda boot option is not working ,
whenever i try to open it from garuda welcome then it suddenly opens and then closes in just a millisecond , I don't know whether it is a bug or a problem in my laptop only , I reinstalled the whole system and still it is not solved so I thought to ask about it here ,

inxi -Faz


 ╭─[email protected] in ~
 ╰─λ inxi -Faz
System:    Kernel: 5.15.3-2-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule root=UUID=3d8862a3-cc90-4161-81ad-195e8064062c rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: sway 1.6.1 vt: 1 dm: N/A Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: Inspiron 7570 v: N/A serial: <superuser required> Chassis: type: 10
           serial: <superuser required>
           Mobo: Dell model: 06K08K v: A00 serial: <superuser required> UEFI: Dell v: 1.16.0 date: 02/17/2020
Battery:   ID-1: BAT0 charge: 27.0 Wh (100.0%) condition: 27.0/42.0 Wh (64.4%) volts: 12.7 min: 11.4
           model: Samsung SDI DELL CYMGM79 type: Li-ion serial: <filter> status: Full
           Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> charge: 55% (should be ignored)
           rechargeable: yes status: Discharging
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6
           model-id: 8E (142) stepping: A (10) microcode: EA cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32026
           Speed: 790 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 799 5: 800 6: 799 7: 791 8: 800
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917
           class-ID: 0300
           Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Dell driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:134d
           class-ID: 0302
           Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 1bcf:28c1
           class-ID: 0e02
           Display: wayland server: N/A compositor: sway v: 1.6.1 driver: loaded: nouveau note: n/a (using device driver)
           display-ID: 1 resolution: <missing: xdpyinfo>
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl
           bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.3-2-cacule running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: d000
           bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp2s0 state: down mac: <filter>
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 03:00.0 chip-ID: 8086:095a class-ID: 0280
           IF: wlp3s0 state: up mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:4 chip-ID: 8087:0a2a
           class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: N/A
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 bus-ID: 00:17.0
           chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:    Local Storage: total: 1.14 TiB used: 36.53 GiB (3.1%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block-size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: SDM3 scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 vendor: Micron model: 1100 SATA 256GB size: 238.47 GiB block-size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: L003 scheme: GPT
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 36.53 GiB (3.9%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1
           maj-min: 8:1
           ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 36.53 GiB (3.9%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 36.53 GiB (3.9%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 36.53 GiB (3.9%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.51 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 42.0 C pch: 43.5 C mobo: 43.0 C sodimm: SODIMM C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 258 Uptime: 10m wakeups: 4 Memory: 7.51 GiB used: 1.72 GiB (22.9%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1443 lib: 456 Shell: fish v: 3.3.1 running-in: alacritty
           inxi: 3.3.09

 ╭─[email protected] in ~ took 8s
 ╰─λ

Thanks in advance.......... :smiley:

Try from terminal

sudo garuda-boot-options

BTW, work on i3wm/PC

It didn't open just gave this :

╭─[email protected] in ~
 ╰─λ sudo garuda-boot-options
[sudo] password for ankur:
Authorization required, but no authorization protocol specified
qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

fish: Job 1, 'sudo garuda-boot-options' terminated by signal SIGABRT (Abort)

 ╭─[email protected] in ~ took 4s
[⚡] ×
1 Like
sudo garuda-boot-options
[sudo] Passwort für sgs:    
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
garuda-boot-options version: 0.1
Exec #1: "logname"
Exit #1: 0 QProcess::NormalExit
Exec #2: "mountpoint -q /live/aufs"
Exit #2: 1 QProcess::NormalExit
Exec #3: "pacman -Qq plymouth"
Exit #3: 0 QProcess::NormalExit
Exec #4: "pacman -Qq plymouth"
Exit #4: 0 QProcess::NormalExit
Exec #5: "test -z \"$(lspci -d 80ee:beef)\""
Exit #5: 0 QProcess::NormalExit
Exec #6: "df -T / |tail -n1 |awk '{print $2}'"
Exit #6: 0 QProcess::NormalExit

I think @OdiousImp will take a look :slight_smile:

1 Like

Add an -E

sudo -E garuda-boot-options

(If you wish to understand why this is a good explanation. su - Will Wayland ever support graphical sudo? - Unix & Linux Stack Exchange)

3 Likes

Thanks @OdiousImp for help,
it worked........... :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.