Garuda black screens right after clicking boot with proprietary drivers (NVIDIA) and boot with open source drivers

Hey there, I’m new to Linux. Every time I try to boot into Garuda KDE Dragonized Gaming from my USB using ventoy, Rufus, and a variety of other boot driver creators. None of it works. I get a black screen, my keyboard becomes unusable and it’s freezes everything other than the power off button.

I’m using an HP Pavilion gaming laptop.

Intel I5-8300
16gb RAM
1tb HDD

I’ve tried following multiple fix guides and nothing worked, I can’t open a terminal and I can’t for the life of me figure out how to “chroot”. Like I said I’m brand new to all this and no video installation guide talks about this problem nor can I find a solution that works for me

I’ve tried turning off safe boot, I’ve tried turning off fast boot, I made sure that it’s being boot through UEFI, rearranged the boot order so there is no interference. Still nothing. It’s been over 24 hours of trying to get this to work and I just can’t. Any form of help and newbie friendly explanation would be appreciated.

Install with open source driver and install nvidia later incl.

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ nvidia-drm.modeset=1 "/g' -i /etc/default/grub && sudo update-grub

I’ve tried that as well, nothing works, goes straight to black screen and keyboard doesn’t work, both external and laptop keyboard. I’ve also tried hitting CTRL + ALT + F2 to open a terminal and that doesn’t post anything.

Use not the gaming version and use garuda-gamer after install for gaming installs.
Or try the lts version

I currently have the non gaming version installed on ventoy and have a control iso of Nobara to test. Both non gaming and Nobara experience the same issues. May I ask what the Its version is?

We can best help if we know exactly what you have tried.
It would be stupid if you responded to all help with I have already done it.

You can also post the garuda-inxi from the live ISO.

Did you follow the installer guide?

1 Like

Check the arch wiki for compatibility with your notebook.

From live ISO Garuda Welcome app click chroot.

LTS is a kernel with long time service, the other downloads use the “gaming” Zen kernel.

A quick summary of what I’ve tried:

  • read and followed the installation guide
  • found that black screen happened
  • tried CTRL + ALT + F2 to open the console to update garuda and see if that was the issue (not successful)
  • Tried the non gaming varient to see if that was the issue
  • tried nobara to check if it was just Garuda. (same thing happened)
  • Tried following the chroot guide to see if something was amiss, couldn’t figure out how to open the console to do commands
  • tried searching for a solution on youtube, no avail
  • tried re burning the iso on flash, same issues applied
  • turned off safe boot, turned off fast boot, made sure no intel safe guards were interfering
  • almost every post mentioning the same issue gets sent to another link which I tried to follow but couldn’t.

Thank you for your time so far, I’m just really confused as I’m trying to follow every beginning step, and most fixes that I can access. Could it be that I have to edit the boot parameters to get a safer boot option? nomodeset perhaps? but to be honest I’m very unfamiliar with most of this stuff so trying to fix something without understanding most of the lingo is tricky to say the least.

from what I can tell it’s in a boot loop under the black screen, or it can’t seem to either find or use my graphics card to boot up a graphical interface? I’m guessing and checking at the current moment.

This is what I find after checking the arch wiki HP Pavilion 15-cx0xxx - ArchWiki

You are not even making it to the live environment to do the installation, is that right? Or is this after the installation?

It is secure boot which must be disabled. This is from the ArchWiki article you linked:

You have to disable Secure Boot. repeatedly press F10 during boot to bring up the BIOS setup, navigate to the boot section and disable Secure Boot.

To prevent the system from booting in Legacy mode, i also recommend to disable CSM/Legacy mode

Post some of the links you have found which seem similar. Even if they have dead links in them, it may be a clue for someone else in the community.

If you have not tried another USB stick yet, you really should. Even if you have to go out and buy one, it is worth it I think because sometimes a given USB stick will just not work as boot media for no reason.

1 Like

I’m not making it to the live environment, not even close

I didn’t think of that, I’ll try that next after work tomorrow. The USB I’m using is one that I’ve used to boot a linux install a while ago, and multiple windows installs as well. Maybe it just doesn’t have it in it anymore?

Maybe makesure in your BIOS that the SATA controller is set to AHCI as opposed to RAID or similar.


To prevent the system from booting in Legacy mode, i also recommend to disable CSM/Legacy mode

7 Secure Boot

Secure Boot, if set properly works with GRUB and shim.

It works, but UEFI is an absolute mess so I would not recommend anyone getting too deep


I have a new USB stick and flashed it, still doesn’t work. Should I completely erase windows before trying to boot?

That’s up to you, it is unlikely to fix the issue though.

You need to make sure you are doing all of these suggestions from the ArchWiki in the BIOS:

  • Disable secure boot (this is different than safe boot or fast boot). If you don’t see a way to disable it you may need to wipe the keys first.
  • Set an administrator password in the BIOS.
  • Change the boot priority so the USB drive is first. Setting the administrator password needs to be done before this.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.