Garuda black screen after grub

When I start my PC, the GRUB will load like normal but after that it will say

 Booting 'Garuda'

Loading kernel linux-zen . . .
Loading Initial ramdisk . . .

Then it will be a black screen and nothing else. Wont take me into login screen or anything.
I dont know if i am being dumb and it is a easy fix but it just started doing that.
It has always have worked fine before this.

Hi there, welcome to the community.

Did you install an update recently? Try booting into most recent working snapshot.


You can also boot into a console, press ctrl+alt+f4 , try differentf keys. Look at system logs.


In general, in these cases, you could try to follow this tutorial:


I think I did do a small update the Syu one. But nothing major

When I did the snapshot it will do the same thing. Say its booting that imminently black screen.

Sorry if the question may seem trivial: did you use the latest snapshot before the problem arose (like two days ago)?
I would not like that by sudo pacman -Syu you generated a new snapshot (with the problem still inside) and maybe you tried after the restore, and used this latest snapshot?
It would then be useful to know your detailed specifications.
With a live USB, you could provide the output of inxi -Faz as text, formatted with 3 ~ before and after the text block.


I started using the snapshots after the errors.

I updated my computer than after a couple of hours my entire screen froze but my audio and other stuff was working just the screen. So I shut it down then next time I tried to boot it up, the errors started happening. So I tried a snapshot then it wont do anything.

That is pretty much the story.

Specs: Nvidia GPU
Intel CPU

Did you do any of what you were advised to do to fix the problem?
Have you tried all snapshots?
If that doesn't help, boot the machine with an ISO and follow the black screen help by Jonathon.