Garuda Assistant not working in a VM

well .... finished testing the kde dragonized iso on a VM.

Seems there are some new applets on the latte-dock :slight_smile:

Well, everything worked well, installed, and running nicelly.

But then I went into Garuda Assistant, and tried changing some settings, because there were some issues there in the previous ISO. This time.... I changed some settings ( just to test, for example adding firewalld or uresourced and irqbalance ) ... clicked "apply", and nothing happened, with the previous settings getting back enabled after 1 or 2 seconds.

Can anyone test this ? its a VM, with normal install ( use all new disk ).

Do you have a working pacman? Try running update first.

The behavior you are describing sounds like what happens if you try to use it from the ISO where you have no pacman databases sync'd for the first time.

Yeah, I do !! I just ran pacman -Syu and update ... and retried.

give me a few seconds ( 10 years ).... I will try to do a video and upload it to youtube

@dalto -> video: 2021 09 27 03 03 31 - YouTube

It works fine here, I can't replicate what you are seeing.

What happens if you try to install software manually?

for example, I installed firewalld ( pacman -S firewalld ) and now its selected on garuda assistant ( upon restart of garuda assistant )

@dalto ....

OK , so I put my sherlock holmes hat, and got investigating.

Found out what was the issue: It was because of VirtualBox VMSVGA with 3D accel. It was breaking the creation of the terminal and kdesu windows.

I disabled the 3D Accel and now the windows appear.

Sorry for the lame bug drama ! :frowning: my bad

1 Like

Ah, it is probably because alacritty is 3d accelerated.

It must be that, ... in journalctl there was a vmsvga error , which made me think ( I don't usually think, but that made me ).

Sorry .. its just that its so "unnoticeable" that I didn't think right away about that ( the 3d driver on VB )

I more or less won't use virtualbox anymore. Both vmware and kvm/qemu-based solutions work so much better.

vmware = closed source = no :slight_smile: and kvm/qemu I use when is anything serious. When is just to test something, VB does it. :slight_smile: I guess the 3d was even fast, but has some issues ( which its strange, since as shown in the video, was doing kwin animations and blurs nicelly )

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.