Garuda-assistant bug? - Missing icons on button

Hello, after the update, all the icons on the buttons in Garuda Assistant disappeared

Which DE/WM are you using?

2 Likes

No inxi -Faz

:grimacing:

1 Like
System:
  Kernel: 5.13.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
  root=UUID=25bdb391-e52a-4575-8f27-23aa4b24a0c0 rw [email protected] quiet 
  splash pcie_aspm=off rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 loglevel=3 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Garuda Linux base: Arch Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: GA-A55M-S2V serial: <filter> 
  BIOS: Award v: F2 date: 07/08/2011 
CPU:
  Info: Quad Core model: AMD Athlon II X4 631 bits: 64 type: MCP 
  arch: Fusion family: 12 (18) model-id: 1 stepping: 0 microcode: 3000027 
  cache: L2: 4 MiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 20798 
  Speed: 802 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 802 2: 803 
  3: 808 4: 2265 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: Micro-Star MSI 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1d01 class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: gnome-shell driver: 
  loaded: nvidia display-ID: :1 screens: 1 
  Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 445x278mm (17.5x10.9") 
  s-diag: 525mm (20.7") 
  Monitor-1: HDMI-0 res: 1680x1050 hz: 60 dpi: 90 
  size: 474x296mm (18.7x11.7") diag: 559mm (22") 
  OpenGL: renderer: NVIDIA GeForce GT 1030/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:
  Device-1: AMD FCH Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel 
  bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403 
  Device-2: NVIDIA GP108 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb8 
  class-ID: 0403 
  Device-3: Creative Labs EMU10k2/CA0100/CA0102/CA10200 [Sound Blaster 
  Audigy Series] 
  driver: snd_emu10k1 v: kernel bus-ID: 03:06.0 chip-ID: 1102:0004 
  class-ID: 0401 
  Sound Server-1: ALSA v: k5.13.12-zen1-1-zen running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: no 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8168 v: 8.048.03-NAPI modules: r8169 port: ee00 
  bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Bluetooth:
  Device-1: Conwise CW6622 type: USB driver: btusb v: 0.8 bus-ID: 4-3.3:5 
  chip-ID: 0e5e:6622 class-ID: e001 
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
Drives:
  Local Storage: total: 1.47 TiB used: 562.77 GiB (37.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD10EZEX-22MFCA0 size: 931.51 GiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> 
  rev: 1A01 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 model: SATA SSD size: 111.79 GiB block-size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> 
  rev: 61.2 scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital 
  model: WD5000AAKX-001CA0 size: 465.76 GiB block-size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 1H15 
  scheme: MBR 
Partition:
  ID-1: / raw-size: 94.46 GiB size: 94.46 GiB (100.00%) 
  used: 56.19 GiB (59.5%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17 
  ID-2: /home raw-size: 233.02 GiB size: 228.36 GiB (98.00%) 
  used: 206.95 GiB (90.6%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  ID-3: /var/log raw-size: 94.46 GiB size: 94.46 GiB (100.00%) 
  used: 56.19 GiB (59.5%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17 
  ID-4: /var/tmp raw-size: 94.46 GiB size: 94.46 GiB (100.00%) 
  used: 56.19 GiB (59.5%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17 
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
  ID-1: swap-1 type: zram size: 7.76 GiB used: 512 KiB (0.0%) priority: 100 
  dev: /dev/zram0 
Sensors:
  System Temperatures: cpu: 92.0 C mobo: 48.0 C gpu: nvidia temp: 55 C 
  Fan Speeds (RPM): cpu: 1173 mobo: 675000 fan-1: 1824 fan-3: gpu: nvidia 
  fan: 41% 
  Power: 12v: N/A 5v: 2.96 3.3v: N/A vbat: 3.30 
Info:
  Processes: 300 Uptime: 3h 56m wakeups: 0 Memory: 7.76 GiB 
  used: 4.38 GiB (56.4%) Init: systemd v: 249 tool: systemctl Compilers: 
  gcc: 11.1.0 clang: 12.0.1 Packages: apt: 0 pacman: 1679 lib: 503 
  flatpak: 0 Shell: fish v: 3.3.1 running-in: gnome-terminal inxi: 3.3.06 

1 Like

Yes.
This thing happens in gnome with me as well all the time.
Btw when I was playing with gnome-barebones, I was trying adding garuda's icons and themes.
And in that assistant got some icons but some were missing there as well. (I don't know what caused them to appear in assistant)

But in the official gnome version there are no icons at all.
:thinking:

Gnome 40.4 Mutter (GDM)

For the missing icons in barebones, do you have qt5-svg installed?

3 Likes

I meant to say I got some icons on barebones (dont know how) but can't get them in official release.

I understand. I am saying you can probably get the rest by installing qt5-svg

Hmm. but that's in the barebones what about the normal gnome ( which is the actual issue btw )
:thinking:

It is being investigated. It seems to be a conflict between the assistant and qt5ct

2 Likes

I think we found the source of the issue. Can someone else who is impacted try this?

Open up kvantum manager, edit the current theme and uncheck this button?

3 Likes

Works, great, :slight_smile:

2 Likes

This is not a solution, the checkbox is not available

Can you try going into qt5ct and temporarily changing away from kvantum and see if that fixes it? That will let us know if the problem is in kvantum or somewhere else.

You will probably need to re-launch the app after you make the change.

1 Like

Yes, but it's hard to call it a solution. And it doesn't look like it was ever intended that way. am I right?

It wasn't intended to be a solution. It was just a troubleshooting step. Now we know that some setting in kvantum is causing the problem.

I was using the i3 version(which had the same issue) to test. I am installing the gnome version now.

3 Likes

For gnome, you need to uncheck this one:

4 Likes

Good!

1 Like

A small question in the end. Will all your applications be localized depending on the system language?