Garuda applications and xcb that fails to connect to the display

Hey there,
I have yet another problem: Whenever I run garuda-boot-options or btrfs-assistant I get this error:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

fish: Job 1, 'pkexec garuda-boot-options' terminated by signal SIGABRT (Abort)

I have tried tried multiple things: First of all I tried running it with DISPLAY=:0, and then I tried running the program in a nested wayland window and after that I even tried reinstalling the programs as the error suggests. Following that I tried debugging using QT_DEBUG_PLUGINS=1 and installed all the plugins that were missing but all of my attempts including reinstalling xcb failed.
The debug output: https://termbin.com/d86n

This xcb error is by far the worst as seemingly nothing works...
What is the problem here?
Thanks!

inxi -Fart because it actually works XD
System:
  Host: lolcat Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 compiler: gcc
    v: 11.1.0 parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6e6211b4-cfb4-44c0-8970-5e4a826e0c5e rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 2 dm: Ly Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F50a
    date: 11/27/2019
CPU:
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 4074 high: 4161 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3918 2: 3983
    3: 4131 4: 4128 5: 4161 6: 4124 7: 3833 8: 4062 9: 4151 10: 4134 11: 4141
    12: 4133 bogomips: 86226
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Baffin [Radeon RX 550 640SP / RX 560/560X] vendor: ASUSTeK
    driver: amdgpu v: kernel bus-ID: 08:00.0 chip-ID: 1002:67ff class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 3-3:5 chip-ID: 046d:0825 class-ID: 0102 serial: 248009E0
  Display: server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3600x1200 s-dpi: 96 s-size: 952x317mm (37.5x12.5")
    s-diag: 1003mm (39.5")
  Monitor-1: HDMI-A-0 res: 1680x1050 hz: 60 dpi: 90
    size: 474x296mm (18.7x11.7") diag: 559mm (22")
  Monitor-2: DVI-D-0 res: 1920x1200 hz: 60 dpi: 99
    size: 495x310mm (19.5x12.2") diag: 584mm (23")
  OpenGL: renderer: AMD Radeon RX 560 Series (POLARIS11 DRM 3.42.0
    5.15.12-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.2 direct render: Yes
Audio:
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 08:00.1
    chip-ID: 1002:aae0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media USB Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.4:6 chip-ID: 0d8c:9700
    class-ID: 0300 serial: 201605
  Device-4: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 3-3:5 chip-ID: 046d:0825 class-ID: 0102 serial: 248009E0
  Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel port: f000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: e0:d5:5e:4f:57:57
Bluetooth:
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
    bus-ID: 3-1.1:4 chip-ID: 0a5c:21e8 class-ID: fe01 serial: 5CF3708E8F4F
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up
    address: 5C:F3:70:8E:8F:4F
Drives:
  Local Storage: total: 2.96 TiB used: 1002 GiB (33.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: S4CSNX0N713306T rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: S3YJNX0K332437P rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
    serial: WD-WCC4M1ZHTZTK rev: 0A82 scheme: GPT
Partition:
  ID-1: / raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 32.56 GiB (16.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 736.18 GiB size: 736.18 GiB (100.00%)
    used: 137.18 GiB (18.6%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 32.56 GiB (16.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 32.56 GiB (16.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.36 GiB used: 5 MiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 33.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1431
Repos:
  Packages: apt: 0 pacman: 2014 lib: 483
  Active pacman repo servers in: /etc/pacman.d/chaotic-mirrorlist
    1: https://geo-mirror.chaotic.cx/$repo/$arch
    2: https://cdn-mirror.chaotic.cx/$repo/$arch
    3: https://us-ut-mirror.chaotic.cx/$repo/$arch
    4: https://us-ca-mirror.chaotic.cx/$repo/$arch
    5: https://es-mirror.chaotic.cx/$repo/$arch
    6: https://es-2-mirror.chaotic.cx/$repo/$arch
    7: https://de-mirror.chaotic.cx/$repo/$arch
    8: https://de-2-mirror.chaotic.cx/$repo/$arch
    9: https://de-3-mirror.chaotic.cx/$repo/$arch
    10: https://de-4-mirror.chaotic.cx/$repo/$arch
    11: https://be-bru-mirror.chaotic.cx/$repo/$arch
    12: https://fr-mirror.chaotic.cx/$repo/$arch
    13: https://br-mirror.chaotic.cx/$repo/$arch
    14: https://kr-mirror.chaotic.cx/$repo/$arch
    15: https://bg-mirror.chaotic.cx/$repo/$arch
    16: https://ca-mirror.chaotic.cx/$repo/$arch
    17: https://in-mirror.chaotic.cx/$repo/$arch
    18: https://in-2-mirror.chaotic.cx/$repo/$arch
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
    1: https://mirror.chaoticum.net/arch/$repo/os/$arch
    2: https://mirror.cyberbits.eu/archlinux/$repo/os/$arch
    3: https://phinau.de/arch/$repo/os/$arch
    4: https://archlinux.mailtunnel.eu/$repo/os/$arch
    5: https://archlinux.thaller.ws/$repo/os/$arch
Processes:
  CPU top: 5 of 381
  1: cpu: 11.7% command: firefox pid: 8091 mem: 699.0 MiB (2.1%)
  2: cpu: 10.5% command: firefox pid: 9196 mem: 163.8 MiB (0.5%)
  3: cpu: 6.1% command: firefox pid: 9057 mem: 401.6 MiB (1.2%)
  4: cpu: 2.7% command: firefox pid: 9345 mem: 240.0 MiB (0.7%)
  5: cpu: 2.4% command: xorg pid: 7410 mem: 158.3 MiB (0.4%)
  System RAM: total: 31.36 GiB used: 7.08 GiB (22.6%)
  Memory top: 5 of 381
  1: mem: 699.0 MiB (2.1%) command: firefox pid: 8091 cpu: 11.7%
  2: mem: 401.6 MiB (1.2%) command: firefox pid: 9057 cpu: 6.1%
  3: mem: 397.7 MiB (1.2%) command: steamwebhelper pid: 23990 cpu: 1.0%
  4: mem: 357.4 MiB (1.1%) command: latte-dock pid: 8634 cpu: 1.3%
  5: mem: 340.7 MiB (1.0%) command: firefox pid: 8600 cpu: 1.6%
Info:
  Processes: 381 Uptime: 26m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Shell: fish v: 3.3.1
  running-in: alacritty inxi: 3.3.11

(In case info is missing, my other forum posts should have the -Faz)

Has either worked at any point?

Hmm.

:rofl:

3 Likes

Just FYI:

Your MOBO is likely one of Gigabyte's with bad BIOS support in Linux. Your Ethernet and USB 3 probably are very unreliable. I have a similar/related GB model with these problems as well. I have to add special kernel boot parameters for this mobo, and you likely do as well (if you're not already aware).

1 Like

I remember that garuda-boot-options worked once, but the btrfs assistant has been broken since it's release.
I am gonna try to downgrade the former one.

Edit: 1.0.0 Also doesn't work anymore

1 Like

Actually not. USB is perfectly fine and Ethernet also seems good (Apart from bandwith calculators showing 50mbps dl and me just having 7mbps dl at max

I feel like this was a very bad Idea (Though It's usually ran with pkexec anyways), but garuda-boot-options works with sudo

Have you tried anything for this?
I seem to remember that in another topic/inxi you had kwin_wayland

Well this inxi was just a snapshot of me trying to get it to work - I didn't want to post two inxis just for the x11 - wayland change. So yeah, it's still not working, even under wayland

(Also once again, the btrfs-assistant also works with root, hmm)

2 Likes

It appears that Garuda boot options works when ran via Garuda welcome, and I tried the same with Btrfs Assistant, but to no avail

I would still try adding iommu=soft to your kernel parameters, as with all your issues it may help.

2 Likes

What would that do?

Okay whatever, seems like search engines are actually advanced tools for monke brain

Hello. I have the same issue with Wayfire (default Garuda install) and Qt apps that require root (through polkit). What seems to happen is that root user environment does not have wayland configuration Qt expects. If any application is run with sudo -E it works. By testing I figured out that 3 variables are minimum for Qt apps to run:

XDG_RUNTIME_DIR=/run/user/1000
XDG_SESSION_TYPE=wayland
WAYLAND_DISPLAY=wayland-1

Now I could add those in root env (should XDG_RUNTIME_DIR value change?), but is there a proper fix for this that does not include me messing up with environment? Maybe something with polkit?

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.