Gaming on wayland - dragonized

Hi, probably topic was drilled not once
But i would like to know how to properly switch from x11 to wayland, and do gaming on it
Anyone tried that ?
I have never done any switching and i would like to try, but don't want to break system if i try doing it from scratch googling around

1 Like

Install the package plasma-wayland-session and then you will be able to choose wayland or X11 from the login screen.

Word of caution: some widgets may cause issues with running wayland, Virtual Desktop Bar is one, so if you are having issues, might check/disable them.


And that's all?

I thought that this process might be more difficult

Will i be able to freely switch between x11 and wayland?

Yes, from the login screen


Have anyone played on wayland and amd, is gaming stable? How is behaves for older games?


Seems like in some cases wayland is still lacking much, but for most of games performed little better than x11, wondering how it will behave on games which im playing, gonna make some tests tomorrow. Thank you for now, ill be back with some summary

1 Like
'plasma-wayland-session-5.27.5-1-x86_64.pkg.tar.zst' z : The requested URL returned error: 404

found wayland-1.22.0-1 installed

do i need to remove default wayland package from system?

found some tutorial how to setup wayland on arch

does all of these steps are needed, or just the package like Rodney suggested?

No. I have Wayland package installed. Have you tried to switch over to Wayland yet?

1 Like

No, because there is a problem with package you proposed, cannot install it

Are you using plasma or another DE?

Plasma kde, its garuda dragonized kde, or at least i think it uses plasma

Strange, you must be having a conflict with one of the packages. Well, follow the Arch wiki guide you posted and go from there.

1 Like

im using wayland on garuda sway.. works amazing

1 Like

Try updating your system first.


Then install the new package.

sudo pacman -S plasma-wayland-session

If it still isn’t working, paste the input and output of the command into the thread so we can see what is happening. Also your garuda-inxi output is missing. :wink:

Kernel: 6.3.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6f7982fa-f801-4a9f-a47e-a2cd8f08ee86 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=4fb2a623-f3ae-4757-9e65-4eb2471f1194 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: B450 AORUS ELITE
serial: <superuser required> UEFI: American Megatrends LLC. v: F65a
date: 02/09/2023
Info: model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3312 high: 3800 min/max: 1400/4672 boost: disabled
scaling: driver: acpi-cpufreq governor: ondemand cores: 1: 3034 2: 3034
3: 3800 4: 3793 5: 1400 6: 3793 7: 3793 8: 3034 9: 3035 10: 3033 11: 3793
12: 3800 13: 3028 14: 3793 15: 3800 16: 3031 bogomips: 121375
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
vendor: Sapphire driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-2 empty: DP-1,DP-3,HDMI-A-1 bus-ID: 03:00.0
chip-ID: 1002:73df class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
s-diag: 777mm (30.58")
Monitor-1: DP-2 mapped: DisplayPort-1 model: Samsung LC27G5xT
serial: <filter> built: 2021 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
max: 2560x1440 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon RX 6700 XT (navi22
LLVM 15.0.7 DRM 3.52 6.3.9-zen1-1-zen) direct-render: Yes
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 0a:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 0a:00.6 chip-ID: 1022:15e3
class-ID: 0403
API: ALSA v: k6.3.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:4
chip-ID: 0a12:0001 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: yes address: see --recommends
Local Storage: total: 1.13 TiB used: 215.88 GiB (18.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 33.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: PNY model: CS900 240GB SSD
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 0615 scheme: GPT
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 16.48 GiB (16.5%)
fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 4 GiB size: 3.99 GiB (99.80%)
used: 576 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /home raw-size: 811.51 GiB size: 811.51 GiB (100.00%)
used: 199.4 GiB (24.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 16.48 GiB (16.5%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%)
used: 16.48 GiB (16.5%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: swap-2 type: zram size: 31.21 GiB used: 512 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 39.6 C mobo: N/A gpu: amdgpu temp: 32.0 C
mem: 30.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 899
Processes: 424 Uptime: 22m wakeups: 0 Memory: available: 31.21 GiB
used: 5.04 GiB (16.2%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1815
libs: 526 tools: octopi,paru,yay Shell: fish v: 3.6.1 running-in: konsole
inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-06-03
Last full system update: 2023-06-25 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

After garuda-update i was able to install that wayland package, it's very strange i have updated system like two days ago, and ir couldn't find package, does that package might be updated in last two days? that's why it couldn't find without garuda-update?

1 Like

all games works fine?

Hello there, well 2 days is actually something significant on a rolling release Distro like Garuda. Depending on the upstream of course, but keep in mind to do your updates in short intervalls and especially infront of bigger changes like your Wayland journey.

Bruce :shark:


Okay, ill be updating more often, first time on rolling distro


anything that worked for me on dragonized x11 works even better on sway/wayland