Game in fullscreen is staying on top

Hello,
I am new there. Today I installed game from steam and experienced problem switching between windows. When game is in fullscreen mode I can not bring any other window on top. When I change it to windowed mode and uncheck stay on top feature and then go back to fullscreen it will automatically go back to stay on top mode.
Is there some setting causing this? Could you help me?
Also sorry for my bad english :slight_smile:

Same problem with youtube in fulscreen

can you do alt-tab?

2 Likes

No because window with enabled "stay on top" property will be always on top. That is how it works. Until I disable it manually there is no way to bring other windows on front of fulscreened one.

Hi there, welcome to the community.

Are you sure that it is Garuda specific issue.
Well, I guess that it might not be even an issue, it might be intended feature.

But am not sure.....

2 Likes

Which game?
Which DE you use?
As always, post

inxi -Fza
2 Likes
System:    Kernel: 5.12.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=67ff22b8-b895-4fc8-8a44-b341923d92c8  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop Mobo: ASRock model: B450 Gaming K4 serial: <filter>  
UEFI-[Legacy]: American Megatrends v: P3.90 date: 12/12/2019  
CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23)  
model-id: 71 (113) stepping: 0 microcode: 8701013 cache: L2: 3 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86234  
Speed: 3671 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3671 2: 4029  
3: 3908 4: 4027 5: 3945 6: 3341 7: 4035 8: 4039 9: 3920 10: 3774 11: 4030 12: 4011  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nvidia v: 465.31  
alternate: nouveau,nvidia_drm bus-ID: 0a:00.0 chip-ID: 10de:1b81 class-ID: 0300  
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0  
screens: 1  
Screen-1: 0 s-res: 3840x1080 s-dpi: 80 s-size: 1219x343mm (48.0x13.5") s-diag: 1266mm (49.9")  
Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") diag: 584mm (23")  
Monitor-2: DP-0 res: 1920x1080 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27")  
OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31 direct render: Yes  
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel  
bus-ID: 0a:00.1 chip-ID: 10de:10f0 class-ID: 0403  
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock driver: snd_hda_intel v: kernel  
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403  
Sound Server-1: ALSA v: k5.12.10-zen1-1-zen running: yes  
Sound Server-2: JACK v: 0.125.0 running: no  
Sound Server-3: PulseAudio v: 14.2 running: yes  
Sound Server-4: PipeWire v: 0.3.30 running: no  
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169  
v: kernel port: d000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200  
IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8  
bus-ID: 1-4:2 chip-ID: 0a12:0001 class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>  
Drives:    Local Storage: total: 2.84 TiB used: 81.29 GiB (2.8%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WDS100T2B0C-00PXH0  
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4  
rotation: SSD serial: <filter> rev: 211070WD scheme: MBR  
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB  
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter>  
rev: 0A80 scheme: MBR  
ID-3: /dev/sdb maj-min: 8:16 vendor: Kingston model: SV300S37A120G size: 111.79 GiB block-size:  
physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: BBF0  
scheme: MBR  
Partition: ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 81.29 GiB (8.7%) fs: btrfs  
dev: /dev/nvme0n1p1 maj-min: 259:1  
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 81.29 GiB (8.7%) fs: btrfs  
dev: /dev/nvme0n1p1 maj-min: 259:1  
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 81.29 GiB (8.7%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 81.29 GiB (8.7%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-8: swap-8 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
ID-9: swap-9 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram8
ID-10: swap-10 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram9
ID-11: swap-11 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram10
ID-12: swap-12 type: zram size: 2.61 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram11
ID-13: swap-13 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: 1024 dev: /dev/sdb2
maj-min: 8:18
Sensors:   System Temperatures: cpu: 58.1 C mobo: 38.0 C gpu: nvidia temp: 56 C
Fan Speeds (RPM): fan-1: 453 fan-2: 0 fan-3: 698 fan-4: 457 fan-5: 0 gpu: nvidia fan: 9%
Power: 12v: N/A 5v: N/A 3.3v: 3.31 vbat: 3.26
Info:      Processes: 357 Uptime: 3h 05m wakeups: 0 Memory: 31.28 GiB used: 6.88 GiB (22.0%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1683 lib: 503
Shell: fish v: 3.2.2 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.04

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.
greetings
SGS

Game Dark Souls 3 but it's problem of every fulsceened window. I came here from Manjaro KDE and there wasn't this issue.

BTW, BIOS, no update?

Next, which kernel you use on Manjro KDE?
Maybe try another one on Garuda too.

1 Like

This can be affected by kernel? I don't remember which I used on Manjaro. Probably latest one.
And of cuorse I have everything up to date :smiley:

Still no solution to this issue ?

There seems to be a more recent bios update ASRock > Fatal1ty B450 Gaming K4
I think this is your motherboard but be sure.

Also Proton/WIne sometimes can be weird have you tried borderless fullscreen?

The stay on top flag seems to be a KDE thing and is considered "normal behavior" but you can make a keyboard shortcut i think to toggle that try this and see if it works https://www.linuxuprising.com/2020/12/how-to-use-keyboard-shortcut-to-toggle.html

Good luck!

Updating bios to most recent version didn't helped.

Yes "stay on top" or "keep above others" is KDE feature. But it shouldn't be automaticly enabled every time window goes to fullscreen.
Also I was tallking about borderless fulscreen whole time. There is same issue with youtube fullscreen.
For example if I watch youtube in fullscreen or play any game I am not able to Alt+Tab to other window because fulscreened one will stay on top.
I was using KDE for past 2 years and I have not faced this problem until now.

Did you search in
https://bugs.kde.org/
?

OT

There are always new bugs รคhm, features KDE offers, so who knows?

2 Likes

I have not found it reported as bug.

Also there is screenshot of between my monitors where left window is active and at the same time behind the fullscreened one: