Fstab umask=0022, mount command shows fmask=37777600022,dmask=37777600022

Hi all,

I downloaded and compiled the linux-cacule (5.15 for native ntfs3 support) kernel from the AUR repo. Following the documentation here on the new ntfs3 mount option:
https://www.kernel.org/doc/html/latest/filesystems/ntfs3.html

You can specify the umask (files and directories) or fmask and dmask separately. I have an NTFS partition on one of my drives which is being mounted via UUID in my /etc/fstab file like so:

UUID=B29AC1289AC0EA45          /Windows8_OS   ntfs3 ro,nosuid,nodev,relatime,nohidden,sys_immutable,acl,uhelper=udisks2,umask=0022,uid=1000,gid=1000,iocharset=utf8,user 0 0

You'll notice that my umask specifies 0022, which should result in 0755 for directories and 0644 for files. However, when I run the mount command, this is what my output shows:

/dev/sda5 on /Windows8_OS type ntfs3 (ro,nosuid,nodev,noexec,relatime,uid=1000,gid=1000,fmask=37777600022,dmask=37777600022,iocharset=utf8,sys_immutable,nohidden,acl,uhelper=udisks2,user)

What are these fmask and dmask values? Does it not matter since I'm mounting the partition as ro?

I tried manually mounting another NTFS partition from /dev/sda7 with the following command:

sudo mount -t ntfs3 -o rw,nosuid,nodev,relatime,nohidden,sys_immutable,acl,uhelper=udisks2,umask=0022,uid=1000,gid=1000,iocharset=utf8,user /dev/sda7 /home/user/test

and after it successfully mounted, I ran the mount again and it displayed the same long number for fmask and dmask. I traversed into /home/user/test and typed touch hi and that worked just fine and the file perm was 644.

I even tried remounting but with umask=022 instead to see if that would have made a difference, but the subsequent mount indicated the same long values. I then tried remounting again but instead of umask, I specified fmask=022,dmask=022 but after it mounted, the mount showed the same long integer. I tried googling for the string fmask=37777600022 but couldn't find anything.

Anyone have any insight into this?

EDIT: Here's my inxi -Faz
❯ inxi -Faz
System:    Kernel: 5.15.1-1-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule root=UUID=12979374-b0c5-4bc8-8f21-3b53bd02741b
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3 sysrq_always_enabled=1 intel_iommu=on iommu=pt
           acpi_backlight=vendor delayacct
           Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 20175 v: Lenovo IdeaPad Yoga 13 serial: <filter> Chassis:
           type: 10 v: Lenovo IdeaPad Yoga 13 serial: <filter>
           Mobo: LENOVO model: INVALID v: 31900003WIN8 STD MLT serial: <filter> UEFI: LENOVO v: 66CN55WW
           date: 02/28/2013
Battery:   ID-1: BAT1 charge: 38.4 Wh (100.0%) condition: 38.4/49.3 Wh (78.0%) volts: 16.2 min: 14.8
           model: Lenovo IdeaPad Mocca2 type: Unknown serial: <filter> status: Full
CPU:       Info: Dual Core model: Intel Core i7-3537U bits: 64 type: MT MCP arch: Ivy Bridge family: 6
           model-id: 3A (58) stepping: 9 microcode: 21 cache: L2: 4 MiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19963
           Speed: 1896 MHz min/max: 800/1900 MHz Core speeds (MHz): 1: 1896 2: 1895 3: 1862 4: 1882
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds status: Vulnerable: No microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
           Device-2: Chicony Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 2-1.7:4 chip-ID: 04f2:b322
           class-ID: 0e02
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
           alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1")
           Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 140 size: 290x170mm (11.4x6.7") diag: 336mm (13.2")
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.2.4 compat-v: 3.0
           direct render: Yes
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
           Device-2: DisplayLink Kensington SD4000 USB Dock type: USB driver: cdc_ncm,snd-usb-audio
           bus-ID: 4-2.1:3 chip-ID: 17e9:4344 class-ID: 0a00 serial: <filter>
           Sound Server-1: ALSA v: k5.15.1-1-cacule running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Message: No device data found.
           IF-ID-1: br-1a91b0dd2206 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
           IF-ID-2: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
           IF-ID-3: enp0s20u2u1i5 state: up speed: 100 Mbps duplex: half mac: <filter>
           IF-ID-4: veth572b238 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-5: veth7f8e138 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-6: vetha9407d4 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-7: vethe2f0fbe state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-8: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-9: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-10: wlp0s26u1u4i2 state: down mac: <filter>
Bluetooth: Device-1: Realtek RTL8723AU 802.11n WLAN Adapter type: USB driver: btusb,rtl8723au bus-ID: 1-1.4:4
           chip-ID: 0bda:1724 class-ID: e001 serial: <filter>
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
           hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 458.95 GiB (39.2%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZMTD256HAGM-000L1 size: 238.47 GiB block-size:
           physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 2L0Q scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital model: WD My Passport 0820
           size: 931.48 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1007
           scheme: GPT
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 263.29 GiB (28.3%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat
           dev: /dev/sdb1 maj-min: 8:17
           ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 263.29 GiB (28.3%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 263.29 GiB (28.3%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 263.29 GiB (28.3%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 289 Uptime: 3h 49m wakeups: 1 Memory: 7.64 GiB used: 4.28 GiB (55.9%) Init: systemd
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1868 pacman: 1858 lib: 481
           flatpak: 10 Shell: Zsh v: 5.8 running-in: alacritty inxi: 3.3.08

Could you expand your post with your inxi -Faz, please.

2 Likes

@SGS so sorry! totally forgot, I edited OP

1 Like

I do not mount or touch my win partitionen, so I cant help but you can check for the long numbers :slight_smile:

Yeah, I came across that post too - didn't really provide any insight other than to confirm that these reported numbers seem very unusual.