Fstab has #Modified_by_garuda-hotfixes

hi!

garuda-update failed when it was trying to update the system after installing all the new stuff.

i tried a bunch of different booting options from grub and got into this point, is the resolution the "normal" boot from USB, chroot, garuda-update, reboot?

note: garuda-inxi STOPPED at that point and did not continue so there is no more output from it.

I don't think your issue is due to the fstab change, which was put in place long ago and applied to all of us. Although now it's not needed anymore.

I think you should restore the latest working snapshot and garuda-update again...

4 Likes

here are couple of more interesting events .. will be booting to USB and trying from there.

all good .. so far .. have USB/chroot/update.

i guess ignore all this! :stuck_out_tongue_winking_eye:

Ouch, a kernel panic. Have you tried a different kernel or just straight up restored a snapshot?

hi! well, ive partitioned my ssd and am looking at other distros (cause it is fun! wink!) and what i find is that i cant often reboot from one to the other; they dont often want to start up correctly.

at this point ive even borked my boot partition and it knows about my original garuda but can NOT boot into it (cant find the kernel?!?).

so, today ill be looking around on how to "restore" that vs my garuda install particularly (im assuming the "normal" routine of usb/chroot/etc will fix it).

ive tried the following in the last 24hrs: endeavour os (wouldnt boot), pop!_os (installed, unstable), opensuse (installed, running, discord dies though discord is acting weird on my phone right now so...), and of course garuda on the 2nd/new partition.

1 thing i find interesting is that they ALL mess with the boot partition/loader and make it "theirs" instead of what i would consider playing nice and just adding themselves as a 2nd OS to boot to. this is why i think opensuse borked things as i cant boot back to my original garuda.

anyway, some of what i do is self-inflicted but it is interesting how much linux still isnt as stable as windows (barf but true....)

note tho: i didnt start the distro hopping BEFORE the original update issue.

that happened and i figured since i be burning some USB i might as well spend a day trying things out.

while garuda HAS BEEN/IS my fav so far, it too has had its annoyances.

I do not find this to be true. I have been multibooting Linux systems for a while with no issues. This system has quite a few concurrently installed distros in fact:

You just have to specify that the EFI partition should be mounted but not formatted during the installation. It sounds like you are allowing it to be formatted, which will destroy any data currently sitting on the EFI partition.

I heartily disagree. Nothing is more needlessly destructive to a perfectly fine EFI partition than Windows.

3 Likes

putting manjaro on it "fixed" it and no prob booting right back into my "old" garuda!

awesome!

am i

2 Likes

was wondering if writing this much would get this .. anyway, no problem! hopefully it might be of use to someone.

im 52, been a coder for 40+ (yep: started on the Apple //c! now: python, elixir, racket), love linux but have to use a windows for work -- BOO!

blah blah blah! :wink:

ill stop now. thx everyone!

So you have been coding linux since you were 12 then?

Given the above interesting choice of career path.

1 Like

born: 1971
apple //c: 1983 (Apple IIc - Wikipedia)

yep: 12yrs old, but i guess that is 39yrs .. im old so my math now sucks! :stuck_out_tongue_winking_eye:

Please select the post that solved your problem :hugs:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.