Fresh install - system freezes and can't connect to WiFi

So since Windows started giving me a headache and I’ve tried Garuda before I’ve decided to switch to it completely as standalone OS. My previous experience was fine, everything worked out of the box. Now on my newer PC I have issues with stuttering and freezes and my T4U Plus WiFi adapter doesn’t work (it worked in live USB and on older PC).

System detects internet connection but is stuck in a loop of configuring interface - connection failed. I can try to fix it with GitHub repositories or AUR after I’ll find proper package but I don’t know what to do about these freezes I have. Mouse cursor behaves normally but can’t click anything.


Kernel: 6.8.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=aa47e7f6-d135-4601-88af-ae5a97081886 rw rootflags=subvol=@
quiet resume=UUID=5c94f891-1666-4067-bf30-b7897054b893 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: PRIME B450-PLUS v: Rev X.0x
serial: <superuser required> part-nu: SKU uuid: <superuser required>
BIOS: American Megatrends v: 4402 date: 12/13/2023
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701030
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3589 high: 3754 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3544 2: 3600
3: 3653 4: 3600 5: 3600 6: 3600 7: 3600 8: 3552 9: 3600 10: 3754 11: 3372
12: 3600 bogomips: 86399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
Vulnerabilities: <filter>
Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Sapphire
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DP-1, DP-2, DP-3, Writeback-1 bus-ID: 0b:00.0
chip-ID: 1002:73ff class-ID: 0300
Display: wayland server: v: with: Xwayland v: 23.2.6
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.5-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6600 XT (radeonsi
navi23 LLVM 17.0.6 DRM 3.57 6.8.5-zen1-1-zen) device-ID: 1002:73ff
memory: 7.81 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 9 device: 0 type: discrete-gpu name: AMD
Radeon RX 6600 XT (RADV NAVI23) driver: mesa radv v: 24.0.5-arch1.1
device-ID: 1002:73ff surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.5-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0b:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0d:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech Logitech G PRO X Gaming Headset
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-2:3 chip-ID: 046d:0aaa class-ID: 0300
serial: <filter>
API: ALSA v: k6.8.5-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK RTL8111H driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Device-2: TP-Link Archer T4U ver.3 driver: rtw_8822bu type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1:2 chip-ID: 2357:0115
class-ID: 0000 serial: <filter>
IF: wlp2s0f0u1 state: down mac: <filter>
IF-ID-1: enp2s0f0u4 state: unknown speed: -1 duplex: half mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Xiaomi Mi/Redmi series (RNDIS) driver: rndis_host v: kernel
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4:5
chip-ID: 2717:ff80 class-ID: 0a00 serial: <filter>
Local Storage: total: 931.51 GiB used: 18.21 GiB (2.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lexar model: SSD NM710 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 9742 temp: 39.9 C scheme: MBR
ID-1: / raw-size: 914.43 GiB size: 914.43 GiB (100.00%)
used: 18.21 GiB (2.0%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 914.43 GiB size: 914.43 GiB (100.00%)
used: 18.21 GiB (2.0%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 914.43 GiB size: 914.43 GiB (100.00%)
used: 18.21 GiB (2.0%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 914.43 GiB size: 914.43 GiB (100.00%)
used: 18.21 GiB (2.0%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.08 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
System Temperatures: cpu: 46.4 C mobo: N/A gpu: amdgpu temp: 33.0 C
mem: 30.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Memory: total: 16 GiB available: 15.53 GiB used: 2.6 GiB (16.7%)
Processes: 302 Power: uptime: 8m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.2 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1906 libs: 547 tools: octopi,paru Compilers:
clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.33
Garuda (2.6.25-1):
System install date:     2024-04-13
Last full system update: 2024-04-13
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:

I would update the BIOS first (new version release came out a few days ago) PRIME B450-PLUS - Support

I would also try a different kernel like the LTS kernel, as you mentioned the wifi worked on live USB.


In case you can’t fix your issue with the LTS kernel, in my opinion you could try this driver:

sudo pacman -S rtl88x2bu-dkms-git

Afterwards, you should probably blacklist your current module:

echo "blacklist rtw88_8822bu" | sudo tee /etc/modprobe.d/rtw8822bu.conf

One issue per topic, please.
Let’s focus only on the network one here.


AUR only:

paru rtl88x2bu-dkms-git
1 Like

Pacman can’t find it, Yay can but it can’t build it

==> ERROR: Cannot find the debugedit binary required for including source files in debug packages.
error: failed to build 'rtl88x2bu-dkms-git-5.13.1.r181.2812290-3':
error: packages failed to build: rtl88x2bu-dkms-git-5.13.1.r181.2812290-3

Also LTS kernel didn’t help


Nvm, managed to get that driver with pamac and looks like it works, I’ve lost 5GHz connection however

Edit 2

Works also on zen kernel, no 5GHz still though

Try disconect the adapter, reboot and connect the adapter again.

Check whether you also have the issue with a x11 session. If so, then create a separate topic for it.

Try disconect the adapter, reboot and connect the adapter again.

Sadly it still doesn’t let me connect to 5GHz network. Stuck on configuring interface - connection failed

You got me again :wink:. I was in a hurry as usual and went as usual for a copy and paste from a previous post…

1 Like

There are quite a few issues upstream where 5G is mentioned.
I hadn’t time to read them, I’ll just reference one. Maybe repeat the search and see if there is some kind of workaround as mentioned here:


Well it just connected now, I don’t know exactly why as I haven’t changed that much with drivers or anything so I’d say the issue has been solved :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.