Frequent latte dock crashes and WiFi issues

First off, love this distro more than any other distro I've ever used. It has improved my workflow immensely. I'm not sure I'll ever be able to get away from it.

My problem(s):
1: Frequent latte dock crashes. Happens randomly, sometimes while switching virtual desktops, sometimes for no apparent reason at all.
My hot fix: latte-dock --replace, and then right click on the top panel > edit panel > switch visibility to autohide, and then quickly switch it back to "Always Visible". I have to do this since, even after replacing the latte dock, there are still issues with the top panel showing up on all displays and all virtual desktops.

  1. WiFI issues with BrosTrend AC1200 WiFi adapter.
    My attempted fixes: Searched the forums and tried multiple solutions. Re-installed drivers, blacklisted drivers, and even disabled ipv6 (re-enabled later). None of these worked. I resorted to tethering my phone to my computer via USB and sharing the internet connection from it. This is very inconvenient but it'll have to due for the moment as I'm very busy with work.

I'm required to post the following:
One other question: is it really necessary that users post their cryptdevice info on the forums?

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=11374ffd-57dd-4850-ae21-7018ba2a4020 rw [email protected]
quiet
cryptdevice=UUID=a3b5cba1-2dfa-428f-8997-3864dc0e7ca3:luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
root=/dev/mapper/luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3 quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ipv6.disable=1 ipv6.disable=0
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: Maximus IV Extreme v: Rev 1.xx
serial: <superuser required> BIOS: American Megatrends v: 3604
date: 04/12/2013
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-2600K bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1671 high: 2079 min/max: 1600/5900 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1605 2: 1605 3: 1605
4: 2079 5: 1607 6: 1607 7: 1605 8: 1655 bogomips: 54583
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: ASUSTeK driver: nvidia
v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
(as of 2022-10) arch: Maxwell code: GMxxx process: TSMC 28nm
built: 2014-19 pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:13c0 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 85 s-size: 1147x319mm (45.16x12.56")
s-diag: 1191mm (46.87")
Monitor-1: DVI-I-0 pos: right res: 1280x1024 hz: 60 dpi: 86
size: 376x301mm (14.8x11.85") diag: 482mm (18.96") modes: N/A
Monitor-2: HDMI-0 pos: primary,left res: 2560x1080 dpi: 81
size: 798x334mm (31.42x13.15") diag: 865mm (34.06") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: ASUSTeK driver: snd_hda_intel bus-ID: 1-1.4.1:8 v: kernel
bus-ID: 00:1b.0 chip-ID: 1038:12ad class-ID: 0300 chip-ID: 8086:1c20
class-ID: 0403
Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
Device-3: SteelSeries ApS Arctis 7 type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: Shure X2u Adapter type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.6:7 chip-ID: 14ed:29b6
class-ID: 0300
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel 82579V Gigabit Network vendor: ASUSTeK P8P67 Deluxe
driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503
class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel 82583V Gigabit Network vendor: ASUSTeK driver: e1000e
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: b000 bus-ID: 0c:00.0
chip-ID: 8086:150c class-ID: 0200
IF: enp12s0 state: down mac: <filter>
Device-3: Realtek RTL88x2bu [AC1200 Techkey] type: USB driver: rtw_8822bu
bus-ID: 2-1.6:7 chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
IF: wlp0s29u1u6 state: up mac: <filter>
IF-ID-1: enp0s29u1u5 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-1.1:3 chip-ID: 0a12:0001 class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Device-2: Samsung GT-I9070 (network tethering USB debugging enabled)
type: USB driver: rndis_host v: kernel bus-ID: 2-1.5:11 chip-ID: 04e8:6864
class-ID: 0a00 serial: <filter>
Drives:
Local Storage: total: 447.13 GiB used: 42.22 GiB (9.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSC2BP480G4
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0420 scheme: MBR
Partition:
ID-1: / raw-size: 447.13 GiB size: 447.13 GiB (100.00%) used: 42.22 GiB
(9.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
ID-2: /home raw-size: 447.13 GiB size: 447.13 GiB (100.00%) used: 42.22
GiB (9.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
ID-3: /var/log raw-size: 447.13 GiB size: 447.13 GiB (100.00%) used: 42.22
GiB (9.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
ID-4: /var/tmp raw-size: 447.13 GiB size: 447.13 GiB (100.00%) used: 42.22
GiB (9.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.32 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 79 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 58%
Info:
Processes: 322 Uptime: 11h 53m wakeups: 24 Memory: 31.32 GiB used: 5.9 GiB
(18.8%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1275 libs: 332
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.9-1):
System install date:     2022-10-21
Last full system update: 2022-10-23
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

I'm new to the forums, and would appreciate any tips/pointers. Thank you.

1 Like

You could try one of these AUR packages: rtl88x2bu-dkms-git / rtl88x2bu-cilynx-dkms-git

Pay special attention to blacklist the current module for testing.

6 Likes

Just downloading the package from the github page you linked > GitHub - cilynx/rtl88x2bu: rtl88x2bu driver updated for current kernels. and then running deploy.sh totally fixed my WiFI driver issue. Thank you very much!

Edit: I realize that this may be the wrong driver all together for my current system, but I'm desperate to get anything working at the moment.

Now to figure out this latte dock issue... hehe

You've helped tremendously! Thank you x1000!

1 Like

I must note, however, that the speeds seem to be much lower than with the original drivers I used in other distros. Not quite sure what the problem is there, but this particular driver seems to work better than the default driver on this system, and the one from the AUR.

It will do for now, until I find a way to get the official driver to work.

Edit: I tried the blacklisting suggestion, but it seems that the experimental drivers are not present on my system.

1 Like

My mistake. It was present on my system, but I guess I didn't see it in lsmod at first. I just blacklisted it. Hopefully that will improve speeds. I'll keep you updated.

1 Like

Update: After a blacklist and a restart, I now have full speeds as it doesn't seem to be switching to the higher priority anymore. My WiFi issue is solved.

1 Like

This is a fair question I suppose, although if you are concerned this might compromise your device security somehow: I am certain it does not.

As you might imagine, this--and some of the other information in the inxi output--only occasionally comes in useful. In the case of this specific output, an example of when it would be helpful to have the UUIDs at hand would be when troubleshooting certain kinds of non-booting systems. Knowing that a drive is LUKS encrypted can also profoundly impact the type of troubleshooting required.

Most of the information is not always needed, but all of the information has come in useful at one time or another.

Frequently a solution is found by discovering something in the inxi output that would not have been thought of quickly in a round of tiresome troubleshooting questions.

The greatest benefit of having all this information up front is it can prevent a lot of back-and-forth in the thread that can unnecessarily lengthen the process of finding a solution. Instead of having to put together an idea of the system piecemeal by dragging the information out one question at a time, it is all laid out there to see and can be combed through for clues. :male_detective:

In any case, I'm glad to see your WiFi is fixed and welcome to the community. :slightly_smiling_face:

8 Likes

I see. That makes perfect sense. Thank you! I'm happy to become a part of this friendly community. :grinning:

2 Likes

This is an example of inxi output that may or may not come in handy when troubleshooting if, say, you encounter any hardware-related inconsistencies, and there is a more current BIOS available.

5 Likes

@Dustin Please be sure you use the appropriate DKMS package, otherwise it'll break every time you update your Kernel!

In your case, that seems to be rtl88x2bu-cilynx-dkms-git. I've added it into Chaotic-AUR:

Now you can simply sudo pacman -Syu chaotic-aur/rtl88x2bu-cilynx-dkms-git

3 Likes

Just installed. Very helpful. Thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.