Freeze after opening or minimizing window

Hello.
As the title says sometimes when I open an app or minimize/maximize something my whole system freezes. I can't put it to sleep or anything, all I can do is force shut it down by holding the power button. My friend said that maybe it's an issue with SWAP but I don't know what to do with that information.

System:
Kernel: 5.16.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d454fcf1-f3b8-4e97-b018-0fbe02a026de rw [email protected]
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=f793db8a-e31a-4f81-8b69-7ba9b796aea6 loglevel=3 splash quiet
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-dk1xxx
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 8741 v: 02.34 serial: <superuser required> UEFI: Insyde
v: F.21 date: 01/08/2021
Battery:
ID-1: BAT1 charge: 42.1 Wh (100.0%) condition: 42.1/52.5 Wh (80.2%)
volts: 12.9 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
serial: <filter> status: Full
CPU:
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xEA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 899 high: 900 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 900 2: 900 3: 900 4: 900
5: 899 6: 900 7: 900 8: 900 9: 900 10: 900 11: 900 12: 900
bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Hewlett-Packard
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile]
vendor: Hewlett-Packard driver: nvidia v: 495.46
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2191
class-ID: 0300
Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
bus-ID: 1-5:3 chip-ID: 04f2:b627 class-ID: 0e02
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 950x285mm (37.4x11.2")
s-diag: 992mm (39")
Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 142
size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
Monitor-2: HDMI-1-0 res: 1680x1050 hz: 60 dpi: 89
size: 480x270mm (18.9x10.6") diag: 551mm (21.7")
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.3.4
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:1aeb
class-ID: 0403
Sound Server-1: ALSA v: k5.16.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 07:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: class-ID: 0104
Drives:
Local Storage: total: 1.14 TiB used: 760.38 GiB (65.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB256HBHQ-000H1 size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HPS0NEXH temp: 39.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPSX-60A6WT0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 221.2 GiB size: 221.2 GiB (100.00%)
used: 188.33 GiB (85.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 221.2 GiB size: 221.2 GiB (100.00%)
used: 188.33 GiB (85.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 221.2 GiB size: 221.2 GiB (100.00%)
used: 188.33 GiB (85.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 221.2 GiB size: 221.2 GiB (100.00%)
used: 188.33 GiB (85.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.97 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.43 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 56.0 C pch: 53.0 C mobo: 10.0 C
Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
Processes: 366 Uptime: 6m wakeups: 1 Memory: 15.43 GiB
used: 4.51 GiB (29.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: 1951 pacman: 1942 lib: 505 flatpak: 9
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: yakuake
inxi: 3.3.12
Garuda:
System install date:     2021-11-27
Last full system update: 2022-02-06
Is partially upgraded:   No
Using TLP:               No
Windows dual boot:       No/Undetected

Very, very bad, you can destroy your system or important data files.
Try TTY first.
Ctrl + Shift + F3
Login as user and use reboot or poweroff

Open top/htop in terminal and check which app let freeze your PC.
Maybe different from

Maybe post which one it is :slight_smile:

and
:slight_smile:

3 Likes

Can you describe a bit more how to reproduce your issue?

Does it happen when you have a lot of windows/apps/programs running or it happened also when you had pretty much nothing going on?

And as SGS mentioned, which app(s) caused your issue?

1 Like

First, look for any bios updates if available.

Install linux-firmware-git, then reboot.

Install and test the linux-mainline kernel then boot into it from the grub menu.

Welcome to the Garuda community.

2 Likes

I think it's just when I open minimize window because it happened when I opened/minimized firefox, signal, discord, vscode, maybe even system settings or dolphine (I'm not sure about those two).
Most of the times I only had VSCode, steam, spotify and discord open.
I can't really reproduce it when I want because when I just spam open/minimize windows it's working as it should. It just sometimes catches me offguard.

Maybe you could consider a btrfs full balance.
If I remember correctly there was recently an issue on the relevant Garuda Assistant button.
From terminal this would be simply

sudo btrfs filesystem balance start /

Actually this is worth trying only for generic random freezes.
If you're sure it's only a problem with maximizing / minimizing, probably this won't help.

Are you using kwin or kwin-lowlatency? The latter has some rare issues (I actually filed one of 'em a while back) and who knows on this one... if you use the latter, I'd suggest to test with kwin.

They are very easily interchangeable/replaceable with sudo pacman -Syu kwin or sudo pacman -Syu kwin-lowlatency.

And check your Compositor settings in System Settings, or try different settings in there. Just to rule those out.

1 Like

I did sudo pacman -Syu kwin
and my Compositor settings are as follow

Scale method: Accurate
Rendering backend: OpenGL 3.1
Latency: Balance of latency and smoothness
Tearing prevention: Automatic
Keep window thumbnails: Only for Shown Windows

Have you tried disabling your compositor completely as a test?

2 Likes

I can try that, but as I said, unfortunately I can't seem to replicate this issue so I can't even tell if it worked or not.

If there are no further freezes then you will know the compositor is responsible.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.