FPS tool configuration and KDE flickering info

Hello, First I would like to say I'm loving the distro. Congratulations on making THE best looking desktop I have EVER seen out of the box and I've seen a lot of reviews that feel the same way. Not only the looks but the whole package and underbelly of the distro is great. I hope you continue to succeed and grow the community. You also have a great website as far as usability and the forum. The wiki needs some help but I'm sure it will get there.

To my 2 issues:

  1. I turned on the FPS tool in KDE Plasma Dragon. The configuration is very limited. I was wondering if there was any way of changing the integrated fps tool in a config file to make it less obtrusive. Change the size, position, color, text etc..

  2. The reason that I've turned on the FPS tool is to mitigate a slight flickering that is occurring with what seems to be an overlay on my KDE Plasma. I installed Garuda on an older Alienware 15 laptop. It has an Intel chipset and AMD chipset. The chipset that is used is the Intel one so I'll focus on that one.

Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
           chip ID: 8086:0416 class ID: 0300
           Device-2: Advanced Micro Devices [AMD/ATI] Amethyst XT [Radeon R9 M295X / M390X] driver: amdgpu v: kernel
           bus ID: 01:00.0 chip ID: 1002:6921 class ID: 0380

Symptoms:
If I let the cursor idle, the screen brightens slightly. When I move my cursor, a "sheen" or slight dimming effect turns on. It is barely noticeable but if you are looking at the screen for hours, it may cause headaches. This issue doesn't show up when the FPS effect is in effect because I think it constantly refreshes what I'm thinking is an overlay. If Chrome(Brave) browser is on the screen it doesn't happen. Terminology terminal it does not happen. However, Thunderbird it does happen and the desktop without any apps up. That's about as many as I was paying attention to.

Troubleshooting:

  1. I've tried turning off the Compiz service on startup from the settings menu. I've turned off the dimming effects and tried every other desktop effect individually, one by one to see if I could locate the source of the problem. It doesn't seem to be any setting in the configuration that really is directly tied to this issue.
  2. I saw a post regarding a Gnome user with the same issues. In that post it recommended changing some BIOS settings. I don't have the Discrete settings to turn off/on however in the bios it does say the AMD GPU is in "Discrete 1" mode.
  3. I had a similar issue on the same laptop with Linux Mint. When I switched to i3wm it went away so I never looked in to it again. I'm hoping to figure this out so I can stay on KDE Plasma.
  4. On the FPS tool, if I leave the computer idle, the FPS tool displays a constant tick every second or less than a second. I'm guessing this is the overlay attempting to change and the FPS counter keeping it from idling? Maybe it's just my text cursor on off.
  5. Used powertop and turned off as many power saving settings as I could.
  6. Used cpupower and turned off as many power saving settings as I could.
    NOTE: If anyone on a laptop is reading this, this is a very bad idea if you plan on saving battery. However, if you are planning to travel, you may be able to use these tools to save battery by tuning the power settings there. Try at your own risk.
  7. Read a post on StackOverflow about how to tell what OpenGL version your Chipset supports. Command is glxinfo | grep OpenGL. My chipset supports 3.1 which is not recommended on Garuda. OpenGL 3.3 and above supported. [ How to tell which version of OpenGL my graphics card supports on Linux

"Solution":
It is a hardware related issue that I can workaround with the FPS counter on the upper right hand side.

Hope this helps if anyone else is having some issues on older hardware.

1 Like

1 Like

It turns out that just having a little 'network monitor' or I'm guessing any type of system monitor up mitigates the mouse idle issue. So it's not necessary to have the FPS effect up.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.