FPS drops exponentially after simple reboot from fresh install

Kernel: 6.4.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c9b02208-5917-4b7b-87de-a020fcdbc610 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: X570 AORUS ELITE WIFI v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS ELITE WIFI serial: <superuser required>
UEFI: American Megatrends LLC. v: F37d date: 07/20/2022
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3665 high: 3700 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3588 2: 3700
3: 3596 4: 3700 5: 3700 6: 3700 7: 3599 8: 3700 9: 3598 10: 3700 11: 3700
12: 3700 bogomips: 88795
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
vendor: XFX driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0d:00.0
chip-ID: 1002:73df class-ID: 0300
Display: wayland server: X.org v: with: Xwayland v: 23.1.2
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: 0
Monitor-1: DP-3 res: 3440x1440 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon RX 6750 XT (navi22
LLVM 15.0.7 DRM 3.52 6.4.1-zen2-1-zen) direct-render: Yes
Device-1: Creative Labs CA0132 Sound Core3D [Sound Blaster Recon3D /
Z-Series BlasterX AE-5 Plus] driver: snd_hda_intel v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 1102:0012 class-ID: 0403
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0d:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-3: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0f:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.4.1-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.72 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 05:00.0
chip-ID: 8086:24fb class-ID: 0280
IF: wlp5s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: Intel Wireless-AC 3168 Bluetooth driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-5:3 chip-ID: 8087:0aa7
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 2.29 TiB used: 27.34 GiB (1.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Samsung model: SSD 970 PRO 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 1B2QEXP7 temp: 34.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Sabrent model: Rocket Q
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: RKT30Q.1 temp: 24.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Generic model: Flash Disk
size: 7.81 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter> fw-rev: 8.07
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 27.34 GiB (5.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 27.34 GiB (5.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 27.34 GiB (5.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 27.34 GiB (5.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 42.1 C mobo: 30.0 C gpu: amdgpu temp: 57.0 C
mem: 50.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 669
Processes: 360 Uptime: 9h 43m wakeups: 7 Memory: available: 15.54 GiB
used: 5.52 GiB (35.5%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1796
libs: 518 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-07-06
Last full system update: 2023-07-07
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Tried to ask in Discord, but apparently trying to talk out a problem on a chat application is a no no.

Just a little bit of history to the problem. My system ran perfectly for over a month. I let Distro Tube talk me into giving Doom Emacs a shot. So I downloaded emacs, got it all set up to be doom emacs, and didn't even think about it the rest of the week. Come Friday I ran an update, rebooted, and all of my games were at running at roughly 50 fps. I snapped back to before installing emacs, and that seemed to fix it. But being stubborn, I persisted with trying to get doom emacs going. Reinstalling emacs, snapping back, trying to find any kind of information on why installing emacs killed my gaming experience. It's a text editor, it shouldn't affect my game performance...at all....right?

Well, after snapping back stopped fixing the problem, I decided I'll just reinstall, the system originally ran perfectly after a fresh install, that's probably not the best solution, but it was definitely going to be the fastest way to get me into a gaming session for the weekend. Or so I thought. I've since reinstalled the OS at least 15x probably more. It's just been downhill from there. Essentially, no matter what I install or don't install, my experience goes something like this.....

(I'm using Eve Online as it's the smallest game I own, easily/quickly installed, and has an FPS counter right in the menu)
Fresh install, initial update, immediately shut down setup assistant, and reboot. Setup Steam, install/run Eve ...as it should my fps looks like this..

Screenshot from 2023-07-06 14-47-09

From there, I shut the game down, and just reboot my system, rerun Eve, and now the FPS looks like this...

I'm stumped. I'm not a dev, or a programmer, and I have no clue what could be causing this. And the bigger problem is that I can't reliably reproduce it. What I explained above is just one of the many times, over the last week, that I've encountered this, and at seemingly random intervals, and almost all of the information that I can find is either related to Nvidia, which doesn't help me at all, or integrated graphics, which I don't have. I'd really appreciate any ideas. TIA.

Are you booting to Wayland every time? Have you tried Xorg with the compositor disabled?

What does "FPS Throttling: Not focused" mean? Maybe you should direct your efforts to learning more about that.


I'm not running dual box. I'm not running more than one toon, and I have only one monitor. Also, as I mentioned, I'm only using Eve because it's a fast install with an FPS counter, it's doing this on all my games across steam and lutris. I have tried with only x11, I've tried with Wayland, i've tried the Linux zen kernel, the mainline kernel, the cachyos kernel. For some reason the culprit seems to come either during, or just after the second reboot, but I can't even say that for positive, because sometimes the second reboot doesn't do it. It's not even limited to Garuda. I installed Endeavour and Regata and had the same on that one. BUT installing a fedora based distro (Nobara) I didn't see this problem at all.

Have you tested starting from a cold boot (fully shut down, wait a few seconds, power back on) instead of a reboot?


Lololol...yeah, I've tried turning it off and on again a few times, as well. Of varying lengths, even. From a few seconds to overnight. I even cleared the CMOS for no good reason, at all, because I knew that wasn't going to do anything. I give up. I just don't know enough about Linux, yet, for an endeavour like this. As much as I absolutely love this distro, and I really mean that, dr460nfire, and everyone else that works on this, have done an absolutely stellar job. I really think it's just one of those "arch problems" that I'm just not skilled enough for...yet. So, reluctantly I'm moving back to Nobara. Maybe in 6-8 months, a year, or so both Arch, Garuda, and I will have come far enough that I can confidently mess with it. Hopefully, by then, they'll have implemented Wayland in the install. Thanks for the help !!! :peace_symbol:

I mean, if anyone stops by and thinks they have an idea, I'm still open to hear them. I know it's not Garuda, because every single arch based distro that I tried did this to me. Either it's something in arch, or my hardware doesn't want to play nice with something in arch. I've since installed Nobara, got everything setup the way I want, installed and setup doom emacs, and everything still runs perfectly. I'm already halfway to making Nobara "look" like Garuda. I just don't get it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.