FPS doesn't rise anymore 60

Hello
I have installed nvidia-prime to switch overdiscrete video card.When i run prime-run glxgears get 60 FPS same in games.

prime-run glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
302 frames in 5.0 seconds = 60.345 FPS
301 frames in 5.0 seconds = 59.990 FPS
301 frames in 5.0 seconds = 60.006 FPS
X connection to :0 broken (explicit kill or server shutdown).

garuda-inxi :

garuda-inxi
System:
Kernel: 5.18.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=249f7653-9c53-4673-b1fb-cfac05f66ac8 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Inspiron 3558 v: N/A
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Dell model: 0G1TDD v: A00 serial: <superuser required> UEFI: Dell
v: A21 date: 07/09/2020
Battery:
ID-1: BAT0 charge: 7.7 Wh (100.0%) condition: 7.7/37.3 Wh (20.6%)
volts: 16.6 min: 14.8 model: Panasonic DELL 78V9D65D type: Li-ion
serial: <filter> status: full
CPU:
Info: model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 built: 2015-18 process: Intel 14nm family: 6
model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1730 high: 2614 min/max: 500/2700 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1818 2: 2614 3: 1079
4: 1409 bogomips: 17557
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel
arch: Gen8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
Device-2: NVIDIA GK208BM [GeForce 920M] vendor: Dell driver: nvidia
v: 470.129.06 alternate: nouveau,nvidia_drm non-free: 470.xx+
status: legacy-active (EOL~2023/24) arch: Kepler process: TSMC 28nm
built: 2012-18 pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max: gen: 2
speed: 5 GT/s lanes: 8 bus-ID: 08:00.0 chip-ID: 10de:1299 class-ID: 0302
Device-3: Suyin Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 2-5:3 chip-ID: 064e:9209 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
alternate: fbdev,intel,nouveau,nv,vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: BOE Display 0x0615 built: 2014 res: 1366x768
hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81")
diag: 389mm (15.3") ratio: 16:9, 15:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Device-3: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max: gen: 2 speed: 5 GT/s
lanes: 8 bus-ID: 08:00.1 chip-ID: 10de:0e0f class-ID: 0403
Sound Server-1: ALSA v: k5.18.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.54 running: yes
Network:
Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:08b3 class-ID: 0280
IF: wlp6s0 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000
bus-ID: 07:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 2-6:4 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 27.9 GiB (6.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABF050
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 2D scheme: GPT
Partition:
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 27.9 GiB (6.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 27.9 GiB (6.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 27.9 GiB (6.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 27.9 GiB (6.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 58.0 C mobo: 57.0 C
Fan Speeds (RPM): cpu: 2688
Info:
Processes: 219 Uptime: 2h 6m wakeups: 1 Memory: 7.67 GiB
used: 2.37 GiB (30.9%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1269 lib: 324
Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-07-07
Last full system update: 2022-07-08
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            [email protected]:dell::kbd_backlight.service

That would be because it's

1 Like

Can this be turned off somehow?

Yes.

But before that, what are you hoping to gain by running the game at a higher refresh rate?

2 Likes

get over 60 FPS

That didn't answer my question.

Q: "Why do you want more than 60FPS?"
A: "To get more than 60FPS"

Let me rephrase the question: What gameplay problem is caused by having vsync enabled?

4 Likes

For games 60 FPS is not enough,lags

You are running a 920m depending on your game ? what are you expecting?

3 Likes

There are several places where vsync might be being enforced.

I'd start with the KDE compositor,

https://wiki.archlinux.org/title/KDE#Disable_compositing

then move onto PRIME Sync:

https://wiki.archlinux.org/title/PRIME#PRIME_synchronization

2 Likes

on Windiws gave 100 fps in CS GO, and Linux does not give more than 60

thanks i will try now

Hi there, welcome to the community !
Firstly, you should compare apples with apples.

This is not the CS GO fps, it is just the refresh rate of your screen.

You have to measure fps from CS GO, the same way you measure in windows.
For example, on my laptop

prime-run glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
723 frames in 5.0 seconds = 144.410 FPS
721 frames in 5.0 seconds = 144.018 FPS
721 frames in 5.0 seconds = 144.034 FPS

Though, CS GO FPS may even be as large as 400+ in game. See,

( I am not a very good at playing games though :sweat_smile: )

So, you have to

  1. Enable commands in CS GO settings.

  2. Press ` from your keyboard. This should open command console.

  3. Type net_graph 1 This should show statistics at the bottom of your screen.

  4. Type fps_max_menu 400 and fps_max 400 to set upper limit to 400 fps. ( I set it to 1000, but it will rarely reach it. So, 400 would be more than enough)

  5. Start playing the game, and notice the fps and ping and other stats, and compare them with windows.

If your fps is still low, I will be happy to help.

4 Likes

You are supposed to study and not play :smiley:

3 Likes