Force close programs after uninstalling nohang

Hello.

System:
  Kernel: 5.16.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=f8db34a7-2ded-4c56-a778-9d9440007d33 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma 5.24.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: P7H55-M v: Rev X.0x
    serial: <superuser required> BIOS: American Megatrends v: 1302
    date: 04/25/2011
CPU:
  Info: model: Intel Core i3 540 bits: 64 type: MT MCP arch: Westmere
    family: 6 model-id: 0x25 (37) stepping: 5 microcode: 0x7
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 3044 high: 3077 min/max: N/A cores: 1: 2947 2: 3077
    3: 3077 4: 3077 bogomips: 24619
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: Micro-Star MSI
    driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:1402 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2390x1280 s-dpi: 84 s-size: 723x387mm (28.5x15.2")
    s-diag: 820mm (32.3")
  Monitor-1: HDMI-0 res: 1366x768 hz: 60 dpi: 85
    size: 409x230mm (16.1x9.1") diag: 469mm (18.5")
  Monitor-2: DVI-D-0 res: 1024x1280
  OpenGL: renderer: NVIDIA GeForce GTX 950/PCIe/SSE2 v: 4.6.0 NVIDIA 510.54
    direct render: Yes
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
    class-ID: 0403
  Device-2: NVIDIA GM206 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fba
    class-ID: 0403
  Sound Server-1: ALSA v: k5.16.10-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8P67 and other motherboards driver: r8169 v: kernel
    port: d800 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 2-1.4.1.2:6 chip-ID: 0a12:0001 class-ID: fe01
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 763.85 GiB used: 109.05 GiB (14.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-9WS142
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: SDM1
    scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST320LT012-1DG14C
    size: 298.09 GiB block-size: physical: 4096 B logical: 512 B
    speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: LVM1
    scheme: MBR
Partition:
  ID-1: / raw-size: 298.09 GiB size: 298.09 GiB (100.00%)
    used: 109.05 GiB (36.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 298.09 GiB size: 298.09 GiB (100.00%)
    used: 109.05 GiB (36.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-3: /var/log raw-size: 298.09 GiB size: 298.09 GiB (100.00%)
    used: 109.05 GiB (36.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/tmp raw-size: 298.09 GiB size: 298.09 GiB (100.00%)
    used: 109.05 GiB (36.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.39 GiB used: 1.21 GiB (35.6%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 44.0 C mobo: 30.0 C gpu: nvidia temp: 31 C
  Fan Speeds (RPM): cpu: 2163 case-1: 0 gpu: nvidia fan: 42%
  Power: 12v: 12.32 5v: N/A 3.3v: 3.33 vbat: N/A
Info:
  Processes: 233 Uptime: 3h 38m wakeups: 0 Memory: 3.39 GiB
  used: 2.43 GiB (71.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1786 lib: 518 Shell: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.5-1):
  System install date:     2022-02-22
  Last full system update: 2022-02-25
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            [email protected] 


I had a problem with forced closing of programs (presumably as a measure of protection against OOM). I wanted to get rid of this by removing nohang, but even after I removed nohang, I cleared all directories that mentioned nohang (by removing the package with " paru -Rss nohang "
,after deleted all directories with the name of the package
" find. -name 'nohang' ")
, and this did not lead to any result, except that the notification about the lack of memory was gone, but the programs still closed.

What program were you trying to run?
As you only have 4gig of ram

2 Likes

This is a really limited amount of RAM for a modern desktop OS. You might want to upgrade your PC hardware at some point.

3 Likes

this application close problem has happened to almost every one of my everyday apps (discord, firefox, telegram) and the problem here is that on a different system (pure arch) without nohang pre-installed, these and other memory-intensive programs didn't cause problems with OOM and worked stably. I just need to disable this annoying daemon that closes my programs without my knowledge.

How much RAM does that one have?

1 Like

The problem here is that this is a different system.

It is not Arch.

If you wish to know more about why this is so, please spend a bit more time investigating before removing integral system parts then complaining when it goes tits up. No matter it was in a very clumsy manner.

I run plain old Arch & various DE/WMs on an old, 2010 low-end 2nd Gen. Intel laptop without problems as long as I don't try to exceed the limitations inherent in running a new system on old hardware. When I install Garuda dr460nized it slows to a crawl, and even the most conservative settings do little to improve the 'feel' of it. Not so much the WMs, although I'm just beginning exploring them. Upping the RAM to 6 gigs with old boards scavenged from otherwise dead PCs helped quite a bit, but still not enough for dr460nized.

So my suggestions are thus;
install more RAM and,
Use a less intensive DE or WMs and,
Less aggressive Garuda settings or,

Run vanilla Arch since you're successful in that. I do. You can easily add the Chaotic-AUR repository and Garuda has all their configs at Garuda Linux · GitLab (as shown on the page header) so it's easy to make it nearly-Garuda, and a fair shake for that old dungmobile you're driving. :wink:

And welcome to Garuda Linux! :smiley:

3 Likes

Hi there, welcome to the community.

You can disable nohang from Garuda Assistant. But beware You are responsible for your pc hanging and any data loss that may happen due to it.

2 Likes

I already disabled the item "nonang enable" and it did not help

In which case it's not related to the nohang service.

As already pointed out, 3GB of RAM is not enough for a modern desktop OS.

4 Likes