Font glaring after gnome upgrade in xorg/x11

I like wayland and use it as my main compositor on other distros but here on gnome I had horrible fonts glaring and rendering issues so that was the main/only reason why I switched back to xorg (editing the gdm/custom.conf file) since under xorg everything was polished and crisp.

Now I don't know what happened but I guess few days ago there must have been a global gnome update since I noticed my /etc/gdm/custom.conf had been overwritten and I was back on wayland again. I noticed that because of this very font issue I spoke before (meaning on wayland it's always there). So I switched back to xorg but this time the font glaring issue has been carried over on xorg too!

I checked my display settings and other stuff font related (antialias and hue settings) but nothing has changed that I am aware of. My main display is a 4k tv but setting it up with 'adjust for tv' made it possibly even worse. The problem is clearly there on my secondary monitor too so that's not an hardware related issue with my tv.

This is a major issue for me since I read a lot every day and it will for sure require a reinstall if I can't fix it.

Here a cpl of screenshots from my terminal and browser to hopefully show up how bad this is:

  Kernel: 6.3.2-AMD arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd
    root=UUID=62a91f89-2c4b-4d73-871c-5da143c10cb3 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: GNOME v: 44.1 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 44.1
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG CROSSHAIR VII HERO v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 4703
    date: 03/01/2022
  Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 2 microcode: 0xA201205
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 3695 high: 3700 min/max: 2200/4950 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3700 2: 3700
    3: 3700 4: 3700 5: 3700 6: 3700 7: 3700 8: 3700 9: 3700 10: 3700 11: 3700
    12: 3700 13: 3599 14: 3700 15: 3700 16: 3700 17: 3700 18: 3700 19: 3700
    20: 3700 21: 3700 22: 3700 23: 3700 24: 3700 bogomips: 177653
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: XFX
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 13:00.0 chip-ID: 1002:73bf
    class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: 0
  Monitor-1: DP-3 model: AOC U3477 serial: <filter> built: 2015
    res: 3440x1440 dpi: 109 gamma: 1.2 size: 800x335mm (31.5x13.19")
    diag: 867mm (34.1") modes: max: 3440x1440 min: 720x400
  Monitor-2: HDMI-A-1 model: Samsung serial: <filter> built: 2020
    res: 3840x2160 dpi: 103 gamma: 1.2 size: 1872x1053mm (73.7x41.46")
    diag: 1093mm (43") ratio: 16:9 modes: max: 3840x2160 min: 720x400
  Message: No known Wayland EGL/GBM data sources. API: EGL/GBM
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 13:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 16:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.3.2-AMD status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 0d:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp13s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: Realtek Bluetooth 5.1 Radio driver: btusb v: 0.8 type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:2 chip-ID: 0bda:a725
    class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 6.82 TiB used: 63.46 GiB (0.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 4B2QEXM7 temp: 28.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: Western Digital
    model: WD BLACK SN850X 1000GB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 620311WD temp: 33.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD15EADS-00P8B0
    size: 1.36 TiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: N/A serial: <filter> fw-rev: 0A01 scheme: MBR
  ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD40EZRZ-75GXCB0 size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A80 scheme: GPT
  ID-1: / raw-size: 200 GiB size: 200 GiB (100.00%) used: 63.35 GiB (31.7%)
    fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:10
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 117.5 MiB (23.0%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:7
  ID-3: /home raw-size: 200 GiB size: 200 GiB (100.00%)
    used: 63.35 GiB (31.7%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:10
  ID-4: /var/log raw-size: 200 GiB size: 200 GiB (100.00%)
    used: 63.35 GiB (31.7%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:10
  ID-5: /var/tmp raw-size: 200 GiB size: 200 GiB (100.00%)
    used: 63.35 GiB (31.7%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:10
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.25 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 47.1 C mobo: N/A gpu: amdgpu temp: 32.0 C
    mem: 34.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 879
  Processes: 508 Uptime: 23m wakeups: 0 Memory: available: 31.25 GiB
  used: 3.71 GiB (11.9%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1382 libs: 371 tools: pamac,paru Shell: Zsh v: 5.9 running-in: kitty
  inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-03-28
  Last full system update: 2023-05-14 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

Just reboot and check.

My eyes are not the best anymore and the forum software reduces the resolution of pictures, but I don't see the problem. Probably because I don't have a reference image to see the difference.


Can you describe the problem another way? The screenshots do not clearly illustrate any kind of issue (they look like just normal screenshots to me).


It's like a halo of white/brightness around each and every letter or icons since they are technically fonts too (nerd fonts that is). Nothing in images, bezels, any other graphical element of the page. A bit like in a 3d movie where 2 images are out of phase or as if the RGB layers were not really mixed together properly. I think one could call it 'blur' but it's really a bit bright. Makes the space between the letter 'i' and the dot above it imperceptible. Small fonts are almost unreadable and normal size fonts give you headache after 5 minutes of reading.
In all my wayland install it's pretty evident across all the distro I tried (a lot of distro) but not in xorg. Did you guys never noticed it on wayland?

ps: I did reboot a bunch of times, both in wayland and xorg back and forth few times. Now I'm here after at least 3 reboot in xorg.

What is the global scaling set to? Check if the issue goes away when set to 100%.

If you mean in Gnome Tweaks, it's set to 1.31. I just tried bringing it to 1 and nothing changed. I mean, it's worse now cause fonts are smaller but it's basically the same.

Hmm, this sounds like something else. The global scaling should be in the normal settings--not Gnome Tweaks.

If you meant the display settings then it's always been 100%

Gotcha, it must be something else then. Have you tried disabling all installed extensions?

I only have a cpl of gnome extensions (just perfection and floating dock) and always had them. I'm sure it's something related to a recent update since nothing changed in my personal install or config files.

I found out what it was. I connected my Raspberry Pi to my tv yesterday and for whatever reason it nuked all my custom settings on the tv, bringing back sharpness and contrast to full blown range and most of all switching to 'dynamic range' which is what creates the 'glaring effect' in the first place.

I think we can call this solved, except I'd still be interested in how to fix it on wayland (that I'm sure has nothing to do with my tv)

1 Like

I think it most likely does have to do with the TV, since the screenshots you posted do not have the issue you have described. Examine the screenshots from another device and you will see what I mean.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.