Fn + F2 keybind "reloads"

Hi, I dont exactly know what Fn + F2 does, it just reloads everything. But id like to unbind it but can find the option to remove it. Any tips would be nice

System:
  Kernel: 5.16.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=f181ffc3-cea3-4242-9c63-210fcfa3609e
    rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DV_FX505DV v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FX505DV v: 1.0 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: FX505DV.312 date: 01/28/2021
Battery:
  ID-1: BAT0 charge: 40.4 Wh (99.5%) condition: 40.6/48.1 Wh (84.5%) volts: 12.5 min: 11.7
    model: FX50442 type: Li-ion serial: N/A status: N/A
CPU:
  Info: model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen/Zen+
    note: check family: 0x17 (23) model-id: 0x18 (24) stepping: 1 microcode: 0x8108102
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 384 KiB
    desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2887 high: 3693 min/max: 1400/2100 boost: enabled scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 2716 2: 3693 3: 3238 4: 3691 5: 2462
    6: 2416 7: 2442 8: 2440 bogomips: 33537
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: ASUSTeK driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f11 class-ID: 0300
  Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile Series] vendor: ASUSTeK
    driver: amdgpu v: kernel bus-ID: 05:00.0 chip-ID: 1002:15d8 class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 5-1:2
    chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver: loaded: modesetting,nvidia
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6")
    diag: 395mm (15.5")
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.1-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169
    v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave
    driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: d000 bus-ID: 04:00.0 chip-ID: 10ec:c822
    class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
Bluetooth:
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-4:3
    chip-ID: 13d3:3548 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 213.76 GiB (44.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200V MTFDHBA512TCK size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: P1MA0V4 temp: 47.9 C scheme: MBR
Partition:
  ID-1: / raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 213.76 GiB (44.8%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-2: /home raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 213.76 GiB (44.8%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /var/log raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 213.76 GiB (44.8%)
    fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-4: /var/tmp raw-size: 476.93 GiB size: 476.93 GiB (100.00%) used: 213.76 GiB (44.8%)
    fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.26 GiB used: 1.76 GiB (24.2%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 70.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 3000
  GPU: device: nvidia screen: :0.0 temp: 50 C device: amdgpu temp: 80.0 C
Info:
  Processes: 322 Uptime: 1h 36m wakeups: 1 Memory: 7.26 GiB used: 5.67 GiB (78.1%) Init: systemd
  v: 250 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1573 lib: 459
  Client: Unknown Client: garuda-assistant inxi: 3.3.12

Any useful info rummaging in System Settings / Shortcuts and Custom Shortcuts?

1 Like

Time to learn, how to search

Sometimes the manuals can help, too.

Please follow next time the template.

Post your terminal/konsole in- and output as text (no pictures) from:

garuda-inxi
Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

3 Likes

I did already go through every shortcut but didnt find one with Fn + F2, I even tried ones that looked close to it like ctrl + F2 cause it was the only one close to it.

Why do you not post the full garuda-inxi?
Use garuda-assistant if you can't handle it.

Check also your laptop manual about FN keys.

2 Likes

Hi @Muddyfox

The function key shortcuts are usually hardcoded into keyboard. They actually work like dedicated key. For example if your keyboard has button to Raise Volume, take example as Fn+F7 in my laptop keyboard. It actually send command "Audio volume up" (to cinnamon in my case), as if it was a dedicated key to raise volume in my keyboard.

The best workaround that I know to prevent function by particular key, would be reassign it to empty command/other useful command you like, from your DE settings.

2 Likes

My Fn + F2 should just lower the volume and it does but right afterwards it does this reload thing.
@SGS I did update the inxi

Nope, but as and Naman said, check your hardware manual

4 Likes

What is reloading, exactly? Can you be more specific about what is happening?

4 Likes

Look in the manual, please, what F2 do.
image

2 Likes

Perhaps if you care to explain the "reload thing" those who actually know how it works can understand what's going on.


Those Fn key combos are tricky and hardware model specific, and they don't necessarily generate regular keyboard scan codes. Some do not report being pressed at all.
It may be the case they cannot be easily rebound/repurposed like the other keys, or not at all.
Being non-standard, it may be some models are not very well supported in Linux -- or rather, they don't support Linux. Hardware vendors generally don't publish the necessary information and only care about making their stuff work with Windows.

Some easily found entry points to the rabbit hole:
https://search.garudalinux.org/search?q=linux+how+are+laptop+fn+key+combos+handled
drivers - How to debug keyboard on Linux - Unix & Linux Stack Exchange
Laptop/ASUS - ArchWiki -- your particular model isn't listed, but I can see some have all the Fn working out of the box and some do not.


Seeing you are on X11, you could try running xev (not sure if it comes with X11 or should be installed separately), press Fn+F2 and report the output here.

Or, just give up using Fn+F2 and bind some other key combo to volume up/down.

3 Likes

Its like loging out but much faster (about 4 times faster).
The Output of xev is:

KeymapNotify event, serial 41, synthetic NO, window 0x0,
keys:  4294967180 0   0   0   0   0   0   0   0   0   0   0   0   0   0   4   
0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

KeyRelease event, serial 41, synthetic NO, window 0x3800001,
root 0x88c, subw 0x3800002, time 306940, (32,54), root:(996,112),
state 0x10, keycode 122 (keysym 0x1008ff11, XF86AudioLowerVolume), same_screen YES,
XLookupString gives 0 bytes: 
XFilterEvent returns: False

FocusOut event, serial 41, synthetic NO, window 0x3800001,
mode NotifyGrab, detail NotifyAncestor

That hints at some important process crashing, once I got a similar thing fiddling around with Sway stuff (I use that not KDE) but hold on I can't remember what to look for. :man_shrugging:

edit: Just to make sure I'm not misunderstanding, after pressing Fn+F2 you have log back in, that is, you are asked the user password again, is that correct? And previously open applications, are they still there or disappeared?

edit #2: More relevant information in case you did not find it yet:
Keyboard input - ArchWiki
Extra keyboard keys - ArchWiki
I can't praise the Arch wiki enough, always straight to the point.

If you too suspect it's really the X session crashing, you may (or may not) find a clue in some log files and/or start the session manually from a console (not the GUI terminal) to see if there are any obvious error messages (it will likely spit an amount of incomprehensible stuff, the last lines before it closes should be the relevant ones).

This, only if you actually care to debug the issue and learn something in the process, otherwise if you simply want a functioning key shortcut to volume up/down, just bind some other key combo and call it a day. Sometimes, a problem circumvented is a problem solved.

P.S. I don't see anything wrong in the xev but I'm no expert.

Yes exactly
Thanks for your help I will try to find log that could be important to it and update the thread accordingly

I forgot to ask, does it logout (or whatever to that effect) only with Fn+F2 volume down, and not Fn+F3 volume up? Or do they both cause the problem?
Binding another key combo to volume up/down, does it cause problems?
Changing volume by any other means, does it cause problems?
Make sure to reach end-of-scale (0% and 100% that is) when testing the above and insist to do volume down when it's already 0 and volume up when it's already 100.

3 Likes

I might want to take a look at my BIOS settings to see if they address my keybindings.

EDIT: Accidently posted to this old thread.