Flickering while sharing screen online over Teams

So, I was sharing my screen over Teams on the browser today and noticed this weird flickering. I stumbled upon this before, and just decided to leave it be since I wouldn’t be doing it again… or so I thought.

Out to search for screen flickering on KDE while sharing the screen, I found this video from 2 years ago saying to disable blur. That seemed to solve the issue, but then I noticed all my Dolphin windows now have transparency. So I open settings again to try and find where to disable this transparency… found none, gave up. Ran something from the Dolphin folder and things get hectic. All over the desktop.

Until I get back on settings and reenable blur. Then all goes back to normal.

I have no idea what is going on here? The flickering I’m seeing is only on the transmitted video feed, not on my desktop itself, on the top of the screen, but the behavior is pretty similar to the one shown on the video.

  Kernel: 6.6.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c614a0f3-47fd-4aea-8dbb-d006e8a7cd65 rw rootflags=subvol=@
    quiet resume=UUID=510675e6-47ee-4beb-9916-7dec4be6849f loglevel=3
    modeset=1 fbdev=1 ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: G5 5590 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0CNDTP v: A04 serial: <superuser required> UEFI: Dell
    v: 1.13.2 date: 05/22/2020
  ID-1: BAT0 charge: 42.8 Wh (100.0%) condition: 42.8/60.0 Wh (71.4%)
    volts: 16.9 min: 15.2 model: SMP DELL JJPFK87 type: Li-poly serial: <filter>
    status: full
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3066 high: 3102 min/max: 800/4500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3100 2: 3100 3: 2701
    4: 3102 5: 3100 6: 3100 7: 3100 8: 3100 9: 3099 10: 3100 11: 3100 12: 3100
    bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: none off: eDP-1 empty: DP-2, DP-3, HDMI-A-2, HDMI-A-3
    bus-ID: 0000:00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Dell
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-10; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 ports: active: none
    off: DP-1,HDMI-A-1 empty: none bus-ID: 0000:01:00.0 chip-ID: 10de:1f11
    class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0c45:671f
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    unloaded: intel,nouveau alternate: fbdev,nv,vesa dri: iris
    gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x2160 s-dpi: 114 s-size: 571x482mm (22.48x18.98")
    s-diag: 747mm (29.42")
  Monitor-1: DP-1 mapped: DP-0 note: disabled pos: primary,top
    model: LG (GoldStar) HDR WFHD serial: <filter> built: 2018 res: 2560x1080
    hz: 60 dpi: 81 gamma: 1.2 size: 798x334mm (31.42x13.15")
    diag: 869mm (34.2") modes: max: 2560x1080 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled pos: bottom
    model: LG (GoldStar) ULTRAWIDE serial: <filter> built: 2013 res: 2560x1080
    hz: 60 dpi: 96 gamma: 1.2 size: 677x290mm (26.65x11.42")
    diag: 628mm (24.7") modes: max: 2560x1080 min: 640x480
  Monitor-3: eDP-1 mapped: eDP-1-1 note: disabled model: BOE Display 0x084a
    built: 2018 res: 2560x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
    surfaceless: drv: nvidia x11: drv: nvidia inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
    memory: 5.86 GiB
  API: Vulkan v: 1.3.269 layers: 14 device: 0 type: integrated-gpu
    name: Intel UHD Graphics 630 (CFL GT2) driver: mesa intel v: 23.2.1-arch1.2
    device-ID: 8086:3e9b surfaces: xcb,xlib device: 1 type: discrete-gpu
    name: NVIDIA GeForce RTX 2060 driver: nvidia v: 545.29.06
    device-ID: 10de:1f11 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:10f9
    class-ID: 0403
  Device-3: Generalplus USB Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-4.1:4 chip-ID: 1b3f:2008 class-ID: 0300
  Device-4: Realtek USB Audio driver: snd-usb-audio type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4.5:8 chip-ID: 0bda:4014
    class-ID: 0102 serial: <filter>
  API: ALSA v: k6.6.7-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek vendor: Dell driver: r8169 v: kernel port: 3000
    bus-ID: 0000:3b:00.0 chip-ID: 10ec:2502 class-ID: 0200
  IF: enp59s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Dell driver: ath10k_pci v: kernel bus-ID: 0000:3c:00.0
    chip-ID: 168c:003e class-ID: 0280
  IF: wlp60s0 state: down mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 6-1.2:3
    chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: enp58s0u1u2 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-6d4b4771a2f9 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: vethda4f11c state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:7 chip-ID: 0cf3:e007
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
    driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
    chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 1.14 TiB used: 712.76 GiB (60.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN520 NVMe WDC 256GB size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B tech: SSD serial: <filter> fw-rev: 20240012 temp: 44.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10SPZX-75Z10T3 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 4514 scheme: GPT
  ID-1: / raw-size: 221.33 GiB size: 221.33 GiB (100.00%)
    used: 116.75 GiB (52.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 592 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 221.33 GiB size: 221.33 GiB (100.00%)
    used: 116.75 GiB (52.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 221.33 GiB size: 221.33 GiB (100.00%)
    used: 116.75 GiB (52.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 221.33 GiB size: 221.33 GiB (100.00%)
    used: 116.75 GiB (52.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.43 GiB used: 3.09 GiB (20.0%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.84 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 66.0 C pch: 66.0 C mobo: N/A gpu: nvidia
    temp: 51 C
  Fan Speeds (rpm): N/A
  Processes: 406 Uptime: 8h 45m wakeups: 0 Memory: total: 16 GiB
  available: 15.43 GiB used: 10.83 GiB (70.2%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 1965
  pm: pacman pkgs: 1958 libs: 542 tools: octopi,paru pm: flatpak pkgs: 7
  Shell: Zsh v: 5.9 running-in: kitty inxi: 3.3.31
Garuda (2.6.19-2):
  System install date:     2023-11-10
  Last full system update: 2023-12-15
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:         

I ran into this same issue with OBS. I never looked too deep into it, but I found disabling the compositor works fine for me. It’s quick and easy to toggle before recording/streaming. In KDE you can toggle it with Shift+Alt+F12.

If I had to guess, I’d say it has to do something with the transparency/blur effects of the panels. If disabling the entire compositor isn’t a route you want to go, maybe you can try targeting the panel’s opacity setting instead.


I tried messing around with blur, couldn’t find anything about transparency, but everytime I mess with blur things go bad trip crazy

The panel has it’s own setting for transparency. If you right-click it, and enter edit mode, it’s inside the more options menu labeled opacity. I can’t guarantee that setting it to opaque will solve the issue, though. I tried to test it, but of course I couldn’t get it to flicker while trying :sweat_smile:.


yeah, I found it… didn’t help either =(

Interesting. Then my assumption about it being the panel transparency is incorrect. Do you still see the flickering after disabling the compositor entirely? I’m assuming no, as you said disabling blur worked.

To be honest, I’m not really sure where all the transparency settings are. Panel has it’s own, there’s some settings inside settings > appearance > applications styles > pencil icon button > transparency, some themes include this, kvantum, there used to be a setting in desktop effects which I don’t see, etc. It’s kind of all over the place.

I wrote a small script to toggle blur and attached it to a custom shortcut


cval=$(grep "^blurEnabled" ~/.config/kwinrc | sed s/^blurEnabled=//)
nval=$([ $cval == "false" ] && echo "true" || echo "false")

kwriteconfig5 --file ~/.config/kwinrc --group Plugins --key blurEnabled "$nval" && qdbus org.kde.KWin /KWin reconfigure

But I know you said that Dolphin is transparent and things go wonky when you disable it. I also have mouse wheel setting inside window management > window behavior > window actions set to change opacity when holding down Meta. Though I don’t know if this will help if the transparency is coming from a theme, and not window rules.

Hopefully someone else that knows the system better chimes in.

I just noticed @sgs’s edit here… I’m not sure this is exclusive to Teams, as I remember having the same problem with OBS streaming. I was going to test it again and up somewhere to share, but OBS decided to segfault.

─Δ obs
debug: Found portal inhibitor
debug: Attempted path: share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: share/obs/obs-studio/locale.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale.ini
debug: Attempted path: share/obs/obs-studio/locale/pt-BR.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/pt-BR.ini
info: Using preferred locale 'pt-BR'
debug: Attempted path: share/obs/obs-studio/themes/Yami.qss
debug: Attempted path: /usr/share/obs/obs-studio/themes/Yami.qss
warning: [Safe Mode] Unclean shutdown detected!
warning: [Safe Mode] User elected to launch normally.
info: Using EGL/X11
info: CPU Name: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
info: CPU Speed: 800.019MHz
info: Physical Cores: 6, Logical Cores: 12
info: Physical Memory: 15803MB Total, 4363MB Free
info: Kernel Version: Linux 6.6.7-zen1-1-zen
info: Distribution: "Garuda Linux" Unknown
info: Desktop Environment: KDE (KDE)
info: Session Type: x11
info: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.21.1
info: Qt Version: 6.6.1 (runtime), 6.6.1 (compiled)
info: Portable mode: false
info: OBS 30.0.2-1 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
	samples per sec: 48000
	speakers:        2
	max buffering:   960 milliseconds
	buffering type:  dynamically increasing
info: ---------------------------------
info: Initializing OpenGL...
info: Loading up OpenGL on adapter NVIDIA Corporation NVIDIA GeForce RTX 2060/PCIe/SSE2
info: OpenGL loaded successfully, version 3.3.0 NVIDIA 545.29.06, shading language 3.30 NVIDIA via Cg compiler
info: ---------------------------------
info: video settings reset:
	base resolution:   1920x1080
	output resolution: 1280x720
	downscale filter:  Bicubic
	fps:               30/1
	format:            NV12
	YUV mode:          Rec. 709/Partial
info: NV12 texture support not available
info: P010 texture support not available
info: Audio monitoring device:
	name: Padrão
	id: default
info: ---------------------------------
warning: Failed to load 'en-US' text for module: 'decklink-captions.so'
warning: Failed to load 'en-US' text for module: 'decklink-output-ui.so'
libDeckLinkAPI.so: não é possível abrir arquivo compartilhado: Arquivo ou diretório inexistente
warning: A DeckLink iterator could not be created.  The DeckLink drivers may not be installed
warning: Failed to initialize module 'decklink.so'
info: [pipewire] Available captures:
info: [pipewire]     - Desktop capture
info: [pipewire]     - Window capture
warning: v4l2loopback not installed, virtual camera disabled
info: NVENC supported
zsh: segmentation fault (core dumped)  obs

Same thing happens if I choose to launch it in safe mode.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.