Flatpak apps not displayed in the menu

I Installed a flatpak app (spotify) but I can't able to open it then I run it from terminal using the below command and however, the app is opened but in terminal it says this. I think this might be the issue but I don't know how to fix. If you guys know how to fix this issue it would be very helpful for me. Terminal commands are mentioned below:

╭─[email protected] in ~
╰λ flatpak run com.spotify.Client

Note that the directories

'/var/lib/flatpak/exports/share'
'/home/xtarotcards/.local/share/flatpak/exports/share'

are not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.

spotify(-dev and more) is in repositories (chaotic-aur) no flatpak needed.

2 Likes

But when I tried to log in with facebook it said update your spotify

1 Like

why laughing?
OOF

Because of these bugs and non-free software, Snap and Flat are not supported by Garuda.
You are on your own or you should address your questions and complaints to facebook and spotify and not Garuda as we have no control over it.

and
:slight_smile:

4 Likes

This is too general description of the way you use. You haven't even provided any system info.
Are you one of those that don't care about Rules?
I am not sure this is welcome to the forum... :thinking:
Running a flatpak app (not a native archlinux system app) is not always automatic, depending on your DE.
https://wiki.archlinux.org/index.php/Flatpak#Run_applications
https://wiki.archlinux.org/index.php/Flatpak#Adding_Flatpak_.desktop_files_to_your_menu

6 Likes

What shell are you using?

Bash should work fine, using fish as the login shell produces this exact error for me.

1 Like

Following these links works. Thankyou so much

Rather than bumping an old post on a technical help request, you can simply add a "Like" to show your appreciation of helpful posts.

Necrobumping technical threads is discouraged on our forum.

3 Likes