Fish theme issue after update

Hello Garuda users.

After the recent update, I migrate latte to native kde system. But I lose all theme for garuada fish konsole.

Anyone would help me to restore the theme. I tried to reset the fish config from garuda assistant but the effect was to delete all themes ...

Kernel: 6.1.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f327471a-c329-462b-a1dc-fca7bb7580b2 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.0 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 20TH001AFR v: ThinkPad P1 Gen 3
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20TH001AFR v: SDK0T08861 WIN
serial: <superuser required> UEFI: LENOVO v: N2VET26W (1.11 )
date: 11/16/2020
ID-1: BAT0 charge: 70.3 Wh (97.6%) condition: 72.0/80.4 Wh (89.5%)
volts: 16.8 min: 15.4 model: SMP 5B10X19049 type: Li-poly serial: <filter>
status: not charging cycles: 214
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i9-10885H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xF4
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3007 high: 4912 min/max: 800/5300 scaling:
driver: intel_pstate governor: performance cores: 1: 4912 2: 4900 3: 2400
4: 2400 5: 2400 6: 4907 7: 2400 8: 4594 9: 2400 10: 2400 11: 2400 12: 2400
13: 2400 14: 2400 15: 2400 16: 2400 bogomips: 76800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
class-ID: 0300
Device-2: NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] vendor: Lenovo
driver: nvidia v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2023-02) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none off: HDMI-A-1
empty: DP-1,DP-2 bus-ID: 01:00.0 chip-ID: 10de:1fb8 class-ID: 0300
Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-8:2 chip-ID: 04f2:b6cb class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1184x380mm (46.61x14.96")
s-diag: 1243mm (48.96")
Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: top-right
model: Dell U2715H serial: <filter> built: 2016 res: 2560x1440 hz: 60
dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27")
ratio: 16:9 modes: max: 2560x1440 min: 640x480
Monitor-2: eDP-1 pos: primary,bottom-l model-id: CSO 0x1500 built: 2019
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 3840x2160
API: OpenGL v: 4.6 Mesa 22.3.4 renderer: Mesa Intel UHD Graphics (CML GT2)
direct-render: Yes
Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0401
Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Sound API: ALSA v: k6.1.12-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.65 running: yes
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Local Storage: total: 953.87 GiB used: 202.16 GiB (21.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 5108AGLA temp: 42.9 C scheme: GPT
ID-1: / raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 202.13 GiB (34.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 33.6 MiB (13.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 202.13 GiB (34.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 202.13 GiB (34.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 202.13 GiB (34.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.98 GiB used: 1.01 GiB (3.3%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 81.0 C pch: 59.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 4485 fan-2: 4335
Processes: 416 Uptime: 20m wakeups: 5 Memory: 30.98 GiB
used: 8.57 GiB (27.7%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 1589 libs: 375 tools: octopi,paru Shell: fish v: 3.6.0 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.25
Garuda (2.6.15-1):
System install date:     2021-11-16
Last full system update: 2023-02-20
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Other things, but I've not realy invest for now, when I use two screens I can't move a window by taking the top bar with my mouse. I need to reduce the windows to be able to move it.

THank for your help.

Make sure to this as colorscheme for Konsole:


That is sadly unsupported by Plasma panels. I'm also feeling quite bad about this being gone, a workaround could be pressing the meta button while dragging the window.


Indeed change style is the first thing, I'm idiot to not think about this option. But I keep the issue that I no longer have the startup banner on my terminal like the new format or the old :

For the plasma panels issue, I agree it is verry frustrating. The bot panel is painfull to, I can't duplicate panels (top and front) on each screens, the open windows are show only on the active screen. I hope new features and fix soon.

It just spawns a regular shell? Try resetting the fish config via Garuda Assistant in this case. I'm curious, as I never noticed something like this while testing :eyes:

I feel you! I have to admit one gets used to the new layout quite quickly though :slight_smile:
Maybe it is possible to show applications from all screens, I haven't looked into this before.

We are agree that it is the only manipulation : check fish on the assisant and click on reset ?

I try this but nothing

Other interesting thing, the garuda drigonized theme is not set at all. The font color not corresponding

Make sure all fits with what is listed in the blue INFO bubbles here Dr460nized migration info | Garuda Linux wiki

1 Like

All settings are good. The main problem remains that fish konsol initialisation not work as expected. The banner with system info is never display. Look my first screenshoot

Hi All
99% Happy with the Migrations. The Fish Console in the Migrations text has a Dragon :-
How do i get this Dragon ?
All I have is a big 'G' made up of Letters and Numbers.
Then it will be 100%

1 Like

I have nothing at all :smiling_face_with_tear: just the prompt

If I get the Dragon. You can have my big assed 'G' :slight_smile:

It seems we should add the fish config to the migration? :eyes:

The logo is shown via fastfetch:


But how to fix after the migration?

We use a custom fastfetch preset, which can be loaded by fastfetch --load-config dr460nized in ~/.config/fish/


That is amazing.
Also amazing is the fact i worked out how to do it after a tiring days work!

Problem solve !!!!!! and WTF ! fastfetch was not install on my laptop .... I install it from chaotic-aur

@dr460nf1r3 what is your advise fastfetsh from chaotic or garuda-fastfetch-git ?

Every day is a school day.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.