Firefox doesn't render some websites properly

Firefox doesn't render some websites properly.
I have been noticing this issue with websites with intense graphics and stuff like this Samsung's one:

I even tried opening it in firefox's default profile.
This doesn't happen with epiphany or chrome.

Firefox or Firedragon?


Are you facing the same issue?
I am facing the same issue in my Linux Mint installation.

All fine on LibreWolf and FireDragon :smiley:
Open issue on Firefox.

We can not take care of every software in the world :smiley:

Nag the guys to properly support Firefox. All other browsers use webkit and are the same. A lot of web-developers today only test their stuff with webkit.

@SGS I see the same problem here with firedragon. The structure of the page renders ok, but a lot of the graphics are just not displayed (no download issue). So I am pretty sure the developers of the page are at fault here and use some webkit specific hacks.

1 Like

There is no garuda-inxi, so not much context to troubleshoot an issue like this. Not every Firefox session is the same.

  • What version of Firefox are you running? Have you tried ESR, or other spins?
  • What DE is running?
  • A Wayland session, or X11?
  • Is Firefox running in Wayland mode, or Xorg mode? Or Xwayland mode?
  • Have you tried changing any of the above variables?
  • Try TNE's Firefox video acceleration package: paru -S firefox-video-acceleration

I would have wished that the problem pages were posted and not just the home page, possibly I would have looked at more if it was about the Ultra with 12GB/1 TB :slight_smile:


If that helps Austin, I'm at work so no Linux here, I have opened up Firefox in WinCOUGHdows and all renders fine.
It is truly graphics intensive but no slowdown or rendering issue on a 4yo machine (this is bad with Windows). The short animated videos also work fine.

I did get a BSOD while I was writing this, but that has nothing to do with Firefox or that website, as I had closed Firefox prior. loll


I am on my old laptop with Linux-mint, which also has the same issue as on Garuda.
So what happened is my father had to get some work done on our new laptop with Garuda, and he was complaining that some of his work-related websites won't function properly on firefox. I installed chrome for him, and it's working now.
I will share my inxi, and check out your suggestions when I have the laptop.

 garuda-inxi 
  Kernel: 6.1.12-1-cachyos arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
    root=UUID=974f3ce6-ba35-41c5-a737-23cb1e2b873f rw [email protected]
    lsm=landlock,lockdown,yama,integrity,apparmor,bpf quiet splash
    mitigations=off rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 audit=1 amd-pstate=active ibt=off
  Desktop: GNOME v: 43.3 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM v: 43.0
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Acer product: Swift SF314-43 v: V1.04
    serial: <superuser required>
  Mobo: LN model: Sake_CA v: V1.04 serial: <superuser required> UEFI: Insyde
    v: 1.04 date: 07/28/2021
  ID-1: BAT1 charge: 42.8 Wh (93.2%) condition: 45.9/53.2 Wh (86.2%)
    volts: 12.3 min: 11.6 model: COSMX AP20CBL type: Li-ion serial: <filter>
    status: discharging
  Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A
    status: N/A
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608102
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1162 high: 2780 min/max: 400/4056 scaling:
    driver: amd_pstate_epp governor: powersave cores: 1: 400 2: 2070 3: 400
    4: 2780 5: 2071 6: 400 7: 400 8: 2157 9: 2071 10: 400 11: 400 12: 400
    bogomips: 50303
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Lucienne vendor: Acer Incorporated ALI driver: amdgpu
    v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
    class-ID: 0300 temp: 37.0 C
  Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-3:3
    chip-ID: 0408:a094 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 22.1.8
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x683d built: 2019 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.1.12-1-cachyos) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: Acer Incorporated ALI driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_rpl_pci_acp6x,snd_pci_ps,snd_sof_amd_renoir,snd_sof_amd_rembrandt
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound API: ALSA v: k6.1.12-1-cachyos running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: Lite-On driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp1s0 state: down mac: <filter>
  IF-ID-1: enp3s0f3u1c4i2 state: up speed: N/A duplex: N/A mac: <filter>
  Device-1: Lite-On Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-4:4 chip-ID: 04ca:3802 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
  Local Storage: total: 476.94 GiB used: 56.75 GiB (11.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3512B-AA1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EDFK0S03 temp: 41.9 C scheme: GPT
  ID-1: / raw-size: 64.41 GiB size: 64.41 GiB (100.00%) used: 28.7 GiB (44.6%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%)
    used: 308 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 64 GiB size: 64 GiB (100.00%) used: 2.19 GiB (3.4%)
    fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 64.41 GiB size: 64.41 GiB (100.00%)
    used: 28.7 GiB (44.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 64.41 GiB size: 64.41 GiB (100.00%)
    used: 28.7 GiB (44.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.12 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 44.1 C mobo: N/A gpu: amdgpu temp: 37.0 C
  Fan Speeds (RPM): N/A
  Processes: 439 Uptime: 31m wakeups: 5 Memory: 7.12 GiB
  used: 3.14 GiB (44.1%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: 1427 pm: pacman pkgs: 1398
  libs: 360 tools: gnome-software,pamac,paru,yay pm: flatpak pkgs: 29
  Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.25
Garuda (2.6.14-1):
head: cannot open '/var/log/pacman.log' for reading: No such file or directory
  System install date:     
  Last full system update: 2023-02-17
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:
  • I am running firefox 110
  • I am on gnome
  • This issue is there in both wayland and xorg
  • I tried firefox-video-acceleration, it didn't change anything
  • Even firefox-esr has the same issue.

how do I check that?

I suppose everyone is facing this issue in firefox on Linux, but @FGD didn't face it on windows :thinking:.
Actually, I have been noticing this issue in firefox for some time now, whenever the websites have some heavy graphics.

Thanks in advance.

Correct! And I will add to that: I face the same rendering issue as you on Firedragon Linux.


As I already mentioned, this issue is also there in Linux Mint.
So we can conclude Firefox Linux and its derivatives have this issue.

It would be nice if someone could report this bug to Firefox, it would be a little difficult for me as my exams are coming up, and I am also not exactly familiar with this process.

There is an environment variable which can be enabled for better performance on Wayland sessions, see here: Firefox - ArchWiki

If you switch back and forth, an easy way to have this taken care of automatically is add to your .config/fish/

if [ "$XDG_SESSION_TYPE" = "wayland" ]

I also was unable to get this website working correctly, but I'm not so sure there is a bug to report to Firefox or anything like that. It looks like there is a problem with the website:

I tried to force the website to load the page even though it is broadcasting insecure elements, but couldn't quite figure out how to do it despite some hacking around in about:config. I discovered if you toggle security.mixed_content.upgrade_display_content from false to true, it will change the "connection not secure" badge to "connection secure", but it doesn't appear to change the elements displayed on the page in any way.

After working through this page here: Websites look wrong or appear differently than they should | Firefox Help, I found a link at the bottom to report a website that is broken on a specific browser at Here is the issue I raised:

It only took about ten minutes to raise the issue. I'll let you know if they reach out or respond to the ticket in any way.


Now if I try to find non-functioning heavy websites(apple, asus etc.), everything seems to work. I think this Samsung's website was an exception. As far as I remember, I experienced this issue on other websites as well some time back, but now most of those seem to be fixed.
What actually caused me to post this issue here was my father's work-related website not functioning in firefox, and I had to install chrome :sweat_smile:. Now I don't know which website it was, but it didn't have any heavy graphics; it just wasn't responding.

Thanks, @BluishHumility, for submitting the issue at webcompat.

1 Like

Hi to all,

I have the same problem with:

Firefox ESR

When trying the next URL:

Samsung Galaxy S23 Ultra | Samsung India

Here my garuda-inxi:

Garuda's PrivateBin

My scenario is:

Distro: Garuda KDE Dr460nized Gaming Edition
DE: KDE Plasma 5.27.0
WM: KWin (X11)

I alredy have the:

paru -Q | grep firefox-video-acceleration
firefox-video-acceleration 1.0.0-1

More ideas ?

Thanks for your support !

1 Like

I can't tell if you are just trolling or not. Have you had a chance to read through the previous comments in the thread?