Firedragon's whoogle is slow in VM [VM not recommended as it might result in a bad experience!]

Whoogle gave me a very bad user experience as it was very too slow.
Having it in the live iso is not a good thing to do

System:
Kernel: 5.16.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2f2ec219-da15-430d-bc14-a3d8bec36cb5 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 2324FV6 v: ThinkPad X230
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 2324FV6 serial: <superuser required>
UEFI-[Legacy]: LENOVO v: G2ETB7WW (2.77 ) date: 09/24/2019
Battery:
ID-1: BAT0 charge: 37.8 Wh (99.5%) condition: 38.0/57.7 Wh (65.8%)
volts: 12.5 min: 11.1 model: SANYO 45N1031 type: Li-ion serial: <filter>
status: N/A
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:
Info: model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge
family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2895 high: 2993 min/max: 1200/3300 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2993 2: 2894 3: 2865
4: 2830 bogomips: 20751
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-1.6:4 chip-ID: 04f2:b2eb class-ID: 0e02
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: modesetting alternate: fbdev,intel,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: LVDS-1 res: 1366x768 hz: 60 dpi: 125
size: 277x156mm (10.9x6.1") diag: 318mm (12.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Sound Server-1: ALSA v: k5.16.1-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.20 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e
v: kernel port: 6080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
v: kernel bus-ID: 03:00.0 chip-ID: 8086:0085 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-3: Sierra Wireless Sierra Wireless Gobi 3000 Modem device (MC8355)
type: USB driver: qcserial,qmi_wwan bus-ID: 3-4:3 chip-ID: 1199:9013
class-ID: 0000
IF: wwp0s20u4 state: down mac: <filter>
Drives:
Local Storage: total: 119.25 GiB used: 12.36 GiB (10.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Morebeck model: V602 120GB
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1A0 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk
model: Cruzer Blade size: 7.45 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 1.27 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 35.08 GiB size: 35.08 GiB (100.00%)
used: 12.36 GiB (35.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /home raw-size: 35.08 GiB size: 35.08 GiB (100.00%)
used: 12.36 GiB (35.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-3: /var/log raw-size: 35.08 GiB size: 35.08 GiB (100.00%)
used: 12.36 GiB (35.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/tmp raw-size: 35.08 GiB size: 35.08 GiB (100.00%)
used: 12.36 GiB (35.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.43 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 70.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 4189
Info:
Processes: 242 Uptime: 8m wakeups: 3 Memory: 7.43 GiB
used: 2.47 GiB (33.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1404 lib: 327 Shell: fish
v: 3.3.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.11

So how does it do when you install the Live ISO?

1 Like

Sorry i'm not a native english speaker i'm assuming that you are asking how it performs from live iso .
As i stated whoogle is slow from live iso as well as from installed garuda

BTW, I have a lightning fast whoogle here in Firedragon.

I have even provided video evidence what more do you want?
Can i know why you guys use whoogle?
Some one mentioned the browser issues on distrowatch

This was apparently caused by the Nextcloud cronjob running at the VM where Whoogle also resides, after stopping it Whoogle returned to quick results. Guess limiting Nextcloud resources will come in handy here :thinking:

6 Likes

The reviewer didn't even install it on bare metal even though our download page explicitly states performance WILL be bad in VMs. So consider this review invalid, it has no worth if reading of basic instructions fails already. Nevertheless, your point about Whoogle being slow was a good one.

5 Likes

Not to drag this thread off-topic, but I absolutely agree with this.

Installing on bare metal or not, the reviewer appears to have skipped the entire part of the installer where it specifically asks you what software you want to be set up with out of the box.

  1. "Cannot play [media]": my installer gave me a ton of options for software to install, from basic stuff like VLC to robust, task-specific stuff like Darktable.
  2. "Doesn't have Office-suite": my installer offered not just Libre Office but other options as well.
  3. "Doesn't have responsive browser": browser selection was more than generous. I almost never see Vivaldi offered out of the box for example, but there it was.
  4. "Doesn't have email client": seriously? What was the email client that isn't offered, Microsoft Outlook? :laughing:

It's difficult to take this person's opinion seriously when they couldn't even bother to pay attention during the installation. It's like they got 80% finished assembling an IKEA bookshelf, threw the rest in the trash, and then announced "This bookshelf is not that good, it seems like it is missing some shelves." :man_facepalming:

5 Likes

Same here working fine

2 Likes

Forgot to mention that i get this error when trying to search using whoogle

Refresh usually fixes it but today

3 Likes

Sorry, but you might consider a better translator. I asked the opposite. How does it do, meaning perform, after you install the ISO?

3 Likes

if you go down to setting in the browser and change to say Duck Duck does it work if you highlight a word and search? If so it may be issue with the whoogle misdirecting from the browser

I have the same behavior with the page redirection and "Instance has been ratelimited" and I am not in a VM.

I changed my search engine to DDG and DDG is lightning fast, but the "Instance has been ratelimited" of Whoogle persists the same way. I've been trying to find out what that is lately but so far I went nowhere. Still searching, if I find something I'll definately post as I've seen that same error on the Forums now.

2 Likes

@Dr.porkchop Take a look at this, maybe it answers some of your slowlyness?

2 Likes

Why was the title edited to say VM when I'm experiencing this issue in disc installation and live iso?

Maybe it got edited before you mentioned you also experience in Live ISO and the person forgot to change it back afterwards?

I can confirm though that some of what you experience ("Instance has been ratelimited" error page) I also experience on 3 KDE Dragonized (1 VM and 2 physical machines) + on my work Windows [yark] machine + on my Android phone, with VPN enabled and with VPN disabled.

2 Likes

Your Post #4's image says, "I tested the KDE Dragonized under a VM" I would suppose.

"Ratelimiting" is a very interesting topic, by the way. You could probably find a lot of articles concerning its use. Maybe even a few ways to get around it.
:wink:

EDIT: I believe the "fix" for it may be found by doing this

"adding a blank CONFIG_COUNTRY and setting CONFIG_LANGUAGE to lang_en also solved"

As suggested here: [BUG] Captcha for Single-person Use · Issue #558 · benbusby/whoogle-search · GitHub

I had to drill-down from a Google (how ironic) search, and the ratelimiting may be caused by a CAPTCHA bug. I say may. :wink:

Best of luck in your endeavors.

2 Likes

Thats sadly something which happens on Whoogle from time to time as a lot of people are using the instance at the same time. Thanks to Whoogles dev though, we have Farside integration which means choosing another instance to continue searching is easy! :slight_smile: As for the http issue, I have encountered this a few times when changing instances with Farside, I guess I'll file a bugreport if it doesn't exist soon :thinking: Thanks for doing some digging in Whoogles repo already guys :handshake:

4 Likes

I said i found a review on distro watch that says it . I have installed garuda on my laptop as well as pc.
For my system specs i can only imagine how garuda would be performing in VM :fearful:

I'm not trying to fix this issue on my end i'm fine with google and google-chrome .
I'm just concerned about the live iso and newcomers.

1 Like