FireDragon Scaling Wayland Plasma

Hello everyone.

First of all, I’d love to express my love for Garuda Linux community & forums (I always LOVE to be in a community which is rich, helpful and welcoming :slight_smile:).

Being that said, I’ll go with what brings me here today. First goes first, I’m not on Garuda Linux, I’m on our mother, Arch, with the Chaotic-AUR repo added to my pacman.conf file.

I tend to use Brave as my daily driver, but I wanted to check something on my secondary web browser, which is, OF COURSE, FireDragon, and, given that the day before yesterday I enabled in Brave Flags the Ozone to be in Wayland, making Brave into a Wayland native app and just with that change, making it work as it should be with the scaling, (seeing everything really crispy and that), I just remembered that FireDragon is Wayland native with my configuration, just opened and my face turned into sad, it’s blurry, as it was in Brave before doing the change.

So my “shout” is in search of light/help in this matter, to try to make that FireDragon looks as crispy as Brave in Wayland session in Plasma, with the scaling I’ve got configured.

Thank you very much in advance for your help.

Bests :people_hugging: :slight_smile:.

Not sure this will help, anyway… check if this helps:

1 Like

These are the basics, yeah, thanks.
I’ve got that environment variable added to my .zshrc already, qt5-wayland is installed, yeah (it’s a required dependency for plasma-wayland-session), as for the latest one, I had the line to export that environment variable with wayland as the value, not the xcb one, but thanks anyway :slight_smile: :pray:t2:.

Hi @Takuya , in your case you should simply add to /etc/environment a line reading


you can check if you’re using xwayland or the native wayland backend by going to about:support in FireDragon and searching for “wayland” .


Hello mate :slight_smile:.
First of all, thank you very much for the answer.
As I said earlier, I’ve got it on my .zshrc file (thought it was enough with that), but seems I was wrong.
As you pointed out, FireDragon shows xwayland on the about:support page, so I should do what you & the mate pointed before, adding it on /etc/environment, instead of .zshrc and check it out if that fixes the “issue”.

1 Like

Let us know if it works for you and mark it as a solution so other can benefit , have great rest of your day .

1 Like

Good morning, dear mate.
Yeah, sorry to be late on the update, yesterday I wasn’t able to use my PC that much.
I’m afraid that this make it worse than before.
As I show with a few screenshots, now that wayland appears as the Window Protocol, there’re some issues:

  1. The mouse cursor is really tiny, normally.
  2. The Ctrl + Tab (change tab) preview is really broken, as you can see on the first screenshot.
  3. The contextual menu, as well as the tab’s tooltip is buggy too.
  4. Not to mention that the original matter of blurry/not crispy matter is still the same.

Hoping you can help me to fix/find the reason of this issue :sos:.
Thank you very much, as always.

Update/Edit: Sorry about this, it was my problem, I went to about:config before and touched 2 settings there, added a number value which I just deleted, just before writing this, (the value was 2.0, if I remember correctly, it was something that I added trying to force a 2x scaling in FireDragon) & the one I thing it was causing the main disturb, widget.wayland.fractional-scale.enabled, which I had set up to true, I just defaulted to false and the contextual menu, tab cycling preview & tab’s tooltip (name) works again, but the mouse cursor remains tiny, don’t know why, as well, the original issue is still persisting.

Hi again @Takuya , sorry for late response, SO! for the mouse cursor problem just go to :
System Settings > Appearance > Cursors
as shown in the Image :

In below you will see 36 is my cursor size , just chose one you want and it will be fixed .

Now for FireDragon you have to add to /etc/environment a line reading

by going into the terminal and type or just copy it :

sudo nano /etc/environment

you will be asked to enter password so do it , and then you will see text and stuff ,
look like this :

just copy this command :


and paste it anywhere using Cntrl + Shift + V and then click both Cntrl + x to exit , you will see down below a confirmation so type Y (it mean yes make changes) and then click Enter
it look like this :

Then update your system using sudo garuda-update , after finishing the update , reboot ,and then CONGRATS !!! issue will be fixed . Ask anything you need you are in the best community .

1 Like

Hi, dear mate :slight_smile:.
First of all, thank you very much for your response, no worries for the “delay” on it.
And really sorry from my side for the REALLY late response :bowing_man:. Honestly, I totally forgot to check this thread for a few days, being a bit busy with other things :sob:.
Going in order.
First matter. The Cursor.
I use a custom theme, (macOS El Capitan) which, sadly, doesn’t have multiple size, so I can’t customize that :slightly_frowning_face:.

Second matter. The issue with blurry/not crisp in FireDragon. I already added that line in the


As you can see in the screenshot:

I’m not on Garuda, I’m on the mother, Arch, so the command garuda-update doesn’t exist to me, but I guess what it does is to perform a sudo pacman -Syu or something like that.
Just tried to open FireDragon while I was writing this Reply (in Brave), this happened, with a crash of the app a few seconds later :cry:.

Hoping this will be fixed after an update or some change from my side.
As always, thank you very much for your time, effort & reply :pray::people_hugging:.

1 Like

No problem mate, me or others always gonna help ,
So for this problem actually when i got time i will install it in other machine , and test it in Arch and see what is going on . for now this methods mentioned worked well in Garuda , but for Arch , i have to do more research .

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.