FireDragon "Save As" default

The “Save as” dialog has a dropdownmenu with:
(I’ll translate from the german text)
“Website, complete”: Pics etc will go in a subdir (default)
“Website HTML only”: Saves the HTML page only
“Text files”: didn’t tried yet
“All Files”: didn’t tried yet

I will use “HTML only” more often.
Is it possible to change the order? Or make “HTML only” to default?

Bye, Christian

1 Like

Save one into the desired location as HTML only, then the next time you save one it will come up with HTML only as the default format.

That is not working. The Dropdownmenu is the same as before.
What I tried: Lookup a page → Save As HTML-Only somewhere → directly save as again same directory and “Website complete” is back again and saves as complete

Next Try: Another page opening a few sub pages → On a sub page save as HTML → that page again complete is default → close that page and look at the next opened sub page → save as in same directory HTML only → save as again and is complete again (and if i save, it is a complete save).

Bye, Christian

Hi @Amiganer , even though i don’t think is an issue , but there is no such a thing or a feature that can be changed there , at least in Firefox based browsers .


I tried in Firefox directly and you’re right.
I used Brave and Vivali before and they are doing so.

Then it is a “nice to have” thing?

By, Christian

1 Like

Exactly .

1 Like

This is not what happened when I tested. Do you have “Website complete” files saved in that directory? Try moving those out or deleting them, so the directory contains only HTML-only files.

Next Try…

I opened a Webpage, Ctrl-S for Save as, Going to a Directory outside the old one, create a new Directory, Save as with HTML only there. If I open now the “Save as” again, it’s again “save complete”.
Next Webpage, Save as inside the first save, HTML-only, open “Save as” again and “complete” is the default.

I tried without the second “save as” for the same page, no change.

So other ideas?

Under “help” the version of Firefox is 119.0 and garuda-linux 1.0

Does one of you, who knows the Code a little better, is there a option of doing what I want (SAVE as with HTML-only the first time and next time HTML-only is the default till i change that)?

Bye, Christian

This is exactly what it does on my computer. I’m not sure how you got it to switch to another behavior.

I tested further:

  • Save as > “Web Page, complete”
  • Next time I save as, it defaults to “Web Page, complete”
  • Save as > switch to “Web Page, HTML only”
  • Next time I save as, it defaults to “Web Page, HTML only”
1 Like

Thanks. It’a “nice to have”. 1000 Thanks.

Bye, Christian

I realized why we are getting different behavior from this action: I was testing in a browser where there is an override on the hard-coded file picker settings Firedragon ships with. I tested with a KDE install where this setting is intact, and it has the behavior you have described (reverts back to “Web Page, complete” every time).

If you would like to override the hard-coded file picker, you can do so by setting up an override config file.

micro ~/.firedragon/firedragon.overrides.cfg

Paste this into the file:

// Override Firedragon's hardcoded file-picker setting
lockPref("widget.use-xdg-desktop-portal.file-picker", 2);

Press Ctrl+Q to exit Micro (be sure to save), then close and reopen the browser and test again.

The pickers are a little different; here they are side by side:

The KDE version seems to have a couple extra features (you can zoom in on the thumbnails for example), so you’ll have to decide for yourself if it is worth it or not to switch.

1 Like


No change at all. The Picker is the same as before.
So I did:

deinstalled the firedragon, delete the config dir “~/.firedragon” completely.
Made a full update of all, restart.
Re-install firedragon. The “AUR” version breaks with an error, the “chatic-aur” installed fine. A had to select “firedragon kde integration” manually and installed it.

My “~/.firedragon” looks like this:
drwx------ - amiganer 7 Dez 12:31 ez6m6qr2.default-release
drwx------ - amiganer 7 Dez 11:45 rreazmpd.default
.rw-r–r-- 113 amiganer 7 Dez 11:41 firedragon.overrides.cfg
.rw-r–r-- 62 amiganer 7 Dez 11:26 installs.ini
.rw-r–r-- 259 amiganer 7 Dez 11:26 profiles.ini

2 configs???

Inside firedragon I looked up the ¸¸"widget.use-xdg-desktop-portal.file-picker" inside “about:config”: It is greyed out, locked and value is “2”.

I think, are this different configs inside the “~/.firedragon” Directory.
How to cleanup this and make it “the right way”?

Bye, Christian

I see only one .cfg = config file.


The first 2 are directoies with many files inside…
There are no “*.cfg” inside.

And I think that is that is NOT correct here.
But: How to cleanup?
What has to be inside here?

on ¸¸¸¸"GitHub - dr460nf1r3/firedragon-browser: A fork of Librewolf with enhanced KDE integration, saner defaults & custom branding 🐉 (mirrored from GitLab)" I found a config, but where to put what?
Should I delete all files in my “~/.firedragon” and copy the github-one inside for getting a known default config?

By, Christian


my “~/.firedragon/profiles.ini”:





Which profile is the active one at start?
Only the first is “locked”, is that active?

After a while…

I changed a config and so I think the “ez6…” is the active profile, because files inside the directory a upadted in time of the change.

ls .firedragon/

.rw-r--r-- 336 sgs 15 Nov 02:11  firedragon.overrides.cfg
.rw-r--r--  62 sgs  1 Dez  2021  installs.ini
.rw-r--r-- 259 sgs  1 Dez  2021  profiles.ini

There is only one. If you mean firedagon.cfg?
Please, don’t sign your posts — every post has your profile information attached to it. :slight_smile: Keep It Tidy. Thanks.

drwx------ 1 amiganer amiganer 1894 7. Dez 13:33 ez6m6qr2.default-release
drwx------ 1 amiganer amiganer 68 7. Dez 11:45 rreazmpd.default
insgesamt 16
-rw-r–r-- 1 amiganer amiganer 113 7. Dez 11:41 firedragon.overrides.cfg
-rw-r–r-- 1 amiganer amiganer 259 7. Dez 11:26 profiles.ini
-rw-r–r-- 1 amiganer amiganer 62 7. Dez 11:26 installs.ini

there is a default config, but there is no “profiles.ini” (that I have) for activating (?) the setting.

If the “profile.ini” is looked at after the “firedragon.cfg” then we should create one, but the “right way” to keep the firedragon working.

Deleting all files inside “~/.firedragon” leads to a nomore working firedragon.

Hmm, this is a curious result. It appears you have applied the override successfully, but sounds like you are still not getting the “ordinary” picker.

Can you please test Librewolf?

Firedragon is Version 119

Installed librewolf (Version 120)without everything else with Octopi.

started, go to a page, save as HTML-only in my test diretory, open save as again → webpage complete is default

open “Save as”, goto Downloads, create new directory, HTNL-only is okay, open Save as again → Webpage complete is default.

I tried “firefox” before and there is the behavior the same. Someone said earlier that is normal in “Firefox”.