FireDragon Plugins Problem

Hi guys, first of all....thanks a lot to the garuda team....i fell in love on this distro several months ago...and lost the tickling feeling of keep changing distro...hahaha. In any case, im not a coding expert or something, simply enjoy the linux experience.

Lately i got the firedragon browser and i really like it with its lovely detalis like darkreadfer, canvas and u block....and i just make the exceptions on the tabs i dont want them. Nevertheless i also love to watch plex and netflix and both of them need some plugins of widevine and cisco thing (screenshot attahced). The thing is that they never install and only says "OpenH264 Video Codec provided by Cisco Systems, Inc. will be installed shortly." and same for widevine. Could you please helpme to fix this issue and only use firedragon :)?

Thanks, have a great day.

Cheers,

karlangas

Ill have a look at that. I dont need these plugins so I didnt notice that until now, but its happening to me as well when trying to reproduce :thinking:
After doing some research I found that we have this in firedragon.cfg:

λ locate firedragon.cfg
/usr/lib/firedragon/firedragon.cfg
defaultPref("media.gmp-manager.url", "data:text/plain,");
defaultPref("media.gmp-manager.url.override", "data:text/plain,");

This pretty much overrides the actual URL so these "antifeatures" wont be installed (a Librewolf preference). By removing the part following

// -----------------------
// User Settings : DRM/CDM
// -----------------------

and restarting the browser, you will be prompted to install the missing plugin. Let me know if this works for you, if it doesnt we will have to dig deeper :smiley:
Actually I want both of these to work as they are needed to do Netflix or other things people do so itll be included if working :slight_smile:

2 Likes

Hi dr460nf1r3, thanks a lot for your reply :slight_smile:

Unfortuantely it didnt worked.

Tried suppressing only

defaultPref("media.gmp-manager.url", "data:text/plain,");
defaultPref("media.gmp-manager.url.override", "data:text/plain,");

and also removing the whole DRM/CDM content

// -----------------------
// User Settings : DRM/CDM
// -----------------------

defaultPref("media.eme.enabled", true);
defaultPref("media.gmp-provider.enabled", true);
defaultPref("media.gmp-manager.url", "data:text/plain,");
defaultPref("media.gmp-manager.url.override", "data:text/plain,");
defaultPref("media.gmp-manager.updateEnabled", false);
defaultPref("media.gmp.trial-create.enabled", false);

defaultPref("media.gmp-widevinecdm.visible", true);
defaultPref("media.gmp-widevinecdm.enabled", true);
defaultPref("media.gmp-widevinecdm.autoupdate", false);

defaultPref("media.gmp-gmpopenh264.enabled", false);
defaultPref("media.gmp-gmpopenh264.autoupdate", false);
defaultPref("media.peerconnection.video.enabled", false);
//lockPref("media.peerconnection.video.h264", true);
defaultPref("media.gmp-eme-adobe.enabled", false);
defaultPref("media.gmp-manager.certs.2.commonName", "");
defaultPref("media.gmp-manager.certs.1.commonName", "");

Nevertheless it still doesnt work. Particualry on Netflix is taking me to a different webpage. I attach screenchots. The addons screenshot is the same.

Thanks again for your support.

Cheers.

Did you restart the browser afterwards? Follow this closely (can be applied as settings are 99% the same) :smiley:
https://librewolf-community.gitlab.io/docs/drm/

2 Likes

Morning dr460nf1r3,

Well it cant be followed exactly since there is no User Settings: DRM/CDM - Main and User Settings: DRM/CDM - Widevine, i guess thay are all the setting under the same section named

// -----------------------
// User Settings : DRM/CDM
// -----------------------

Indeed after every test (commenting some of the preferences or all the section), restarting and checking update on the addon screen, firedragon still not working. Even though something changed on the addon screen...now only widevine is yellow...but in any case neither plex nor netflix works. Attached screen.

Cheers :slight_smile:

1 Like

Hi dr460nf1r3,

So finally, it worked...jejejejee...you were right 99.9% but we were missing something...and is that for some reason i had to disable all extensions, use about:restartrequired on the browser for 3 times in order for it to work. After those 3 resets i went back to netflix and plex and working like a Charm! After that i enabled the extensions and all good.

Hope this gets fixed on next releases...but no clue why i had to reset it 3 times (actually i learned that on How To Enable DRM Restricted Content In LibreWolf - YouTube).

Cheers,

2 Likes

Thats very nice to hear, I removed the corresponding settings so hopefully itll work out of the box once the next update comes. :grin:

4 Likes

Rather than using allowing DRM in browser I would use silo-netflix and/or such, just to be in safer side as I don't know what Google does.

1 Like