Firedragon never save history broken

I use all my browsers by under privacy & security remove everything that logs history. I know most people are too lazy to type in their passwords every time and rely on the safety of the browser / OS. In Firedragon I noticed for about a 2 months now under the privacy & security tab you can’t activate " never remember history option. You can click on it and the browser even restarts but when you go back to the settings it jumps back to " use custom settings for history " let’s not be Windows can we get this bug sorted in firedragon? Thanks you Garuda team. :slight_smile: Meanwhile I just switched to firefox until this resolves.

Seems to be a feature, not a bug. :wink:

If you wish to change the setting, provide your desired overwrite in ~/.firedragon/firedragon.overrides.cfg.

3 Likes

Thank you for the quick reply and the solution. If it’s a feature and not a bug what is the point of having the illusion for the settings " never remember history " option in the first place? This is the first setting I select every time I install a new browser or use Firedragon. Since this " feature " that Firedragon defaults back to " using custom settings to history " although I have all the history and password sliders off even on custom settings I have to manually clear browsing data for firedragon not to remember my history or passwords for websites. It’s unsafe and annoying in my opinion. Editing the cfg is a quick solution however there are three concerns about this. 1. Never remembering history should be always as option as with 90% browsers have it and Firedragon always had it since it’s creation until very recently. I realize most people willing to give up privacy for convenience that is why we are where we are in the digital world sadly. 2. If the option is there in the first place it should also function. 3 This might be something that anyone willing to keep as an option will always have to edit manually as well as I suspect every time Firedragon updates users concerned with privacy will have to keep editing the cfg . I love Garuda Linux and it’s been my main distro for about 3 years now and I love how it grew over the years to even better distro. The reason I put time into reporting things like this because I care about Garuda where with most distros I would just ignore and move on. Be it a bug or a " feature " it would be nice to see the " never remember history " option function again as it was intended without needing to edit the cfg file. Thank you Garuda TEAM for all your hard work.

There’s no need to use firedragon.overrides.cfg. You should just be able to configure it to not remember history and clear data on close like this:

1 Like

This setting does not enhance your privacy unless other people have access to your computer. Your browser history is just as private as any other files you choose to save on your computer.

~/.firedragon/firedragon.overrides.cfg is not overridden during updates.

It sounds like they already tried that.

Clearing history when the browser closes is not the same as never saving it in the first place. It sounds like they want the behavior of a private browser session (with regard to history).

I’m not sure, it seems to be set this way for a specific reason but I can’t tell what functionality the custom mode provides.

/** [SECTION] HISTORY AND SESSION RESTORE
 * Since we hide the UI for modes other than custom we want to reset it for
 * everyone. Same thing for always on PB mode.
 */
pref("privacy.history.custom", true);
pref("browser.privatebrowsing.autostart", false);
defaultPref("browser.formfill.enable", false); // Disable form history
// defaultPref("browser.sessionstore.privacy_level", 2); // Prevent websites from storing session data like cookies and forms
defaultPref("browser.sessionstore.interval", 60000); // Increase time between session saves

Edit

It looks like these settings may be relevant for something Librewolf has done with the UI, and were sort of “copied over” when Firedragon rebased to Floorp (even though Floorp is not making the same back-end changes to the UI).

Here is the history section on Librewolf:

The drop-down menu for history preference and the “Always use private browsing mode” settings are not present in the UI.

From the Librewolf FAQ:

Why can’t I use always-on private browsing?

We have decided to hide that option as it doesn’t provide any benefit over the default cleaning mechanism of LibreWolf. Instead it introduces many regressions, as it doesn’t respect cookie exceptions and installed addons, while also being fingerprintable.

Probably we should just scrap those settings from the Firedragon cfg, since they are relevant for a Librewolf patch and not a Floorp one.

2 Likes

Thank you for the explanation. Huh, strange but makes sense now. I actually stopped using Librewolf since started using Firedragon. I guess it’s up to the Garuda team now. 1. Fix the UI option to correspond with " never remember history " and follow the firefox code on this option . I trust that is the route Firedragon will take or 2. Simply follow Librewolf and also remove this UI option. ( I hope not ). Thanks guys I will keep an eye on future Firedragon updates meanwhile swapping back and forth between Firedragon and a heavily configured Firefox until there is a solution. Have a fantastic day.