Firedragon fails to open right after boot

$ garuda-inxi
System:
Kernel: 5.16.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c8982a18-bb6f-4ff7-9721-342b22111ce0 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=708a711b-88d8-4d3b-8c31-1d7ddd168843 loglevel=3
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME Z690-P WIFI D4 v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 0407
date: 09/13/2021
CPU:
Info: model: 12th Gen Intel Core i5-12600K bits: 64 type: MST AMCP
arch: Alder Lake family: 6 model-id: 0x97 (151) stepping: 2 microcode: 0xD
Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled
cache: L1: 864 KiB desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB
L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 20 MiB desc: 1x20 MiB
Speed (MHz): avg: 4437 high: 4900 min/max: 800/6300:3600 scaling:
driver: intel_pstate governor: performance cores: 1: 4554 2: 4842 3: 4473
4: 4832 5: 4708 6: 4893 7: 4662 8: 4626 9: 4577 10: 4686 11: 4848
12: 4900 13: 3600 14: 3600 15: 3603 16: 3600 bogomips: 117964
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: ZOTAC driver: nvidia
v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1c02 class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.0x10.7")
s-diag: 554mm (21.8")
Monitor-1: HDMI-0 res: 1920x1080 hz: 75 dpi: 102
size: 480x270mm (18.9x10.6") diag: 551mm (21.7")
OpenGL: renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2
v: 4.6.0 NVIDIA 510.54 direct render: Yes
Audio:
Device-1: Intel Alder Lake-S HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:7ad0 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
Sound Server-1: ALSA v: k5.16.13-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:7af0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 4000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:6 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Drives:
Local Storage: total: 2.28 TiB used: 167.78 GiB (7.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: N/A size: 447.13 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 8A0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM003-1CH162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC49
scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD10JPCX-24UE4T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: SanDisk model: USB 3.2Gen1
size: 28.64 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 429.54 GiB size: 429.54 GiB (100.00%)
used: 34.67 GiB (8.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 580 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 764.84 GiB size: 764.84 GiB (100.00%)
used: 133.11 GiB (17.4%) fs: btrfs dev: /dev/sdb5 maj-min: 8:21
ID-4: /var/log raw-size: 429.54 GiB size: 429.54 GiB (100.00%)
used: 34.67 GiB (8.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 429.54 GiB size: 429.54 GiB (100.00%)
used: 34.67 GiB (8.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.09 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 15.37 GiB used: 1.66 GiB (10.8%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 42 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 56%
Info:
Processes: 448 Uptime: 10m wakeups: 0 Memory: 15.37 GiB
used: 5.21 GiB (33.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1999 lib: 557 Shell: fish v: 3.3.1
running-in: konsole inxi: 3.3.13
Garuda (2.5.5-1):
System install date:     2021-12-10
Last full system update: 2022-03-09
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

photo_2022-03-10_01-43-31

This warning appears when I try to launch Firedragon right after KDE finishes loading. It only correctly opens if launched ~30 seconds after KDE loads.

Have you tried searching on the internet for the equvalent Firefox error?
E.g. here you have some hints to remove a lock file, recreate the profile, etc.

Or in general

1 Like

Solved it, there was something absolutely cursed within my profile causing it to break. Had to manually move different parts of the profile until I found the problem was somewhere within the "storage" directory.

1 Like

Sounds like someone was watching too much porn. :rofl:

Just kidding. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.