Firedragon default profile breaks

Firedragon default profile breaks

When I open a profile that is set as default, I get this banner at the top saying that it’s in use by some other application. This doesn’t happen with profiles that aren’t the default.

With this, several things seems to break:

  • Browser history stops updating
  • Any extensions stop remembering and kind of break
    • Unhook (youtube declutter extension) seems to constantly reset itself and turn itself off
    • Sideberry (vertical tabs sidebar) just doesn’t load
    • other extensions show signs of not working
  • address bar url autocomplete stops working

I tried making new profiles and duplicating my current setup, but doesn’t seem to help. This only seems to apply whatever profile is selected as default, any non-default profile I launch is fine and works great.

garuda-inxi:

System:
  Kernel: 6.8.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=e49c1f07-1f07-4998-aa9c-4e366d5462d5 rw rootflags=subvol=@ resume_offset=2810612
    resume=UUID=e49c1f07-1f07-4998-aa9c-4e366d5462d5 rd.udev.log_priority=3
    vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: Hyprland v: 0.39.1-141-g40201a76 vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Convertible System: LENOVO product: 20R5A000US v: ThinkPad L13 Yoga
    serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: LENOVO model: 20R5A000US v: SDK0J40700 WIN serial: <superuser required>
    part-nu: LENOVO_MT_20R5_BU_Think_FM_ThinkPad L13 Yoga uuid: <superuser required> UEFI: LENOVO
    v: R15ET47W (1.28 ) date: 01/12/2021
Battery:
  ID-1: BAT0 charge: 28.3 Wh (64.8%) condition: 43.7/46.0 Wh (95.0%) power: 8.5 W volts: 15.6
    min: 15.4 model: SMP 5B10W13933 type: Li-poly serial: <filter> status: discharging cycles: 371
CPU:
  Info: model: Intel Core i5-10210U bits: 64 type: MT MCP arch: Comet/Whiskey Lake note: check
    gen: core 10 level: v3 note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xFA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 799 high: 1200 min/max: 400/4200 scaling: driver: intel_pstate
    governor: powersave cores: 1: 1200 2: 1200 3: 1200 4: 400 5: 400 6: 1192 7: 400 8: 400
    bogomips: 33599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: DP-1, DP-2,
    HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300
  Device-2: IMC Networks Integrated Camera driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-5:2 chip-ID: 13d3:56a6 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6 compositor: Hyprland
    v: 0.39.1-141-g40201a76 driver: X: loaded: modesetting alternate: fbdev,intel,vesa dri: iris
    gpu: i915 display-ID: 1
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris device: 1 drv: swrast
    surfaceless: drv: iris wayland: drv: iris x11: drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.6-arch1.2 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2) device-ID: 8086:9b41
    memory: 7.17 GiB unified: yes
  API: Vulkan v: 1.3.279 layers: 7 device: 0 type: integrated-gpu name: Intel UHD Graphics (CML
    GT2) driver: mesa intel v: 24.0.6-arch1.2 device-ID: 8086:9b41 surfaces: xcb,xlib,wayland
    device: 1 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
    v: 24.0.6-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Lenovo driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:02c8 class-ID: 0403
  API: ALSA v: k6.8.9-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:02f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:0d4f class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  IF-ID-1: MABGaruda state: unknown speed: N/A duplex: N/A mac: N/A
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:5 chip-ID: 8087:0aaa class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1 lmp-v: 10 status:
    discoverable: no pairing: no class-ID: 6c0000
Drives:
  Local Storage: total: 931.51 GiB used: 330.99 GiB (35.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 2B2QEXM7 temp: 35.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 330.99 GiB (35.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 330.99 GiB (35.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 330.99 GiB (35.5%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 330.99 GiB (35.5%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2 file: /swap/file
  ID-2: swap-2 type: zram size: 7.34 GiB used: 317.2 MiB (4.2%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 17.0 C mobo: N/A
  Fan Speeds (rpm): fan-1: 0 fan-2: 0
Info:
  Memory: total: 8 GiB note: est. available: 7.35 GiB used: 2.52 GiB (34.4%)
  Processes: 271 Power: uptime: 4m states: freeze,mem,disk suspend: deep avail: s2idle wakeups: 0
    hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 2.92 GiB
    services: power-profiles-daemon, thermald, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1905 pm: pacman pkgs: 1895 libs: 521 tools: octopi,pacseek,paru,yay pm: flatpak
    pkgs: 10 Compilers: clang: 17.0.6 gcc: 13.2.1 Client: shell wrapper v: 5.2.26-release
    inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2023-09-22
  Last full system update: 2024-05-04
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       no
  Failed units:            nmb.service 

Other thing, this issue only started after the new firedragon profile migration and update

When was that?
For me the definition of “new Firedragon profile migration and update” means when we switched from Librewolf-based to Floorp-based, a few months ago.

That’s interesting. I wonder if the DE has anything to do in this.

Can you confirm you have no other Firedragon instance running (a reboot would make sure of that)?

What does this say?

ls ~/.firedragon/
3 Likes

When was that?

I think it was a bit after Floorp migration? Initially with Floorp it was fine for a while, but then an update about maybe 3 weeks ago ish broke it for me? I’m sorry if I can’t remember this too well, should’ve reported it sooner.

Hyprland

I’m doing a bit of a weird thing, running both Hyprland and Plasma. Right now as I’m writing this, I’m back on Plasma, but the issue seems to affect both DEs.

Here’s the firedragon folder:

drwx------   - mab  6 May 13:08  firefox-mpris
lrwxrwxrwx   - mab  4 May 15:19  l05k4jwp.default -> /run/user/1000/psd/mab-firedragon-l05k4jwp.default
drwx------   - mab  4 May 18:24  l05k4jwp.default-backup
drwx------   - mab  1 May 02:18  l05k4jwp.default-backup-crashrecovery-20240501_023446
lrwxrwxrwx   - mab  4 May 15:19  we6sytc7.default-release -> /run/user/1000/psd/mab-firedragon-we6sytc7.default-release
drwx------   - mab  6 May 12:52  we6sytc7.default-release-backup
drwx------   - mab  1 May 02:24  we6sytc7.default-release-backup-crashrecovery-20240501_023446
.rw-r--r-- 100 mab  1 May 03:29  installs.ini
.rw-r--r-- 400 mab  1 May 03:29  profiles.ini

When I tried making a new profile, I also tried creating one at a custom directory

which looks like this:

lrwxrwxrwx - mab  4 May 15:19  mab3 -> /run/user/1000/psd/mab-firedragon-mab3
drwxr-xr-x - mab  4 May 18:24  mab3-backup

In the default FD folder (~/.firedragon) what do you get with

cat ~/.firedragon/installs.ini
cat ~/.firedragon/profiles.ini
2 Likes
File: /home/mab/.firedragon/installs.ini
[E60E74956B9A3361]
Default=/home/mab/Applications/Custom/Browser-Profiles/Firedragon/mab3
Locked=1
File: /home/mab/.firedragon/profiles.ini
[InstallE60E74956B9A3361]
Default=/home/mab/Applications/Custom/Browser-Profiles/Firedragon/mab3
Locked=1

[Profile1]
Name=default
IsRelative=1
Path=l05k4jwp.default
Default=1

[Profile0]
Name=default-release
IsRelative=1
Path=we6sytc7.default-release

[General]
StartWithLastProfile=1
Version=2

[Profile2]
Name=mab3
IsRelative=0
Path=/home/mab/Applications/Custom/Browser-Profiles/Firedragon/mab3

The files look good, but I question the full path here, maybe due to your non-std path location.

Let’s keep it simple, what if you replace installs.ini with:

[E60E74956B9A3361]
Default=l05k4jwp.default
Locked=1

and profiles.ini with:

[InstallE60E74956B9A3361]
Default=l05k4jwp.default
Locked=1

[Profile1]
Name=default
IsRelative=1
Path=l05k4jwp.default
Default=1

[Profile0]
Name=default-release
IsRelative=1
Path=we6sytc7.default-release

[General]
StartWithLastProfile=1
Version=2

Before replacing, delete your mab3 profile using Firedragon -P.
Take backups of both files before deleting profile and replacing files.

1 Like

Went ahead and change the config files as you suggested, still the same error :frowning:

Thanks btw so much for all your help so far!

Well that really sucks!

Let’s try more devastating measures. After taking backups of all your important files like bookmarks, settings, etc., could you uninstall FD and delete everything related to it on your system?

Mostly a

rm -rf ~/.firedragon
sudo rm -rf /usr/lib/firedragon

Reboot
Login into Plasma
Install FD
From Terminal firedragon -P
Load the default profile and see if you get the error. If you do get it, then please post the output of everything from Terminal following firedragon -P.

This starts to get really awkward, I always some in mind the corrupted files issue, normally a full clean up like this and reinstall should take care of that.

1 Like

Sorry, meant to do it earlier, but then put it off this past week after I found myself working on some projects.

Anyways, just finished the re-install, I’ve re-configured the browser the way I like it, and everything seems to be working properly now.

Who knows what it was, at least everything is working again!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.