FireDragon browser is unable to correctly locate a decoder

My English is not very good, I apologize if the sentence is offensive.
I am encountering an issue with the FireDragon browser on Garuda Linux where it is unable to correctly locate a decoder.
And my desktop environment is Hyprland.
I tested the website at (not an endorsement).
My system and FireDragon are up to date.
Bilibili can choose AV1, HEVC, AVC, and one more,but none of them worked for me.
I just installed Garuda Linux yesterday, and FireDragon has never played Bilibili videos correctly.
Another issue I’ve encountered is that the dynamic wallpaper on a browser tab is also not playing.
However, YouTube videos can be played smoothly.
I installed Edge and it can play the videos.

Could you please post the codecs listed under the “Media”-section on the about:support-page?


I don’t have any problem playing videos on that website.

Make sure you Allow Audio and Video here

1 Like

I opened a test configuration file and hardly made any changes. When I play Bilibili videos and dynamic wallpapers in the background, the decoder looks like this.
And this:
$ vainfo
Trying display: wayland
vainfo: VA-API version: 1.21 (libva 2.22.0)
vainfo: Driver version: Mesa Gallium driver 24.1.3-arch1.1 for AMD Radeon 780M (radeonsi, gfx1103_r1, LLVM 18.1.8, DRM 3.57, 6.9.8-zen1-1-zen)
vainfo: Supported profile and entrypoints
VAProfileH264ConstrainedBaseline: VAEntrypointVLD
VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
VAProfileH264Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointEncSlice
VAProfileH264High : VAEntrypointVLD
VAProfileH264High : VAEntrypointEncSlice
VAProfileHEVCMain : VAEntrypointVLD
VAProfileHEVCMain : VAEntrypointEncSlice
VAProfileHEVCMain10 : VAEntrypointVLD
VAProfileHEVCMain10 : VAEntrypointEncSlice
VAProfileJPEGBaseline : VAEntrypointVLD
VAProfileVP9Profile0 : VAEntrypointVLD
VAProfileVP9Profile2 : VAEntrypointVLD
VAProfileAV1Profile0 : VAEntrypointVLD
VAProfileAV1Profile0 : VAEntrypointEncSlice
VAProfileNone : VAEntrypointVideoProc

After I allowed this option, I still couldn’t play it. However, on YouTube, I can see the videos even if it’s not turned on, but they won’t start playing automatically.

It seems you are missing H264 SW and AAC SW decoders, could you check if you have gst-plugins-bad (should be installed through gstreamer-meta) and ffmpeg (should be installed as dependency of firedragon already) installed?



yay gstreamer-meta
2 aur/gstreamer-meta 1-2 [+1 ~0.00] [已安装:1-4]
    Metapkg for GStreamer support
1 garuda/gstreamer-meta 1-4 [0 B 0 B] [已安装]
    Meta-package for GStreamer support
:: 要安装的软件包(例如:1 2 3, 1-3):

 ╭─po@po in ~ took 2s
 ╰─λ yay -Q ffmpeg
ffmpeg 2:7.0.1-2

 10 extra/jellyfin-ffmpeg 1:6.0.1p7-5 [0 B 58.26 MiB] [已安装]
    Jellyfin fork of ffmpeg
  9 extra/gst-libav 1.24.5-2 [0 B 242.75 KiB] [已安装]
    Multimedia graph framework - libav plugin
  8 extra/ffnvcodec-headers [68.24 KiB 430.41 KiB]
    FFmpeg version of headers required to interface with Nvidias codec APIs
  7 extra/ffms2 5.0RC4-1 [123.64 KiB 354.82 KiB]
    A libav/ffmpeg based source library and Avisynth plugin for easy frame accurate access
  6 extra/ffmpegthumbs 24.05.2-1 [31.78 KiB 87.47 KiB] (kde-applications kde-multimedia)
    FFmpeg-based thumbnail creator for video files
  5 extra/ffmpegthumbnailer 2.2.2-6 [0 B 272.86 KiB] [已安装]
    Lightweight video thumbnailer that can be used by file managers
  4 extra/ffmpeg4.4 4.4.4-6 [8.54 MiB 23.34 MiB]
    Complete solution to record, convert and stream audio and video
  3 extra/ffmpeg2theora 0.30-8 [50.81 KiB 154.24 KiB]
    Simple converter to create Ogg Theora files
  2 extra/emby-ffmpeg 2023_06_25-2 [10.28 MiB 52.02 MiB]
    Emby fork of ffmpeg
  1 extra/ffmpeg 2:7.0.1-2 [0 B 38.97 MiB] [已安装]
    Complete solution to record, convert and stream audio and video

I believe I should have installed it.
I only installed these with ffmpeg.
“已安装” means “already installed.”

Please, no pictures from terminal output.

They are not searchable if they are pictures, and can be hard to see across different devices.
Please select the text in the terminal, copy the text and paste the text into the post.
Select the newly pasted text in the post.
Click the </> icon in the post toolbar.

This creates nicely formatted text that we can use by forum search.

Thank you :slight_smile:


Sorry, I will correct this point, thank you for pointing out my problem.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.