Firedragon Auto Updates/can't find how to disable in .cfg file

Hi, trying to find where in the firedragon.cfg file auto update is enabled or where/how I can disable it. It always does it on its own and makes me restart Firedragon, almost always when I'm in the middle of something important.

I've searched and searched, even on LibreWolf as well and cannot find it. Anyone know how to disable auto update?


If you do important on the browser, you should not go through a garuda-update or similar in between, if there are updates for FD included, FD will eventually report restarting it.

It is desirable to post always, garuda-inxi. Thank you.


Auto update what?
I have Firedragon on over 10 machines and it never never restarted by itself.

If you are talking about auto updates of EXTENSIONS, you can disable them here:

1 Like

If you run your system updates (garuda-update or pacman -Syu or paru or however you are doing it) and Firedragon is one of the packages that is updated, you will have to restart the browser after the update completes. The browser does not get updated independently from your other packages.


Thanks for the help each of you. I don’t run garuda-update super frequently but when I do typically FD is open. I was trying not to be boneheaded about it by searching for the answer within the application when all along it was the system update that was doing it. Duh.
Linux is my 2nd-OS (like a 2nd language speaker) and my (1st-OS) macOS mentality got the best of me so I made erroneous assumptions. My bad, but again, thanks for the replies & help - also for not making me feel any dumber than I already do. Much appreciated! I’ve been using Garuda for a couple months now and I absolutely love it!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.