Fingerprint reader not working on Dell XPS 15 (7590)

Hello,

I am not being able to setup my fingerprint reader on Dell XPS 15 (7590).
So far I tried to follow many articles about fprint (fprint - ArchWiki) and Fingerprint GUI (Fingerprint GUI - ArchWiki) but without success.
When I try to fprintd-enroll the output looks like this:

Impossible to enroll: GDBus.Error:net.reactivated.Fprint.Error.NoSuchDevice: No devices available

Also, when I enter already pre-installed app Fingerprint Password Settings I get instant error in pop-up window:

Could not claim device.
Please cancel all other fpint sessions
and press retry.

I canceled all fprint sessions and there are none running in the background.

Output of my lsusb looks like this and there is my fingerprint reader which is supported by fprint according to their docs:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 27c6:5395 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
Bus 001 Device 002: ID 8087:0029 Intel Corp. AX200 Bluetooth
Bus 001 Device 004: ID 0c45:6723 Microdia Integrated_Webcam_HD
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So, do you have any other recommendations? I would love to use my fingerprint on the login screen as well as an authentication to access some apps.

System:
Kernel: 5.16.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6caa828b-1fe1-438c-b753-ec4d6173e158 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=55204ea6-05d6-4401-b78d-0fc6406bcba3 loglevel=3
Desktop: KDE Plasma 5.24.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: XPS 15 7590 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0T8KGX v: A00 serial: <superuser required> UEFI: Dell
v: 1.5.0 date: 12/25/2019
Battery:
ID-1: BAT0 charge: 12.9 Wh (14.7%) condition: 87.7/97.0 Wh (90.5%)
volts: 10.6 min: 11.4 model: SMP DELL GPM0365 type: Li-ion serial: <filter>
status: Discharging
Device-1: hidpp_battery_4 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 50% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Info: model: Intel Core i9-9980HK bits: 64 type: MT MCP arch: Coffee Lake
family: 6 model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xEC
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 892 high: 901 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 900 2: 900 3: 900 4: 900
5: 900 6: 900 7: 901 8: 900 9: 800 10: 872 11: 900 12: 900 13: 900
14: 900 15: 900 16: 900 bogomips: 76800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,DP-2,DP-3
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: Hewlett-Packard driver: nvidia v: 510.54
alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1f91 class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-12:4 chip-ID: 0c45:6723 class-ID: 0e02
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: modesetting,nvidia gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 model: Samsung built: 2019 res: 1920x1080 dpi: 142
gamma: 1.2 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") ratio: 16:9
modes: 3840x2160
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Sound Server-1: ALSA v: k5.16.10-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™
driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 3b:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp59s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-4:2 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 113.53 GiB (11.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 42AZS6AC
temp: 33.9 C scheme: GPT
Partition:
ID-1: / raw-size: 920.9 GiB size: 256 GiB (27.80%) used: 113.53 GiB (44.3%)
fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 351 MiB size: 350.3 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 920.9 GiB size: 256 GiB (27.80%)
used: 113.53 GiB (44.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-4: /var/log raw-size: 920.9 GiB size: 256 GiB (27.80%)
used: 113.53 GiB (44.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 920.9 GiB size: 256 GiB (27.80%)
used: 113.53 GiB (44.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: swap-2 type: zram size: 15.26 GiB used: 458.2 MiB (2.9%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.0 C pch: 44.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
Processes: 437 Uptime: 21h 49m wakeups: 4458 Memory: 15.26 GiB
used: 7.66 GiB (50.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 1537 pacman: 1522 lib: 335 snap: 15
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.13
Garuda (2.5.5-1):
System install date:     2022-02-23
Last full system update: 2022-02-24
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Try to give a look here:
https://wiki.archlinux.org/title/Laptop/Dell#XPS
For a model similar to yours (XPS 13 7390) seems to be not working. But it doesn't mean the same is valid for yours.

4 Likes

So there is no way how to make fingerprint reader on my laptop work with arch based distros?

I don't know. I just meant that there is that possibility. But you can keep on trying! And maybe the driver, if not yet available, will arrive. See the links at the end of the page for the other model.