Files in hard disk deleted

Hello.
I was working in my file which was in my New volume but my computer suddenly became frozen . then when i try to open New volume this error occurs:

An error occurred while accessing 'Home', the system responded: The requested operation has failed: Error mounting /dev/sda1 at /run/media/haru/New Volume: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error

also file i was working on was expo project when i run server ,my computer frozen

There was all file in that disk . Is it possible to get my files back?

garuda-inxi

sudo mount /dev/sda1/run/media/haru/New Volume
i tried it .
but output is :
mount: Volume: mount point does not exist.

1 Like

The output of garuda-inxi when you enter it in a terminal, please, not just a mention to the command. :wink:

2 Likes

i found it from ubuntu - mount: wrong fs type, bad option, bad superblock - Unix & Linux Stack Exchange but im afraid of doing anything because i dont really know what is going on

1 Like

garuda-inxi:

Kernel: 5.16.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bbd799ba-2a67-46cc-8a35-2e7ff843bcfa rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.3 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Micro-Star product: GF63 Thin 9SCX v: REV:1.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Micro-Star model: MS-16R4 v: REV:1.0 serial: <superuser required>
UEFI: American Megatrends v: E16R4IMS.505 date: 11/05/2020
Battery:
ID-1: BAT1 charge: 31.5 Wh (71.3%) condition: 44.2/51.3 Wh (86.1%)
volts: 11.3 min: 11.4 model: MSI Corp. MS-16R4 type: Li-ion serial: N/A
status: discharging
CPU:
Info: model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Coffee Lake
family: 6 model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xEC
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 924 high: 1000 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 974 2: 1000 3: 925
4: 900 5: 900 6: 900 7: 900 8: 900 bogomips: 38400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU117M vendor: Micro-Star MSI driver: nvidia v: 510.54
alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0302
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: modesetting,nvidia gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x23ed built: 2017 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:2 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 704.24 GiB used: 32.06 GiB (4.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: ADXA0103
temp: 44.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM000-SSHD-8GB
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: LIV9
scheme: GPT
Partition:
ID-1: / raw-size: 237.68 GiB size: 237.68 GiB (100.00%)
used: 32.06 GiB (13.5%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 237.68 GiB size: 237.68 GiB (100.00%)
used: 32.06 GiB (13.5%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-4: /var/log raw-size: 237.68 GiB size: 237.68 GiB (100.00%)
used: 32.06 GiB (13.5%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 237.68 GiB size: 237.68 GiB (100.00%)
used: 32.06 GiB (13.5%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.6 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.0 C pch: 56.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 296 Uptime: 31m wakeups: 1 Memory: 7.61 GiB
used: 3.45 GiB (45.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1269 lib: 314 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.14
Garuda (2.5.6-2):
System install date:     2022-03-25
Last full system update: 2022-03-25
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:```
1 Like

Well, in the article the solution was formatting, so you'd loose your data...
Maybe you could start providing the output of lsblk -f and sudo fdisk -l.

2 Likes

so my files are already gone right?

Not necessarily

2 Likes

with things like that, the first thing i tend to do is live boot and see if you can read the partition from there. Only takes a minute to do and then you'll know if further, more drastic action is required.

1 Like

This command is very wrong. If this is the exact command you entered in terminal, it is expected to fail.
If this is wrong, post the exact command.

6 Likes

im beginner to linux. if there's no certain solution.Should i reinstall os ?

1 Like

Is one of your drives an NTFS formatted (Windows) drive?

If so disconnect it from your computer.

This is looking like an NTFS bug, see:

4 Likes

I think it is just missing a space. :joy:

Probably will still have to replace ntfsprogs with ntfs-3g because of the bug TBG mentioned.

3 Likes

See this post:

Install the ntfs-3g package:

sudo pacman -Syu ntfs-3g

Then try mounting your drive as follows:

sudo mount -t ntfs-3g /dev/sda1 /mnt/windows_garbage
5 Likes

i think that the files are corrupt because

  1. hard drive is dead fix: buy new one
1 Like

More likely the filesystem. NTFS is very fragile and improper mounts/dismounts can "break" it.

I think this is probably unnecessary. A more realistic worst case scenario would be having to use the disk repair utility from Windows to restore the filesystem.

5 Likes

NTFS sucks lol. I wonder why Microsoft refuse to use something better but maybe because of compatibility reasons with old versions of Windows. Would be nice to run Windows on ext4 though. Or even btrfs

1 Like

Windows with BTRFS would be a match made in heaven... "Microsoft broke my shit again, guess a snapshot it is"

3 Likes

Yeah if only that was possible. Tbh though I break Linux like daily almost and haven't had Windows fully break beyond repair in years. Probably because I can't do stupid stuff as much as they limit you a lot haha.

1 Like

If it is an NTFS drive that is broken, try mounting it in Windows and doing a scan/repair on it through Windows.

If you cannot get it to mount at all, then you could try using testdisk to repair the drive or recover the files you want to save.

4 Likes

I think from the Linux side of the fence, NTFS causes nothing but grief. For a Windows user, it is a robust and useful filesystem. Unfortunately for us, a lot of the usefulness of NTFS is baked in to the elaborate software padding that Windows (only) provides.

We all kind of scoff at NTFS and consider it a lesser filesystem, but in its day it was revolutionary. It was the first journaling filesystem available to casual users (some seven or eight years before ext3), and also the first to roll out other features we now take for granted like encryption and compression.

Nowadays a lot of the cool features of NTFS are secreted away behind Microsoft's walled garden. Windows users can enjoy a filesystem that detects and repairs errors automatically--sometimes without the users awareness--which is a far cry from the frequently broken, featureless filesystem visible to us Linux users.

6 Likes