Few Applications Extremely Laggy

Hey, I am fairly new to Linux.
I recently started using Grauda i3wm.

Firefox, Telegram and XFCE4 terminals work super fast as expected.
But certain applications like Chrome, Discord, VSCode and Alacritty are extremely laggy for me to a point where they're unusable.

How do I fix the lag?

Read

please
and post

inxi -Fxxxza

as text. Only llaggy on my system ist geany but maybe I have to many files inside.

and
:slight_smile:

1 Like
System:    Kernel: 5.10.11-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=246ea4ba-7ce8-476b-baae-a42ee30583fb rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: i3 4.19.1 info: i3bar dm: LightDM 1.30.0 Distro: Garuda Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505GD_FX505GD v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX505GD v: 1.0 serial: <filter> UEFI: American Megatrends v: FX505GD.307 date: 05/25/2020 
Battery:   ID-1: BAT0 charge: 39.3 Wh condition: 39.3/48.1 Wh (82%) volts: 12.7/11.7 model: Simplo SDI ICR18650 type: Li-ion 
           serial: <filter> status: Full cycles: 41 
CPU:       Info: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: A (10) microcode: DE L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36799 
           Speed: 3998 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3998 2: 3939 3: 4000 4: 3986 5: 3999 6: 3915 7: 3990 
           8: 3987 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK driver: nvidia v: 460.39 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c8d 
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1-11:5 chip ID: 13d3:56a2 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: picom v: git-dac85 driver: loaded: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: HDMI-1-0 res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5") diag: 598mm (23.5") 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: sof-audio-pci 
           alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: Samson GoMic compact condenser mic type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:7 
           chip ID: 17a0:0305 
           Sound Server: ALSA v: k5.10.11-zen2-1-zen 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: 3000 
           bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5060 bus ID: 00:17.0 
           chip ID: 8086.282a rev: 10 
Drives:    Local Storage: total: 931.51 GiB used: 14.67 GiB (1.6%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LX015-1U7172 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: SDM1 
Partition: ID-1: / raw size: 67.78 GiB size: 67.78 GiB (100.00%) used: 14.67 GiB (21.6%) fs: btrfs dev: /dev/sda5 maj-min: 8:5 
           ID-2: /boot/efi raw size: 590 MiB size: 588.8 MiB (99.80%) used: 560 KiB (0.1%) fs: vfat dev: /dev/sda4 
           maj-min: 8:4 
           ID-3: /home raw size: 67.78 GiB size: 67.78 GiB (100.00%) used: 14.67 GiB (21.6%) fs: btrfs dev: /dev/sda5 
           maj-min: 8:5 
           ID-4: /var/log raw size: 67.78 GiB size: 67.78 GiB (100.00%) used: 14.67 GiB (21.6%) fs: btrfs dev: /dev/sda5 
           maj-min: 8:5 
           ID-5: /var/tmp raw size: 67.78 GiB size: 67.78 GiB (100.00%) used: 14.67 GiB (21.6%) fs: btrfs dev: /dev/sda5 
           maj-min: 8:5 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 975.6 MiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 975.6 MiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 975.6 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 975.6 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 975.6 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 975.6 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 975.6 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 975.6 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 60.0 C mobo: 27.8 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 290 Uptime: 55m wakeups: 1 Memory: 7.62 GiB used: 3.54 GiB (46.5%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: pacman: 1247 lib: 319 Shell: Zsh v: 5.8 running in: xfce4-terminal inxi: 3.2.02 

I think all the GPU Accelerated programs are slow. Possible Nvidia driver issue?

Laptop I do not know, less RAM, Intel/Nvidia seems special. Maybe other can help.

Please use forum search, too.

I update today to kernel 5.10.12, there other changes too.

1 Like

Yes.
Search for errors.

I had the same issue is definitely Nvidia driver issue. And it makes sense since alacritty is a GPU based terminal. Try opening alacritty from another terminal (just type alacritty). There you can find any errors
that show up.
Just go into the settings and add the right driver for you:

1 Like