Fastfetch won't leave .bashrc | i3wm

Due to fastfetch for some reason not supporting lolcat when it comes to drawing the logos, I decided to swap back to neofetch because I like the little rainbow. However upon replacing the line fastfetch -l garuda in .bashrc upon restart it had automatically put itself back into the bottom of my config, which yields an annoying result of two fetches. It has continued to do this after multiple reboots and me commenting it out. Any particular reason or does it just work this way.

(however in the meanwhile I have some cool things that while not directly related are fun!)

unrelated fun stuff:

queercat, lolcat but pride flags
cool little rain effect
psensor, pretty good temp monitor


Kernel: 6.5.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=8f73c2ee-4399-4af0-be0f-e16f37bffd55 rw rootflags=subvol=@
radeon.si_support=0 amdgpu.si_support=1 radeon.cik_support=0
amdgpu.cik_support=1 quiet quiet rd.udev.log_priority=3
resume=UUID=f90b7653-d3f7-47fd-9dc1-b22866e431b1 loglevel=3 ibt=off
Desktop: i3 v: 4.22 info: i3bar vt: 7 dm: LightDM v: 1.32.0
Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: B450M DS3H WIFI v: -CF
Mobo: Gigabyte model: B450M DS3H WIFI-CF v: x.x
serial: BIOS: American Megatrends LLC. v: F64
date: 11/07/2022
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3861 high: 4170 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4167 2: 4160
3: 3806 4: 3600 5: 3593 6: 3717 7: 4168 8: 4166 9: 4170 10: 3600 11: 3600
12: 3593 bogomips: 86232
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: AMD Hawaii PRO [Radeon R9 290/390] vendor: Micro-Star MSI
driver: amdgpu v: kernel alternate: radeon arch: GCN-2 code: Sea Islands
process: GF/TSMC 16-28nm built: 2013-17 pcie: gen: 3 speed: 8 GT/s
lanes: 8 link-max: lanes: 16 ports: active: DP-1,DVI-D-1
empty: DVI-D-2,HDMI-A-1 bus-ID: 0a:00.0 chip-ID: 1002:67b1 class-ID: 0300
temp: 60.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: Picom v: git-b700a driver: X: loaded: amdgpu
unloaded: modesetting alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 952x285mm (37.48x11.22")
s-diag: 994mm (39.12")
Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: left model: Apple Cinema
serial: built: 2007 res: 1680x1050 hz: 60 dpi: 99 gamma: 1.2
size: 433x270mm (17.05x10.63") diag: 510mm (20.1") ratio: 16:10 modes:
max: 1680x1050 min: 640x480
Monitor-2: DP-1 mapped: DisplayPort-0 pos: primary,right
model: ASUS VG24VQ1B serial: built: 2021 res: 1920x1080 dpi: 93
gamma: 1.2 size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9
modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: AMD Radeon R9 390 Series
(hawaii LLVM 16.0.6 DRM 3.54 6.5.2-zen1-1-zen) direct-render: Yes
Device-1: AMD Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 0a:00.1
chip-ID: 1002:aac8 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Razer USA Kraken Kitty Edition
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-1.3:6 chip-ID: 1532:0521 class-ID: 0300
API: ALSA v: k6.5.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 07:00.0
chip-ID: 10ec:c821 class-ID: 0280
IF: wlp7s0 state: down mac:
Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:3 chip-ID: 13d3:3533
class-ID: e001 serial:
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 1.83 TiB used: 292.34 GiB (15.6%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P3SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: fw-rev: P9CR30A temp: 34.9 C
scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDH3 1T00
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 20RL scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: TeamGroup model: T253512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 61.5 scheme: MBR
ID-1: / raw-size: 448.67 GiB size: 448.67 GiB (100.00%)
used: 292.34 GiB (65.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 448.67 GiB size: 448.67 GiB (100.00%)
used: 292.34 GiB (65.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 448.67 GiB size: 448.67 GiB (100.00%)
used: 292.34 GiB (65.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 448.67 GiB size: 448.67 GiB (100.00%)
used: 292.34 GiB (65.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.09 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
System Temperatures: cpu: 43.8 C mobo: 39.0 C gpu: amdgpu temp: 60.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 992
Processes: 346 Uptime: 11m wakeups: 0 Memory: total: 16 GiB
available: 15.54 GiB used: 3.08 GiB (19.8%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: 2376 pm: pacman pkgs: 2362 libs: 538 tools: octopi,pamac,paru
pm: flatpak pkgs: 14 Shell: Bash v: 5.1.16 running-in: kitty inxi: 3.3.29
Garuda (2.6.16-1):
System install date: 2023-08-08
Last full system update: 2023-09-12
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut
Windows dual boot:
Failed units:

I can guarantee the behaviour you are experiencing is not normal. Try to comment out

if [ -x /usr/bin/fastfetch ]; then
fastfetch --load-config siddharth

line in .bashrc and then make it immutable with

sudo chattr +i .bashrc

This will make .bashrc “un-writable” so open opening your bash shell whatever program is rewriting it will most likely throw and error and you can catch it. Once the culprit is found you can handle it however you like and if you wanna make your .bashrc file mutable, i.e. writable again do this

sudo chattr -i .bashrc

To view attributes of a file/dir

1 Like

I believe this is the culprit here: etc/skel/.config/i3/config · master · Garuda Linux 🦅 / Themes and Settings / Settings / Garuda i3 settings · GitLab

exec --no-startup-id ~/.local/bin/fastfetch-garuda

Here is ~/.local/bin/fastfetch-garuda: etc/skel/.local/bin/fastfetch-garuda · master · Garuda Linux 🦅 / Themes and Settings / Settings / Garuda i3 settings · GitLab

# - 06.03.2023 - Add fastfetch preset to bash and fish shell.
# Remove 'exec --no-startup-id ~/.local/bin/fastfetch-garuda' in '~/.config/i3/config' to disable this script.

set -e

sed -i 's/--load-config neofetch/--load-config garuda/g' ~/.config/fish/

grep -qxF 'fastfetch -l garuda' ~/.bashrc || echo 'fastfetch -l garuda' >> ~/.bashrc

It’s that last line that insists on re-adding the Fastfetch config to your .bashrc.

Just comment out or delete the exec --no-startup-id ~/.local/bin/fastfetch-garuda line in ~/.config/i3/config to disable the script and you should be good to go.


I’m a little late to the party here, but fastfetch does work with lolcat. See here.

For example:

fastfetch --logo garuda --pipe false | lolcat
1 Like

you are correct my good sir!

oh thank you that’s quite useful!

1 Like

No garuda-inxi, so

@BluishHumility must check the screenshot.

I move it from Newbies to i3wm

since i only changed it in i3wm, it only affects i3wm :slight_smile:

1 Like

garuda-inxi is there, just hidden with the “hide details” feature.


I don’t know why people do that with the inxi output! :smile:

1 Like

Hidden inxi must be on top, not on bottom :smiley:
THANKS :slight_smile:

1 Like

3 posts were split to a new topic: Does inxi really contains something that can invade your privacy :thinking:?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.