Fastfetch with Z shell (zsh) "Logo: getCharacterPixelDimensions() failed" error

Hello everyone.
Few months ago I switch to Garuda.
I use Konsole as a terminal and my default shell is ZSH (with oh-my-zsh framework and powerlevel10k for theme).
How to happens with the Fish Shell when opening the terminal, I want to replicate the same thing with ZSH shell using Fastfetch.
I added the following lines to my .zshrc config file like fish .config file:

# Run Fastfetch
if [[ -o interactive ]]; then
fastfetch --load-config dr460nized

# To customize prompt, run `p10k configure` or edit ~/.p10k.zsh.
[[ ! -f ~/.p10k.zsh ]] || source ~/.p10k.zsh

When i run the command:

source .zshrc

I get everything working fine (I see the correct Garuda Dr460nized logo and informations).
But when I open a new terminal session I have the following error:

Logo: getCharacterPixelDimensions() failed

and the Garuda logo is not visible (informations displayed are correctly).

How can I fix it?
Has anyone had the same problem as me and solved it?

My garuda-inxi output:

Kernel: 6.2.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=295ce862-fddc-498e-a99c-c906f2dc086a rw rootflags=subvol=@
quiet rd.luks.uuid=a2077ce0-3674-466f-9f32-19f2c584d6fa quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=/dev/mapper/luks-73f66fc8-67e9-4e1c-87f6-c1c8e3323efc loglevel=3
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 20QT006UIX v: ThinkPad P1 Gen 2
serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: LENOVO model: 20QT006UIX v: SDK0T08861 WIN serial: <filter>
UEFI: LENOVO v: N2OET58W (1.45 ) date: 10/27/2022
ID-1: BAT0 charge: 62.0 Wh (100.0%) condition: 62.0/80.4 Wh (77.1%)
volts: 17.0 min: 15.4 model: SMP 01YU911 type: Li-poly serial: <filter>
status: full cycles: 693
Device-1: hidpp_battery_2 model: Logitech MX Ergo Multi-Device Trackball
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i9-9880H socket: BGA1440 (U3E1) note: check bits: 64
type: MT MCP arch: Coffee Lake gen: core 9 level: v3 note: check built: 2018
process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xD (13)
microcode: 0xF4
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1175 high: 2300 min/max: 800/4800 base/boost: 2300/2300
scaling: driver: intel_pstate governor: powersave volts: 0.8 V
ext-clock: 100 MHz cores: 1: 800 2: 800 3: 800 4: 2300 5: 2300 6: 2300
7: 800 8: 800 9: 800 10: 2300 11: 800 12: 800 13: 800 14: 800 15: 800
16: 800 bogomips: 73598
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] vendor: Lenovo
driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-03) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
chip-ID: 10de:1fb8 class-ID: 0300
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-8:2 chip-ID: 04f2:b67c class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1080 s-dpi: 143 s-size: 796x191mm (31.34x7.52")
s-diag: 819mm (32.23")
Monitor-1: DP-2 pos: primary,left res: 1920x1080 hz: 60 dpi: 142
size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
Monitor-2: HDMI-0 pos: right res: 2560x1080 hz: 60 dpi: 97
size: 673x284mm (26.5x11.18") diag: 730mm (28.76") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: Quadro T2000/PCIe/SSE2
direct-render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
class-ID: 0403
API: ALSA v: k6.2.10-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.68 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bb class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 52:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp82s0 state: up mac: <filter>
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:5 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Local Storage: total: 953.87 GiB used: 102.31 GiB (10.7%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB1T0HBLR-000L7 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 5M2QEXF7 temp: 41.9 C scheme: GPT
SMART: yes health: PASSED on: 151d 14h cycles: 1,340
read-units: 173,136,036 [88.6 TB] written-units: 935,279,803 [478 TB]
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 12.69 GiB (12.7%)
fs: btrfs block-size: 4096 B dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a2077ce0-3674-466f-9f32-19f2c584d6fa
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 752 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 819.57 GiB size: 819.57 GiB (100.00%)
used: 89.63 GiB (10.9%) fs: btrfs block-size: 4096 B dev: /dev/dm-2
maj-min: 254:2 mapped: luks-e8b628f5-e446-4beb-b32e-6732ac88ad88
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 12.69 GiB (12.7%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
maj-min: 254:0 mapped: luks-a2077ce0-3674-466f-9f32-19f2c584d6fa
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%)
used: 12.69 GiB (12.7%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
maj-min: 254:0 mapped: luks-a2077ce0-3674-466f-9f32-19f2c584d6fa
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 34 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/dm-1 maj-min: 254:1
mapped: luks-73f66fc8-67e9-4e1c-87f6-c1c8e3323efc
ID-2: swap-2 type: zram size: 31.03 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 64.0 C mobo: N/A gpu: nvidia temp: 53 C
Fan Speeds (RPM): N/A
Processes: 427 Uptime: 7h 51m wakeups: 34 Memory: 31.03 GiB
used: 11.7 GiB (37.7%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1318
libs: 329 tools: octopi,paru Shell: garuda-inxi (sudo) default: Zsh v: 5.9
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-13
Last full system update: 2023-04-14
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

what if you run fastfetch --load-config dr460nized manually? Does that throw the same error? If that is the case, try reinstalling fastfetch.

Just use the default Garuda shell, it just works.

Hi, if I manually run:

fastfetch --load-config dr460nized 

there are no errors

If instead I open a new terminal session

Maybe you could try removing that ";"?
Or even commenting that line (all sessions are interactive, apart those launched by script, where most likely you don't need fastfetch).
By-the-way, with fish I have:

## Run fastfetch if session is interactive
if status --is-interactive && type -q fastfetch
fastfetch --load-config dr460nized
1 Like

Nope, same error.
I tried to remove the "if" condition as well but the error remains.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.