Failed to save backlight issue on boot

Hello people, whenever I boot I get two error messages

[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0

&

[FAILED] Failed to start Load/Save Screen Backlight #tness of backlight:amdgpu_bl0

My system configurations are:
AMD Ryzen 5 4600H
15.1GB RAM
GTX 1660 Ti, AMD RENOIR

I am attaching the output of mhwd command

3 Likes

This is a known kernel bug for AMD backlight.
Check if you really have "two backlight services", or (normally) only amdgpu_bl0

ls /sys/class/backlight/

Check what systemd finds out

systemctl status [email protected]*

Even if there are two, mask acpi_video0, to test if your system hardware buttons (assuming a laptop, or a capable keyboard, or shortcuts) can control display backlight.

systemctl is-enabled [email protected]:acpi_video0.service
"expected output"> static
sudo systemctl mask [email protected]:acpi_video0.service

Until kernel AMD bug is fixed, set kernel param in /etc/default/grub (update grub afterwards, of course)

systemd.restore_state=0

Please, post your results.
PS: I have an AMD Ryzen laptop, not AMD/Nvidia, so your results may differ.

5 Likes

hi, sorry for the late reply.

I executed these commands and here are the results

ls /sys/class/backlight/
amdgpu_bl0

systemctl is-enabled [email protected]:acpi_video0.service
static

sudo systemctl mask [email protected]:acpi_video0.service
Created symlink /etc/systemd/system/[email protected]:acpi_video0.service → /dev/null.

after opening /etc/default/grub in micro where am i supposed to add

systemd.restore_state=0

thank you

edit: i added this on GRUB_CMDLINE_LINUX_DEFAULT= and upon rebooting didn't face those error.
thanks although brightness still isn't saved

2 Likes

Glad that helped you.

Very nice to have you helping out on the forum @petsam, so nice to see you back in on the action. :smiley:

4 Likes

That's why we call it a bug :wink:.
The brightness values of Linux "kernel" and AMD "GPU" are of different scale, so 255 and 65000 are for 100%, for each case (numbers are from memory and maybe a little different).
With the current workaround, you just use one scale (0-255).
Check your settings with

find  /sys/class/backlight/amdgpu_bl0/*brightness -type f -printf %f  -exec cat {} \;
1 Like

I have this bug on every distro :slight_smile:

1 Like

I still got the error but my linux still boots up not like my earlier install where I get stuck so I had to reinstall garuda dr460nized again in hopes that this was because installing rog-core. But at least it still boots up and I'm really hoping this will be fixed soon. :smiley:

EDIT: Nvm, fixed it. :smiley:

A post was split to a new topic: Problem with backlight gmux_backlight