Failed to boot

Hey there, this is my first post here after a lot of research about my issue which has happened 2 times now. I don't know what's the problem here.

Kernel: linux-zen


Previously I replaced mkinitcpio.conf file with mkinitcpio.conf.pacnew. Can this be the problem? If yes, can you guide me.


Try restoring the latest working snapshot

1 Like

I tried with no success, brought me back the emergency shell.

Possible. It's better not to blindly replace those files, but compare and merge.
I recall a mkinitcpio.conf.pacnew with one of the latest updates, now I will check but likely it was lacking modules necessary for luks.

edit: MODULES=() in the pacnew. I don't use luks but it makes sense some specific modules were necessary. Also, modules for the graphics card were likely there (in the previous .conf).


Finally, fixed it. This helped me:: [solved] Arch with LUKS cryptodisk not found / Newbie Corner / Arch Linux Forums
Typing this from my laptop.
Editing the "mkinitcpio.conf" file was needed with the "encrypt" value in "HOOKS"
Thank you all,

For next time, try using meld to handle pacnew files.

sudo meld /etc/mkinitcpio.conf /etc/mkinitcpio.conf.pacnew

It highlights anything different between the two files in an obvious way, and you can drag any changes you want to keep from the new version into your working config without overwriting any values you want to keep. Then just delete the pacnew.

I believe the new mkinitcpio.conf also has an empty modules field, where the Garuda one has a few standard ones in there. No big deal if everything is working, but if you come across something broken that needs early KMS that would be why.

1 Like

I have to enter LUKs password twice on boot, is this normal?

If you had a keyfile set up, you would have wiped it by overwriting your mkinitcpio.conf with the .pacnew. If you want to avoid inputting your password twice every time, you'll have to set it up again.

1 Like

Just use

alias | grep pacdiff
alias pacdif 'sudo -H DIFFPROG=meld pacdiff'

for all pacnew/pacsave files after updates.

==> pacsave file found for /etc/mkinitcpio.d/linux-amd.preset
-> Files are identical, removing...
removed '/etc/mkinitcpio.d/linux-amd.preset.pacsave'
==> pacnew file found for /etc/pacman.d/mirrorlist
:: (V)iew, (M)erge, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/m/s/r/o/q]                     
1 Like

After hours of researching, fixed everything. I also needed to enable the option to enable booting from LUKS encrypted devices.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.