Failed retrieving file 'libnm-1.48.2-1-x86_64.pkg.tar.zst.sig' from

Hey everyone! it’s been awhile since I have been on Garuda. I ran into this issue while trying to update:

[2024-06-24T12:31:09-0700] [PACMAN] Running 'pacman --sync -u -- libnm'
[2024-06-24T12:31:09-0700] [PACMAN] starting full system upgrade

then this error showed up:

error: failed retrieving file ‘libnm-1.48.2-1-x86_64.pkg.tar.zst.sig’ from : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

has anyone ran into this issue? libnm is needed by networkmanager. is there a work around that someone knows of?

  1. missing inxi
  2. try mirrors and update again (shouldn’t garuda-update do that by default? Did you turn that off in the config?)
1 Like

inix wasn’t missing when I tried installing it. It reinstalled though. I refreshed the mirror list. Then tried using Garuda assistant using system update. It now updated everything without a hitch. I am suspecting that a mirror was being used that was having issues. I am guessing that system update uses garuda-update. Haven’t changed anything in my config file, but it’s possible that something I installed may have changed it. But, everything updated and thank you for your suggestion because it gave me the idea of going the route I used.

is not exactly the right command to update the system.
My :crystal_ball: also says you had run pacman -Sy some time earlier.
From that time until you executed the update, your (good) mirror had been updated with newer packages, thus libnm was not at version 1.48.2-1.
I don’t trust my :crystal_ball: , so, can you verify what version is libnm now?

pacman -Q libnm

╭─sevenday4@sevenday4 in ~ took 682ms
[:mag:] × pacman -Q libnm
libnm 1.48.2-1

So apparently, it did update after doing both a mirror refresh and then using the update system in the Garuda Assistant. To be honest, I am puzzled as to why yay or paru would not update and had a hard time finding “libnm” because it does shows up in Archlinux AUR. Maybe Chaotic-AUR has it’s own version of certain packages which garuda-update points to? It’s pretty interesting none the least.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.