Extreme latency while gaming

Hi not really sure what I would google to fix this particular issue since the topic is so ambiguous.

I get 400-1000mbps down when I go to speed test.net but when I try to play games with my friends I freeze up for several seconds at a time. i thought the issue was my friend since he has a very slow CPU and was hosting the game. me hosting the game did help a bit but only temporarily playing warhammer 3 for example is like watching a slide show. if I play wh3 with gerforce now however there isn’t any latency. i can stream the game to my PC connect to the online services using nvidias virtual machine and boom no problems. Am I using a bad driver/

garuda-inxi
System:
Kernel: 6.6.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=435716c2-fab0-48db-a396-d7cd68ec4368 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=291ca7d0-2be9-4ea8-ae6a-b2e2b7e10d4d loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: NZXT product: X570 AORUS MASTER v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS MASTER v: x.x
serial: <superuser required> BIOS: American Megatrends v: F32
date: 01/18/2021
Battery:
ID-1: hidpp_battery_4 charge: 43% condition: N/A volts: 3.8 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: discharging
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3647 high: 4550 min/max: 2200/5083 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3617 2: 4550
3: 3627 4: 3638 5: 4284 6: 3640 7: 3565 8: 3628 9: 3640 10: 3640 11: 4550
12: 3640 13: 3640 14: 3640 15: 3640 16: 2200 17: 3639 18: 4532 19: 3639
20: 2879 21: 3768 22: 3639 23: 3258 24: 3640 25: 2200 26: 3640 27: 4550
28: 3640 29: 3640 30: 3640 31: 3640 32: 3640 bogomips: 217606
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3080 Ti] driver: nvidia v: 545.29.06
alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
built: 2020-2023 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
off: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 0a:00.0 chip-ID: 10de:2208
class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.02x10.71")
s-diag: 554mm (21.82")
Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled
model: ViewSonic VA2256 Series serial: <filter> built: 2022 res: 1920x1080
hz: 60 dpi: 102 gamma: 1.2 size: 476x268mm (18.74x10.55")
diag: 546mm (21.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2
memory: 11.72 GiB
API: Vulkan v: 1.3.269 layers: 7 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 3080 Ti driver: nvidia v: 545.29.06 device-ID: 10de:2208
surfaces: xcb,xlib
Audio:
Device-1: NVIDIA GA102 High Definition Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0a:00.1 chip-ID: 10de:1aef
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Audio-Technica AT2020USB+
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-6.3:5 chip-ID: 0909:001c class-ID: 0300
API: ALSA v: k6.6.4-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-3: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 06:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-5:2 chip-ID: 8087:0029
class-ID: e001
Report: btmgmt ID: hci1 rfk-id: 1 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: N/A
Device-2: ASUSTek ASUS USB-BT500 driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-3:2 chip-ID: 0b05:190e
class-ID: e001 serial: <filter>
Report: ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
status: discoverable: no pairing: no
RAID:
Supported mdraid levels: raid6 raid5 raid4
Device-1: md0 maj-min: 9:0 type: mdraid level: raid-6 status: active
size: 7.28 TiB
Info: report: 4/4 UUUU blocks: 7813772288 chunk-size: 512k
super-blocks: 1.2 algorithm: 2
Components: Online:
0: sdb maj-min: 8:16 size: 3.64 TiB
1: sdc maj-min: 8:32 size: 3.64 TiB
2: sdd maj-min: 8:48 size: 3.64 TiB
3: sde maj-min: 8:64 size: 3.64 TiB
Drives:
Local Storage: total: raw: 16.37 TiB usable: 9.1 TiB used: 1.75 TiB (19.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 211210WD temp: 66.8 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3B6Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD40EFAX-68JH4N1 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: <filter>
ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD40EFAX-68JH4N1 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: <filter>
ID-5: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD40EFAX-68JH4N1 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: <filter>
ID-6: /dev/sde maj-min: 8:64 vendor: Seagate model: ST4000NE001-3CR101
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: HDD rpm: 7200
serial: <filter>
Partition:
ID-1: / raw-size: 897.09 GiB size: 897.09 GiB (100.00%)
used: 794.97 GiB (88.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 897.09 GiB size: 897.09 GiB (100.00%)
used: 794.97 GiB (88.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 897.09 GiB size: 897.09 GiB (100.00%)
used: 794.97 GiB (88.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 897.09 GiB size: 897.09 GiB (100.00%)
used: 794.97 GiB (88.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 34.42 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: swap-2 type: zram size: 125.74 GiB used: 12.94 GiB (10.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 78.5 C mobo: 58.0 C gpu: nvidia temp: 86 C
Fan Speeds (rpm): fan-1: 1227 fan-2: 0 fan-3: 0 gpu: nvidia fan: 60%
Power: 12v: N/A 5v: N/A 3.3v: 3.36 vbat: 3.27
Info:
Processes: 723 Uptime: 4d 1h 52m wakeups: 0 Memory: total: 128 GiB
note: est. available: 125.74 GiB used: 29.15 GiB (23.2%) Init: systemd
v: 254 default: graphical tool: systemctl Compilers: gcc: 13.2.1
clang: 16.0.6 Packages: 1731 pm: pacman pkgs: 1679 libs: 476
tools: octopi,paru,trizen,yay pm: flatpak pkgs: 52 Shell: fish v: 3.6.2
default: Bash v: 5.2.21 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2022-09-08
Last full system update: 2023-12-07
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:            barrierapp.service connectiscsi.service mdmonitor.service vmware.service

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.