External monitor using DP detected but black screen

Hey folks,

I am trying to connect my external monitor (Dell U3011) using DP which the system seems to recognise please below the Display Configuration screenshot, even when taking a screenshot it seems to recognise the external screen, see below, but I have a black screen. HDMI works fine it's just that my monitors' resolution is pretty bad with HDMI.

Any suggestions?

Thanks in advnace!


currently I am using optimus manager

Optimus config in /etc/X11/xorg.conf.d/


Section "Files"
	ModulePath "/usr/lib/nvidia"
	ModulePath "/usr/lib32/nvidia"
	ModulePath "/usr/lib32/nvidia/xorg/modules"
	ModulePath "/usr/lib32/xorg/modules"
	ModulePath "/usr/lib64/nvidia/xorg/modules"
	ModulePath "/usr/lib64/nvidia/xorg"
	ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerLayout"
	Identifier "layout"
	Screen 0 "integrated"
	Inactive "nvidia"
	Option "AllowNVIDIAGPUScreens"
EndSection

Section "Device"
	Identifier "integrated"
	Driver "modesetting"
	BusID "PCI:6:0:0"
	Option "DRI" "3"
EndSection

Section "Screen"
	Identifier "integrated"
	Device "integrated"
EndSection

Section "Device"
	Identifier "nvidia"
	Driver "nvidia"
	BusID "PCI:1:0:0"
	Option "Coolbits" "28"
EndSection

Section "Screen"
	Identifier "nvidia"
	Device "nvidia"
EndSection

xrandr

╰─λ xrandr
Screen 0: minimum 320 x 200, current 4480 x 1600, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1920x1080    120.04*+  48.01    59.97    59.96    59.93  
1680x1050    120.04    59.95    59.88  
1400x1050     74.76    59.98  
1600x900      59.99    59.94    59.95    59.82  
1280x1024    120.04    85.02    75.02    60.02  
1440x900     120.04  
1400x900      59.96    59.88  
1280x960      85.00    60.00  
1440x810      60.00    59.97  
1368x768      59.88    59.85  
1280x800     120.04    59.99    59.97    59.81    59.91  
1152x864      75.00  
1280x720     120.04    60.00    59.99    59.86    59.74  
1024x768     120.04    85.00    75.05    60.04    85.00    75.03    70.07    60.00  
1024x768i     86.96  
960x720       85.00    75.00    60.00  
928x696       75.00    60.05  
896x672       75.05    60.01  
1024x576      59.95    59.96    59.90    59.82  
960x600       59.93    60.00  
832x624       74.55  
960x540       59.96    59.99    59.63    59.82  
800x600      120.04    85.00    75.00    70.00    65.00    60.00    85.14    72.19    75.00    60.32    56.25  
840x525       60.01    59.88  
864x486       59.92    59.57  
700x525       74.76    59.98  
800x450       59.95    59.82  
640x512       85.02    75.02    60.02  
700x450       59.96    59.88  
640x480      120.04    85.09    60.00    85.01    72.81    75.00    59.94  
720x405       59.51    58.99  
720x400       85.04  
684x384       59.88    59.85  
640x400       59.88    59.98    85.08  
576x432       75.00  
640x360       59.86    59.83    59.84    59.32  
640x350       85.08  
512x384       85.00    75.03    70.07    60.00  
512x384i      87.06  
512x288       60.00    59.92  
416x312       74.66  
480x270       59.63    59.82  
400x300       85.27    72.19    75.12    60.32    56.34  
432x243       59.92    59.57  
320x240       85.18    72.81    75.00    60.05
360x202       59.51    59.13
360x200       85.04
320x200       85.27
320x180       59.84    59.32
320x175       85.27
DP-1-0 connected 2560x1600+1920+0 (normal left inverted right x axis y axis) 641mm x 401mm
2560x1600     59.97*+
1920x1440     60.00
1920x1200     59.88
1920x1080     60.00    59.94    50.00    23.98
1600x1200     60.00
1280x1024     75.02    60.02
1280x800      59.81
1280x720      60.00    59.94    50.00
1152x864      75.00
1024x768      75.03    60.00
800x600       75.00    60.32
720x576       50.00
720x480       59.94
640x480       75.00    59.94    59.93
DP-1-1 disconnected (normal left inverted right x axis y axis)
DP-1-2 disconnected (normal left inverted right x axis y axis)
DP-1-3 disconnected (normal left inverted right x axis y axis)
HDMI-1-0 disconnected (normal left inverted right x axis y axis)
1280x1024 (0x54) 135.000MHz +HSync +VSync
h: width  1280 start 1296 end 1440 total 1688 skew    0 clock  79.98KHz
v: height 1024 start 1025 end 1028 total 1066           clock  75.02Hz
1280x1024 (0x55) 108.000MHz +HSync +VSync
h: width  1280 start 1328 end 1440 total 1688 skew    0 clock  63.98KHz
v: height 1024 start 1025 end 1028 total 1066           clock  60.02Hz
1280x800 (0x62) 83.500MHz -HSync +VSync
h: width  1280 start 1352 end 1480 total 1680 skew    0 clock  49.70KHz
v: height  800 start  803 end  809 total  831           clock  59.81Hz
1152x864 (0x64) 108.000MHz +HSync +VSync
h: width  1152 start 1216 end 1344 total 1600 skew    0 clock  67.50KHz
v: height  864 start  865 end  868 total  900           clock  75.00Hz
1024x768 (0x6f) 78.750MHz +HSync +VSync
h: width  1024 start 1040 end 1136 total 1312 skew    0 clock  60.02KHz
v: height  768 start  769 end  772 total  800           clock  75.03Hz
1024x768 (0x71) 65.000MHz -HSync -VSync
h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
v: height  768 start  771 end  777 total  806           clock  60.00Hz
800x600 (0x8d) 49.500MHz +HSync +VSync
h: width   800 start  816 end  896 total 1056 skew    0 clock  46.88KHz
v: height  600 start  601 end  604 total  625           clock  75.00Hz
800x600 (0x8e) 40.000MHz +HSync +VSync
h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
v: height  600 start  601 end  605 total  628           clock  60.32Hz
640x480 (0xa2) 31.500MHz -HSync -VSync
h: width   640 start  656 end  720 total  840 skew    0 clock  37.50KHz
v: height  480 start  481 end  484 total  500           clock  75.00Hz
640x480 (0xa3) 25.175MHz -HSync -VSync
h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
v: height  480 start  490 end  492 total  525           clock  59.94Hz
inxi -Faz
╰─λ inxi -Faz
System:
Kernel: 5.15.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=875ee751-6d22-4c6a-9792-04892f87fa86 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: PC Specialist product: GK7NPFR v: Standard
serial: <superuser required>
Mobo: TongFang model: GK5NPFO v: Standard serial: <superuser required>
UEFI: American Megatrends v: N.1.20PCS04 date: 12/11/2020
Battery:
ID-1: BAT0 charge: 39.9 Wh (100.0%) condition: 39.9/46.7 Wh (85.4%)
volts: 12.5 min: 11.4 model: standard type: Li-ion serial: <filter>
status: Full
CPU:
Info: model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600103
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1420 high: 1697 min/max: 1400/2900 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1697 2: 1477
3: 1397 4: 1397 5: 1397 6: 1396 7: 1397 8: 1397 9: 1397 10: 1396 11: 1397
12: 1397 13: 1397 14: 1395 15: 1397 16: 1396 bogomips: 92621
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU116M [GeForce GTX 1650 Ti Mobile]
vendor: Tongfang Hongkong Limited driver: nvidia v: 495.46
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2192
class-ID: 0300
Device-2: AMD Renoir vendor: Tongfang Hongkong Limited driver: amdgpu
v: kernel bus-ID: 06:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 3-4:4
chip-ID: 04f2:b642 class-ID: 0e02
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1600 s-dpi: 96 s-size: 1182x422mm (46.5x16.6")
s-diag: 1255mm (49.4")
Monitor-1: eDP-1 res: 1920x1080 hz: 120 dpi: 142
size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
Monitor-2: DP-1-0 res: 2560x1600 hz: 60 dpi: 101
size: 641x401mm (25.2x15.8") diag: 756mm (29.8")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: NVIDIA TU116 High Definition Audio
vendor: Tongfang Hongkong Limited driver: snd_hda_intel v: kernel
bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Tongfang Hongkong Limited
driver: snd_hda_intel v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound Server-1: ALSA v: k5.15.10-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Tongfang Hongkong Limited driver: r8169 v: kernel port: e000
bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 03:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlo1 state: up mac: <filter>
╰─λ nvidia-smi
Wed Dec 22 15:30:43 2021
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 495.46       Driver Version: 495.46       CUDA Version: 11.5     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   44C    P8     6W /  N/A |      5MiB /  3911MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       779      G   /usr/lib/Xorg                       4MiB |
+-----------------------------------------------------------------------------+


All HDMI cables are not created equally, especially older cables. Newer cables are capable of handing 4K or 8K resolutions (but you must be sure they actually do). Older, (or cheaper cables that may claim to be 4K capable) may just not be up to the task of displaying @4K properly.

3 Likes

thanks for the feedback, it's not actually the cable but it's the monitor itself which for HDMI max resolution is 1920x1080 , for my work I use a mac with a docking station via HDMI to DVI (which has a better max resolution) but I have not been able to replicate this on my personal machine, hence I enquired about mini DP which has a max resolution of 2560x1600.

p.s. I tried the HDMI on my TV and it's amazing, so I ruled out the cable

1 Like

Folks,

I think the DisplayPort is not working on the monitor, I tested it with another machine (mac), so in meantime, is it possible to increase the resolution by having an HDMI (Linux machine) - DVI (Monitor) (which has 2560 x 1600) for my linux machine?

I have this working using a docking station and it achieves the max resolution with my mac

many thanks and happy holidays!

turns out it was the monitors dp not working properly, new monitor works just fine.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.