External monitor starts extreme lag if laptop display is shut off

Hi!

Two weeks ago I installed Garuda KDE (dragonized) edition on my laptop.

Works fine as farr as I can tell.

But now I connected an external monitor. And this still works fine if I use the laptop display as primary screen and the external monitor as secondary screen.

But if I switch off the laptop display or if I switch the "primary" setting to he external monitor - KDE starts lagging. A lot! The mouse still moves smooth but every click or movement of windows reacts with a delay of at least one second - it's unusable.

I goolged but found only posts of users with NVIDIA graphics. Mine is the mobile AMD Radeon 6600...

Here's my system info... anyone any ideas how to fix this?


System:
Kernel: 6.1.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=632f8a8c-c1aa-49ef-a0de-f2c8d53339c1 rw [email protected]
cryptdevice=UUID=cecb7477-0fe5-41aa-8fd4-e93bcd974252:luks-cecb7477-0fe5-41aa-8fd4-e93bcd974252
root=/dev/mapper/luks-cecb7477-0fe5-41aa-8fd4-e93bcd974252 splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Micro-Star product: Alpha 17 B5EEK v: REV:1.0
serial: Chassis: type: 10 serial:
Mobo: Micro-Star model: MS-17LL v: REV:1.0 serial:
UEFI: American Megatrends LLC. v: E17LLAMS.103 date: 08/06/2021
Battery:
ID-1: BAT1 charge: 79.5 Wh (90.4%) condition: 87.9/87.4 Wh (100.6%)
volts: 16.9 min: 15.4 model: MSI Corp. MS-17 type: Li-ion serial: N/A
status: not charging
CPU:
Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000C
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3311 high: 4392 min/max: 1200/4462 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3512 2: 2965
3: 2415 4: 2757 5: 2769 6: 3200 7: 2452 8: 4024 9: 4160 10: 4392 11: 3513
12: 3200 13: 4038 14: 3200 15: 2483 16: 3902 bogomips: 102208
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Graphics:
Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Micro-Star MSI
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DP-1 bus-ID: 03:00.0 chip-ID: 1002:73ff
class-ID: 0380
Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-5.1 code: Vega-2
process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1 empty: none
bus-ID: 07:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 50.0 C
Device-3: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 1-4:3
chip-ID: 5986:211b class-ID: 0e02
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 5760x1200 s-dpi: 96 s-size: 1520x316mm (59.84x12.44")
s-diag: 1552mm (61.12")
Monitor-1: HDMI-A-1 mapped: HDMI-A-1-0 pos: right
model: Philips PHL 439P9H serial: built: 2020 res: 3840x1200 hz: 60
dpi: 93 gamma: 1.2 size: 1050x330mm (41.34x12.99") diag: 1102mm (43.4")
modes: max: 3840x1200 min: 640x350
Monitor-2: eDP-1 mapped: eDP pos: primary,left
model: ChiMei InnoLux 0x176e built: 2019 res: 1920x1080 dpi: 128 gamma: 1.2
size: 381x214mm (15x8.43") diag: 437mm (17.2") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon Graphics (renoir LLVM
15.0.7 DRM 3.49 6.1.2-zen1-1-zen) direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Micro-Star MSI
driver: snd_rn_pci_acp3x v: kernel
alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_rpl_pci_acp6x,snd_pci_ps,snd_sof_amd_renoir,snd_sof_amd_rembrandt
pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
bus-ID: 07:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-4: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound API: ALSA v: k6.1.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: down mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac:
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:3
chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Drives:
Local Storage: total: 476.94 GiB used: 73.76 GiB (15.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-AI1
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: rev: ECFK52.8 temp: 32.9 C scheme: GPT
Partition:
ID-1: / raw-size: 327.58 GiB size: 327.58 GiB (100.00%)
used: 73.74 GiB (22.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-cecb7477-0fe5-41aa-8fd4-e93bcd974252
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 26 MiB (8.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 327.58 GiB size: 327.58 GiB (100.00%)
used: 73.74 GiB (22.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-cecb7477-0fe5-41aa-8fd4-e93bcd974252
ID-4: /var/log raw-size: 327.58 GiB size: 327.58 GiB (100.00%)
used: 73.74 GiB (22.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-cecb7477-0fe5-41aa-8fd4-e93bcd974252
ID-5: /var/tmp raw-size: 327.58 GiB size: 327.58 GiB (100.00%)
used: 73.74 GiB (22.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-cecb7477-0fe5-41aa-8fd4-e93bcd974252
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.01 GiB used: 520.8 MiB (3.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 57.5 C mobo: N/A
Fan Speeds (RPM): N/A
GPU: device: amdgpu temp: 48.0 C mem: 48.0 C fan: 0 watts: 7.00
device: amdgpu temp: 51.0 C
Info:
Processes: 444 Uptime: 2h 50m wakeups: 22 Memory: 15.01 GiB
used: 10.57 GiB (70.4%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1412
libs: 440 tools: octopi,paru Shell: fish v: 3.6.0 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
System install date: 2023-01-04
Last full system update: 2023-01-22 ↻
Is partially upgraded: No
Relevant software: snapper NetworkManager mkinitcpio
Windows dual boot: Probably (Run as root to verify)
Failed units: