External monitor crashing ssdm when connected

After a update today, when I try to login with my external monitor connected to my hdmi output port from my discrete gpu the ssdm-helper crashes and returns to the login manager I already tried to clear kde5 cache but it did not work, I've been looking into the journalctl to see what is causing the problem but I can't manage to find it, I'll send both the inxi and the journalctl of today for you guy to read and try to help me.
inxi -Fza:

System:    Kernel: 5.10.48-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=30f871dd-7d1e-48fd-8a77-9fcbb44a5f1a rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Console: tty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Dell model: 0P84C9 v: A01 serial: <filter> UEFI: Dell v: 1.12.1 date: 06/19/2020 
CPU:       Info: Quad Core model: Intel Core i7-7700HQ socket: U3E1 bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 9E (158) stepping: 9 microcode: EA cache: L1: 256 KiB L2: 6 MiB L3: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798 
           Speed: 3549 MHz min/max: 800/3800 MHz base/boost: 2700/2800 volts: 0.9 V ext-clock: 100 MHz Core speeds (MHz): 
           1: 3549 2: 2292 3: 3320 4: 3438 5: 1923 6: 3240 7: 3268 8: 3128 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:591b 
           class-ID: 0300 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nvidia v: 460.67 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300 
           Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-12:5 chip-ID: 0bda:568a class-ID: 0e02 
           serial: <filter> 
           Display: server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.1.4 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 
           class-ID: 0403 
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9 
           class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.48-1-lts running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.31 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: d000 
           bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel 
           port: d000 bus-ID: 03:00.0 chip-ID: 168c:003e class-ID: 0280 
           IF: wlp3s0 state: down mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 0cf3:e007 class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: <filter> 
Drives:    Local Storage: total: 1.82 TiB used: 226.58 GiB (12.2%) 
           ID-1: /dev/sda maj-min: 8:0 vendor: KingDian model: NGFF 2280 1TB SSD size: 931.51 GiB block-size: physical: 512 B 
           logical: 512 B sata: 3.2 speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 9A0 temp: 40 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 129d 0h cycles: 216 read: 51.5 MiB written: 76 MiB 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABD100 family: 2.5" HDD MQ01ABD... size: 931.51 GiB 
           block-size: physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 3D 
           temp: 33 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 2y 79d 3h cycles: 1415 read: 11.76 TiB written: 10.76 TiB Old-Age: 
           g-sense error rate: 2037 
Partition: ID-1: / raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 65.87 GiB (65.5%) fs: btrfs block-size: 4096 B 
           dev: /dev/sda3 maj-min: 8:3 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat block-size: 512 B 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 830.63 GiB size: 830.63 GiB (100.00%) used: 160.72 GiB (19.3%) fs: btrfs block-size: 4096 B 
           dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 65.87 GiB (65.5%) fs: btrfs block-size: 4096 B 
           dev: /dev/sda3 maj-min: 8:3 
           ID-5: /var/tmp raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 65.87 GiB (65.5%) fs: btrfs block-size: 4096 B 
           dev: /dev/sda3 maj-min: 8:3 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 23.35 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 53.0 C mobo: 41.0 C sodimm: SODIMM C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 308 Uptime: 37m wakeups: 1 Memory: 23.35 GiB used: 3.95 GiB (16.9%) Init: systemd v: 248 tool: systemctl 
           Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1997 pacman: 1985 lib: 551 flatpak: 6 snap: 6 Shell: Zsh (sudo) 

journalctl -n 7000 --system --since="2021-07-10 11:11:00" :
https://paste.ofcode.org/QWUAEMmkTg2xgGqeh8zhew
just pasted there because I cant upload the file and pastebin doesn't seem to load to me, some kind of route issue with my ISP

Garuda PrivateBin work fine here.

2021-07-10_17-12

4 Likes

Have you tried as system roll back using timeshift?

If that doesn't fully correct the issue, then try creating a new user account after the system roll back.

5 Likes

That's an overkill for a log. You are probably panicked.

Clean all local cache ($HOME/.cache/*).

Check your pacman update log for messages and failures.
Confirm proper package update status.

In any case, create and log into a new user, to confirm it is not a system issue.

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.