External Display on Lenovo Legion 7 (Ryzen CPU + NVIDIA GPU)

I am using the recently released Lenovo Legion 7 ( 16ACHg6) with AMD Ryzen 9 5900HX and NVIDIA GeForce RTX 3080.

I chose to use opensource drivers during the installation, and I see that DURING BOOTUP my external monitor turns on for about 5 second and shows an eagle (Garuda) for 5 seconds before turning off.

After that the OS appears to think that my external monitor no longer exists. I am new to using Linux on a desktop.

What happens if you use the option for the NVIDIA drivers?

Is this well-supported by the nouveau driver?

This is a laptop?

Also, Linux isn't Windows, so don't expect things to "just work" on newer or more obscure hardware (like the laptop you've just bought).

2 Likes

First:
Research your model. Some laptop models only have support for integrated graphics on their display ports.

Although , I would think a 5900hs would not have a integrated graphic chip

Edit: maybe it does. What is the unknown β€œati” device

1 Like

ATI is the AMD cpu, it uses its old name on devices.

I will try the closesource driver for NVIDIA once I get to the machine. However, I believe that this may not be a driver issue as during bootup β€œI see that my external monitor turns on for about 5 second and shows an eagle (Garuda) for 5 seconds before turning off.” So something os already working before it get switches off.

Press Esc on "Eagle" to see the terminal output.

2 Likes

There are two roads here. As most things in life, one is hard but right and one is easy and wrong:

  1. Provide feedback to the Linux community to help adjust current drivers and configurations to this newly released model
  2. Just use the included OS, so you can play games easily.

I could not understand whether you have managed to install Garuda, or stuck on installation.

If you want to follow the 1st road, you can try some things:

  1. Boot with no external monitor(s), so you can see what is the behavior.
  2. Check in BIOS for available (e/d)GPU options (hybrid, auto, enable, disable)
  3. If there is an option to use only nvidia, select this and use the proprietary option at Installer Grub (1st screen). Install and boot (hopefully) to your installed system and add video-linux in Garuda HW manager\
  4. If there is an Auto option in BIOS for GPUs, do not ever use it, as it is known to confuse Linux HW detection.
  5. Keep HW and Xorg logs from before and after you make video drivers changes, so we can track what happens. Mainly these:
inxi -Gxxxza
cat /var/log/Xorg.0.log
journalctl -b -p3
  1. From your 1st successful login to the ISO installer session, get and post these
inxi -Fxxxza
cat /var/log/Xorg.0.log
journalctl -b -p3

Welcome to Garuda Linux!!

6 Likes

Status: Garuda Linux is successfully installed. I can use it no problem (except for the no sound issue) with my laptop screen. I even added "amdgpu.brightness=0" to enable laptop screen brightness control. Yet, I am trying to get my external monitor to work, which appears to not be working.

Further experiments:
BIOS: Hybrid Graphics

  • Using opensource drivers: when starting Garuda, external monitor briefly shows Eagle for 5 second before the monitor gets disconnected. Laptop screen shows Eagle at the same time before proceeding to run Garuda as normal.
  • Using proprietary drivers: external monitor does not show anything. Laptop screen shows Eagle before proceeding to boot Garuda as normal.

BIOS: Discrete Graphics

  • Using proprietary drivers: Garuda fails to boot.

Partial Solution !!!

BIOS: Discrete Graphics
Using Proprietary drivers at installation
External monitor works right from the start !!!

I really wish I could use Automatic Graphics though.

3 Likes

You probably could if you installed the prime-render-offload driver profile. But that would also rely on you having told us you had hybrid graphics.

4 Likes

What would be the easiest way to do this? Should I continue from where I am (successfully installed with Discrete Graphics) and enable the prime-render-offload?

Or, should I start installation over using Hybrid Graphics and going from there.

Surprisingly I tried Ubuntu and other distros and I only got this far with Garuda.

That would be following given advice. :man_shrugging:

Now that you have disabled amdgpu card, you won't have the prime-render-offload config available.
But you may try adding video-linux and tell us how it fails :upside_down_face: , or not.

It seems your laptop output is linked to nvidia card. That's why it jumps over during boot.
Also it is important if all video outputs are connected to nvidia, or some specific.

Read User's Manual!!

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.