Expat error interrupting the installation and updation process

Hello.
I freshly installed Garuda-qtile edition, but after the update I am new facing this "expat" issue as its not letting me install some additional packages at all.

sudo rm  /var/lib/pacman/db.lck
[sudo] password for raj:
rm: cannot remove '/var/lib/pacman/db.lck': No such file or directory
McFly: Importing shell history for the first time. This may take a minute or two...done.

 [email protected] in ~ as 🧙 took 4s
[🔴] × garuda-update
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur                                                1565.7 KiB   564 KiB/s 00:03 [---------------------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronizing package databases...
 core                                                        133.1 KiB   314 KiB/s 00:00 [---------------------------------------------------] 100%
 extra                                                      1543.0 KiB  2.26 MiB/s 00:01 [---------------------------------------------------] 100%
 community                                                     6.1 MiB  4.18 MiB/s 00:01 [---------------------------------------------------] 100%
 multilib                                                    149.0 KiB   369 KiB/s 00:00 [---------------------------------------------------] 100%
 chaotic-aur                                                1565.7 KiB   795 KiB/s 00:02 [---------------------------------------------------] 100%

--> Applying keyring updates before starting full system update..
error: duplicated database entry 'expat'
warning: archlinux-keyring-20220224-1 is up to date -- skipping
warning: chaotic-keyring-20220220-1 is up to date -- skipping
warning: garuda-hotfixes-1.1.1-1 is up to date -- skipping
 there is nothing to do
spawn pacman -Su
:: Starting full system upgrade...
error: duplicated database entry 'expat'
resolving dependencies...
looking for conflicting packages...

Packages (1) expat-2.4.6-1

Total Installed Size:  0.40 MiB
Net Upgrade Size:      0.01 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                           [---------------------------------------------------] 100%
(1/1) checking package integrity                                                         [---------------------------------------------------] 100%
(1/1) loading package files                                                              [---------------------------------------------------] 100%
(1/1) checking for file conflicts                                                        [---------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
expat: /usr/lib/cmake/expat-2.4.6/expat-config-version.cmake exists in filesystem
expat: /usr/lib/cmake/expat-2.4.6/expat-config.cmake exists in filesystem
expat: /usr/lib/cmake/expat-2.4.6/expat-none.cmake exists in filesystem
expat: /usr/lib/cmake/expat-2.4.6/expat.cmake exists in filesystem
expat: /usr/lib/libexpat.so.1.8.6 exists in filesystem
Errors occurred, no packages were upgraded.

 [email protected] in ~ as 🧙 took 2m3s
[🔴] × ls /var/lib/pacman/local/ | grep expat
drwxr-xr-x - root 31 Jan 21:24  expat-2.4.4-1
drwxr-xr-x - root 28 Feb 19:35  expat-2.4.6-1
drwxr-xr-x - root 28 Feb 19:36  lib32-expat-2.4.6-1

I have tried the method that is available in this link Errors ! shoud i worry about this erorrs

But nothing seems to be working.

I tried the below commands to remove the three entries of expat but it shows something like this.

sudo -Rcns expat lib32-expat
sudo: you are not permitted to use the -R option with expat

sudo purge expat lib32-expat
sudo: purge: command not found

Please tell me what to do now!!

sudo rm -r /var/lib/pacman/local/expat-2.4.4-1
sudo pacman -S --overwrite="*" expat lib32-expat
garuda-update

I'll see if I can fix this issue in garuda-update somehow so this doesn't happen for anyone else until we release a new ISO.

5 Likes

You are passing the -Rncs options to the sudo command. If you are trying to remove the package then you are missing the pacman command,

sudo pacman -Rncs expat
4 Likes

And

:slight_smile:

1 Like

Thanks, This seems to have worked, but now my dmenu is not opening as its showing something like this

dmenu
warning: no locale support

Different issue = new thread.

1 Like

Ok
thanks for telling me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.