Executing unified remote on Boot

Hi, I'm a complete LInux noob and i've just switched from windows because i'm tired of microsoft spying on me. For the most part everything has been fine apart from the fact that i cannot for the life of me make unified remote boot on startup.
I currently have the portable version of the app and it works fine if i double click on it but i don't want to do it everytime i boot my computer. I want it to be done automatically.
I tried adding it to the autostartup tab in settings but it still doesn't work.

I would really appreciate your help.

System:
Kernel: 6.1.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=99bd775c-9336-4ac2-b6c6-6ac136d9f118 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: B450 AORUS M v: N/A
serial: <superuser required>
Mobo: Gigabyte model: B450 AORUS M serial: <superuser required>
UEFI: American Megatrends LLC. v: F63d date: 07/26/2022
CPU:
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 gen: 4
level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3644 high: 3700 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3591 2: 3684
3: 3669 4: 3600 5: 3637 6: 3700 7: 3636 8: 3700 9: 3643 10: 3700 11: 3576
12: 3597 bogomips: 88799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2070 Rev. A] vendor: ZOTAC
driver: nvidia v: 525.85.05 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2022-12) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 07:00.0 chip-ID: 10de:1f07 class-ID: 0300
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
s-diag: 610mm (24")
Monitor-1: DP-0 res: 1920x1080 dpi: 93 size: 527x296mm (20.75x11.65")
diag: 604mm (23.8") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA GeForce RTX
2070/PCIe/SSE2 direct render: Yes
Audio:
Device-1: NVIDIA TU106 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel bus-ID: 5-2:2 v: kernel chip-ID: 0c76:162f pcie:
class-ID: 0300 gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 07:00.1
chip-ID: 10de:10f9 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: JMTek LLC. KLIM Voice V2 type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.7-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 14c3:0608
class-ID: 0280
IF: wlp6s0 state: up mac: <filter>
Bluetooth:
Device-1: MediaTek Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-7:4 chip-ID: 0e8d:0608 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 2.15 TiB used: 163.29 GiB (7.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD Blue SN570 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 234110WD temp: 43.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Corsair model: Force LE200 SSD
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 61.1 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-75WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Crucial
model: CT240BX500SSD1 size: 223.57 GiB block-size: physical: 4096 B
logical: 512 B type: SSD serial: <filter> rev: 1214 scheme: MBR
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 163.29 GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 163.29 GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 163.29 GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 163.29 GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 55.1 C mobo: N/A gpu: nvidia temp: 45 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 31%
Info:
Processes: 336 Uptime: 6m wakeups: 1 Memory: 15.54 GiB
used: 3.71 GiB (23.9%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1927
libs: 539 tools: octopi,paru Shell: fish v: 3.6.0 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2023-01-21
Last full system update: 2023-01-22
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Can you more specifically describe what you added to the startup tab?

I added the application called "urserv" which starts the service when i double click it. However this application doesn't have an extension it's labeled as an executable according to the file manager..

Try to add it in autostart as

/opt/urserver/urserver --daemon

I'm sorry i am a beginner but how do i do that ?

Search for autostart in the system settings.
In case of troubles there are so many tutorials on the internet.
For a better understanding of how it works and the several ways it can be done, the best reference is always the Arch wiki.
https://wiki.archlinux.org/title/Autostarting
(Including a link to KDE autostart)
I'm referencing this guide because the Arch wiki is the best way to start learning Arch and Arch-based distros, and because I guess (I don't know this application at all) you could also start the server as a systemd service.

2 Likes

i managed to create a bash script to open the app however i still can't get garuda to execute this script when i boot up. I still have to manually open the script, is there any way you could help me ?
I added it to the autostart folder and i also tried to do it from the autostart app in the settings and it still doesn't work