Exchange ffmpeg with ffmpeg-amd

Everytime I post here, I’m asked about that, so here it is my inxi file: Garuda's PrivateBin

I have a AMD-Only system here (Ryzen 5900X, AMD/ATi 6700 12GB)
I tried ffmpeg (ffmpeg 2:6.1.1-6, extra) and now I have seen, there is a AMD version of it. When I want to replace the old ffmpeg with ffmpeg-amd one.

I tried: delete ffmpeg → that is not working because of depencies. After deleting the system will not reboot, so I made a turnback to the last snapshoot.

Install ffmpeg-amd is not working because it conflicts with the normal ffmpeg that can not be solved with my knowledge.

So I need your help. How to replace the ffmpeg with the ffmpeg-amd version? Maybe enable some kernel mods needed too?

The actual ffmpeg is not working with libopus, wich is activated in ffmpeg and installed inclusive the opus-tools. Will that be solved afterwards? Would be nice…

This is not meant to be a solving answer, but what exactly do you mean by that?
It seems to me that ffmpeg-amd-full in the AUR (if this is the package you want to use) has the “conflicts” and “provides” for replacement.
Maybe you could provide the output of:

paru ffmpeg-amd-full

to check what is not working.

I don’t think this is worth the effort. We banned it on Chaotic-AUR because:

mpv-amd, ffmpeg-amd: This is just MPV/FFMPEG without CUDA and NVENC to achieve shorter build times without actual end-user benefit.

So basically you get a lighter package, but for what? You will have to update it, recompile it against a lot of deps, ultimately wasting your time.


Ahh, okay. Than it is a “not needed” thing.
I have here many videos to transcode and with ffmpeg from command line I can add many of the metadata in one, that’s why I would use ffmpeg and AMD-version sounded good in first place. Now I will try another way: Let Handbrake (like now) do the transcode and look for a way to add metadata later.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.