Every time i open a steam game, garuda logs out of my account

I downloaded steam native and downloaded a low graphic game, every time I try to launch it, the system logs out and closes everything that was open. there is nothing with my hardware. I have intel i7 and 16GB DDR3 Ram. and Intel HD Graphics.

Can you provide your

inxi -Faz

please

1 Like
System:
Kernel: 5.15.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b3d84ad5-60fd-45aa-a0f9-6fd3f466cafc rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Hewlett-Packard product: HP Z220 CMT Workstation
v: N/A serial: <superuser required> Chassis: type: 6
serial: <superuser required>
Mobo: Hewlett-Packard model: 1790 serial: <superuser required>
UEFI: Hewlett-Packard v: K51 v01.86 date: 06/13/2018
CPU:
Info: model: Intel Core i7-3770 bits: 64 type: MT MCP arch: Ivy Bridge
family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3022 high: 3892 min/max: 1600/3900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1716 2: 3836 3: 3585
4: 3780 5: 3892 6: 2227 7: 3393 8: 1752 bogomips: 54279
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics
vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:0162 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI1 res: 1920x1080 hz: 60 dpi: 81
size: 600x340mm (23.6x13.4") diag: 690mm (27.2")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k5.15.10-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
driver: e1000e v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502
class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: TP-Link TL-WN722N v2/v3 [Realtek RTL8188EUS] type: USB
driver: r8188eu bus-ID: 2-1.8:3 chip-ID: 2357:010c class-ID: 0000
serial: <filter>
IF: wlp0s29u1u8 state: up mac: <filter>
RAID:
Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
port: f060 bus-ID: 00:1f.2 chip-ID: 8086:2822 rev: N/A class-ID: 0104
Drives:
Local Storage: total: 606.99 GiB used: 96.61 GiB (15.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Hikvision model: HS-SSD-C100 120G
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 979 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500DM002-1BD142
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: KC65
scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Generic model: Flash Disk
size: 29.44 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> rev: 8.07 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 58.45 GiB (52.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 58.45 GiB (52.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 58.45 GiB (52.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 58.45 GiB (52.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.07 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 330 Uptime: 2h 26m wakeups: 0 Memory: 15.07 GiB
used: 3.75 GiB (24.9%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: 1687 apt: 2 pacman: 1674 lib: 491
flatpak: 11 Shell: fish v: 3.3.1 default: Bash v: 5.1.12
running-in: konsole inxi: 3.3.11

Have you tried with steam runtime

1 Like

when i open it, it actually opens steam native, should i delete native and open runtime?

You can install it side byside , when installed run and choose game from there.
What game you trying to play

2 Likes

well, I already have steam native and steam runtime, and I'm playing: I MAED A GAM3 W1TH Z0MB1ES 1NIT!!!1

Start steam in terminal and start game and see what error comes up?

1 Like

Have you already tried a different kernel, starting from linux-lts?

2 Likes

can the kernel be the problem?

Is it restarting, or is it just logging out? I ask because a few months ago anytime I would start a game my pc would restart and through process of elimination I figured out my power supply was going bad, and my GPU would put enough of a draw on it to make the system restart.

only logs off

steam.sh[875086]: Running Steam on garuda Soaring 64-bit
steam.sh[875086]: STEAM_RUNTIME is disabled by the user
steam.sh[875086]: Can't find 'steam-runtime-check-requirements', continuing anyway
[2021-12-20 01:22:40] Startup - updater built Dec 16 2021 22:39:04
Installing breakpad exception handler for appid(steam)/version(1639697812)
[2021-12-20 01:22:40] Loading cached metrics from disk (/home/mrrobot/.local/share/Steam/package/steam_client_metrics.bin)
[2021-12-20 01:22:40] Using the following download hosts for Public, Realm steamglobal
[2021-12-20 01:22:40] 1. https://cdn.akamai.steamstatic.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2021-12-20 01:22:40] 2. https://cdn.cloudflare.steamstatic.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2021-12-20 01:22:40] 3. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
Installing breakpad exception handler for appid(steam)/version(1639697812)
[2021-12-20 01:22:40] Verifying installation...
[2021-12-20 01:22:40] Verification complete
Loaded SDL version 2.0.19-6963453

(steam:875168): Gtk-WARNING **: 01:22:41.048: Unable to locate theme engine in module_path: "adwaita",

(steam:875168): Gtk-WARNING **: 01:22:41.052: Unable to locate theme engine in module_path: "murrine",

(steam:875168): Gtk-WARNING **: 01:22:41.052: Unable to locate theme engine in module_path: "murrine",

(steam:875168): Gtk-WARNING **: 01:22:41.053: Unable to locate theme engine in module_path: "murrine",

(steam:875168): Gtk-WARNING **: 01:22:41.053: Unable to locate theme engine in module_path: "murrine",

(steam:875168): Gtk-WARNING **: 01:22:41.053: Unable to locate theme engine in module_path: "murrine",
Installing breakpad exception handler for appid(steam)/version(1639697812)
steamwebhelper.sh[875175]: Runtime for steamwebhelper: disabled by environment (this is unsupported)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
CAppInfoCacheReadFromDiskThread took 19 milliseconds to initialize
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Proceed to auto login
Installing breakpad exception handler for appid(steam)/version(1639697812)
Opted-in Controller Mask for AppId 0: 0

(steam:875168): Gtk-WARNING **: 01:22:42.265: gtk_disable_setlocale() must be called before gtk_init()
Installing breakpad exception handler for appid(steam)/version(1639697812)
MESA-INTEL: warning: Ivy Bridge Vulkan support is incomplete
Installing breakpad exception handler for appid(steam)/version(1639697812)
MESA-INTEL: warning: Ivy Bridge Vulkan support is incomplete
roaming config store loaded successfully - 302 bytes.
migrating temporary roaming config store
BRefreshApplicationsInLibrary 1: 5ms
Installing breakpad exception handler for appid(steam)/version(1639697812)
Failed to init SteamVR because it isn't installed
ExecCommandLine: "'/home/mrrobot/.local/share/Steam/ubuntu12_32/steam'"
System startup time: 4.04 seconds
BuildCompleteAppOverviewChange: 104
RegisterForAppOverview 1: 3ms
RegisterForAppOverview 2: 3ms
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)
Installing breakpad exception handler for appid(steam)/version(1639697812)

Just a thought reinstall steam as steam is not starting properly

steam.sh[455331]: Running Steam on garuda Soaring 64-bit
steam.sh[455331]: STEAM_RUNTIME is enabled automatically
setup.sh[455404]: Steam runtime environment up-to-date!
steam.sh[455331]: Steam client's requirements are satisfied

this is my start of steam

1 Like

Something similar happened to be solved in that way a couple of times in the past. Of course we cannot say it's 100% the same issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.