Every system upgrade (Octopi) resets my keyboard layouts and enables my microphone


I run the LXQt version of Garuda.
None of my microphones on my system are typically found or listed in Pulsaudio (pavucontrol-qt) unless I’ve done a system upgrade (I use octopi for this) in the same running session, after which all microphones are typically found by the system and work as intended. When I reboot, any connected microphones can no longer be found again.

Every time I do a system upgrade, my keyboard settings (under lxqt input settings, “Keyboard and Mouse Settings”) are also resetted. I want to use 2 keyboard layouts and switch between them by holding caps lock. After every system upgrade, the keyboard settings are reset to only one keyboard layout (my main one) and the secondary keyboard layout together with the setting to hold caps lock to activate it, is viped out. After which I have to manually set it again.

I want my microphones to be found by my system without having to force a system upgrad and I do not want to manually change my keyboard settings after each system upgrade.

As they both happen with system upgrades I suspect they couldb e caused by a single issue. Please excuse my ignorance if these two issues are unrelated and thus should have been issued as two separate issues.


  Kernel: 6.5.4-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b594f541-2664-43b4-b1ee-80ebd1a3a03b rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: LXQt v: 1.3.0 tk: Qt v: 5.15.10 info: cairo-dock, lxqt-panel
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: Latitude 7310 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0KD96W v: A00 serial: <superuser required> UEFI: Dell
    v: 1.7.0 date: 05/27/2021
  ID-1: BAT0 charge: 37.0 Wh (100.0%) condition: 37.0/51.0 Wh (72.5%)
    volts: 8.4 min: 7.6 model: LGC-LGC6.843 DELL 4V5X209 type: Li-poly
    serial: <filter> status: full
  Info: model: Intel Core i5-10310U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 10 level: v3 note: check
    built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xF8
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 600 high: 800 min/max: 400/4400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 400 3: 400 4: 400
    5: 800 6: 400 7: 800 8: 800 bogomips: 35199
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Dell Latitude 7310
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:9b41 class-ID: 0300                                                                                                                                                                                  
  Device-2: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0                                                                                                                                                                
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3 chip-ID: 0bda:5539                                                                                                                                                                     
    class-ID: 0e02 serial: <filter>                                                                                                                                                                                                         
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1                                                                                                                                                                             
    compositor: kwin_x11 driver: X: loaded: modesetting                                                                                                                                                                                     
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1                                                                                                                                                               
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")                                                                                                                                                                   
    s-diag: 582mm (22.93")                                                                                                                                                                                                                  
  Monitor-1: eDP-1 model: LG Display 0x05db built: 2018 res: 1920x1080                                                                                                                                                                      
    hz: 60 dpi: 166 gamma: 1.2 size: 294x165mm (11.57x6.5") diag: 337mm (13.3")                                                                                                                                                             
    ratio: 16:9 modes: 1920x1080                                                                                                                                                                                                            
  API: OpenGL v: 4.6 Mesa 23.1.8-arch1.1 renderer: Mesa Intel UHD Graphics                                                                                                                                                                  
    (CML GT2) direct-render: Yes                                                                                                                                                                                                            
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Dell driver: snd_hda_intel                                                                                                                                                                 
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3                                                                                                                                                             
    chip-ID: 8086:02c8 class-ID: 0403                                                                                                                                                                                                       
  API: ALSA v: k6.5.4-zen2-1-zen status: kernel-api with: aoss                                                                                                                                                                              
    type: oss-emulator tools: alsactl,alsamixer,amixer                                                                                                                                                                                      
  Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:5 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
  Hardware-1: Intel Comet Lake RAID Controller driver: intel_nvme_remap v: N/A
    port: 3060 bus-ID: 0000:00:17.0 chip-ID: 8086:02d7 rev: class-ID: 0104
  Local Storage: total: 238.47 GiB used: 34.09 GiB (14.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B tech: SSD
    serial: <filter> fw-rev: 11004101 temp: 36.9 C scheme: GPT
  ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
    used: 34.08 GiB (14.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 592 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
    used: 34.08 GiB (14.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
    used: 34.08 GiB (14.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
    used: 34.08 GiB (14.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.3 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 294 Uptime: 8m wakeups: 386 Memory: total: 16 GiB note: est.
  available: 15.3 GiB used: 3.98 GiB (26.0%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1517 libs: 496 tools: octopi,paru Shell: Bash v: 5.1.16
  running-in: qterminal inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-09-06
  Last full system update: 2023-09-26
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

For updates, use only the terminal, please.


or shorter, just update.

If this does not change anything, post again.

1 Like

I ran garuda-update in QTerminal. (Luckily there was one non-updated package to update.)
After updating, the terminal prints “System Updated!”

My keyboard layout settings did not change. Neither did my computer find connected (audio) input devices.

At least this method of updating does not cause keyboard layout reset.

Updating the system exclusively through terminal like this seems like an unintended way to update the system when the OS ship with the Octopi GUI package manager that even boots with its own tray icon in the panel.

Well, we will stop the delivery of Octopi, as it has already happened with Pamac.
There are always problems with graphical user interface (GUI) installations.
This GUI should be used only for searching.

You can of course continue to use it, but if you have problems with it, please contact the appropriate developer.

Thank you for your support and the provided information.

I can live with using the terminal for system upgrades (even if I still prefer GUI).

If there is anyone here that has and want to provide additional information with further specificity how to avoid keyboard layout setting reset while still having a GUI for updates, or information about why and how to trigger the OS to find connected audio input devices, that would still be appreciated.

Check this ArchWiki article:

Advanced Linux Sound Architecture/Troubleshooting - ArchWiki

No microphone input

In alsamixer, make sure that all the volume levels are up under recording, and that CAPTURE is toggled active on the microphone (e.g. Mic, Internal Mic) and/or on Capture (in alsamixer, select these items and press space). Try making positive Mic Boost and raising Capture and Digital levels higher; this may make static or distortion, but then you can adjust them back down once you are hearing something when you record

As the pulseaudio wrapper is shown as “default” in alsamixer, you may have to press F6 to select your actual soundcard first. You may also need to enable and increase the volume of Line-in in the Playback section.

To test the microphone, run these commands (see arecord(1) for further information):

$ arecord --duration=5 --format=dat test-mic.wav $ aplay test-mic.wav

Alternatively, you can run this command:

$ arecord -vv --format=dat /dev/null

alongside alsamixer to easily identify channel which you should select and unmute.

To test a particular device, use the --device parameter followed by the hardware PCM name in the form hw:C,D for card C device D, or plughw:C,D for plugged hardware. For instance:

$ arecord -vvv --format=dat --device=plughw:0,0 /dev/null

If all fails, you may want to eliminate hardware failure by testing the microphone with a different device.

For at least some computers, muting a microphone (MM) simply means its input does not go immediately to the speakers. It still receives input.

Many Dell laptops need “-dmic” to be appended to the model kernel module parameter:

options snd-hda-intel model=*dell-m6*-dmic

Since you have a Dell laptop, that last section seems like it may be especially relevant.

Check if you can resolve the issue by adding options=grp:shift_caps_toggle to ~/.config/lxqt/session.conf like the person in the last comment of this thread: lxqt key to change keyboard layout won't save / Newbie Corner / Arch Linux Forums


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.